• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

L'assieme mi salva il componente sbagliato

New Rider

Utente Standard
Professione: Impiegato Tecnico
Software: SolidWorks17s.p05 +Solidworks2018s.p02+DrafthSight
Regione: Veneto
#1
Buonasera,

ho utilizzato il toolbox per importarmi una corona circola da 160 denti di un certo diametro esterno.
Su questa corona ho eseguito delle lavorazioni ( fori ) salvandola su una parte diversa ( file nuovo ).
Ora questa corona da me modificata la porto all'interno del mio assieme l'accoppio con le altre parti e fin qui nessun problema.
Salvo l'assieme e chiudo. Riapro l'assieme e invece di apparire la corona da me salvata in precendenza trovo la corona della toolbox!!!
Come mai.. Sbaglio qualche legame??

Saluti.
 

luca1669

Utente Standard
Professione: progettista
Software: solidworks,solid edge, pro/e 2000i-wf4
Regione: emilia romagna
#2
Non sono espertissimo di toolbox, ma dalla mia esperienza se ti vuoi distaccare completamente dalla libreria devi creare nella parte salvata una nuova configurazione e cancellare quella salvata di default con la toolbox. Rientra nell'assieme e sostituisci la parte standard con quella da te salvata.
 

New Rider

Utente Standard
Professione: Impiegato Tecnico
Software: SolidWorks17s.p05 +Solidworks2018s.p02+DrafthSight
Regione: Veneto
#3
Proverò cosi vedremo che succederà... Grazie
 

New Rider

Utente Standard
Professione: Impiegato Tecnico
Software: SolidWorks17s.p05 +Solidworks2018s.p02+DrafthSight
Regione: Veneto
#4
Ciao a tutti...
Quindi per risolvere il problema ho fatto come dici tu Luca1669.
Ho creato una nuova configurazione rinominata Corona Forata diam. xx.
Ho eliminato le altre configurazioni compresa quella di default.
Da li in poi il problema non si è più presentato.

Grazie. Buona Domenica.
 

Mike1967

Moderatore CAM
Staff Forum
Professione: Pane e lamiera
Software: Solidworks 2016 sp 5 X 2017 sp 0
Regione: Lombardia, Varese-Canton Ticino, Svizzera
#5
Ciao a tutti...
Quindi per risolvere il problema ho fatto come dici tu Luca1669.
Ho creato una nuova configurazione rinominata Corona Forata diam. xx.
Ho eliminato le altre configurazioni compresa quella di default.
Da li in poi il problema non si è più presentato.

Grazie. Buona Domenica.
Il consiglio spassionato che ti do è quello di slegare quel componente dal toolbox.
Per fare ciò devi salvare il componente come copia (credo tu l' abbia già fatto) e
togliere la proprietà di toolbox con l' applicazione sldsetdocprop.exe contenuta in :

X:\Program Files\SOLIDWORKS Corp\SOLIDWORKS\Toolbox\data utilities

A quel punto quando riaprirai l' assieme non vedrai più il componente come elemento toolbox ma
come un semplice parte.