ipart e vincoli

atonucci

Utente Junior
Professione: Insegnante/Progettista
Software: Proe, SE V19, solid works, Inventor 2009
Regione: Marche
#1
Salve a tutti

lavoro con inventor 2015 da qualche mese e sto utilizzando le ipart. Vi chiedo come mai quando trasformo una part in ipart e sostituisco il generico con un elemento della famiglia perdo tutti i vincoli del componente.

Saluti

Alberto
 

eugenesis

Utente Standard
Professione: perito meccanico
Software: Inventor-Autocad
Regione: Emilia-Romagna
#2
il file della parte generica intendi la Factory ??
Se parli di assieme , non si inserisce la Factory , ma direttamente un member , a quel punto non perdi niente ,
se vuoi puoi gestire anche gli iMates .
Se hai già inserito la parte normale nell' assieme e poi la trasformi in iPart , e dopo gli fai calcolare un altro member ,
allora operi una sostituzione di files vera e propria.
 

atonucci

Utente Junior
Professione: Insegnante/Progettista
Software: Proe, SE V19, solid works, Inventor 2009
Regione: Marche
#3
Ciao Eugenesis

quello che intendevo è la seconda parte della tua risposta.
Ho fatto un assieme e alcune parti le ho trasformate in ipart ma quando sostituisco il fine iniziale con un elemento della famiglia appartenente allo stesso file che nel frattempo l'ho trasformato in ipart perdo i vincoli che legano la parte sostituita con gli altri elementi dell'assieme.
come posso evitare questo?
 

eugenesis

Utente Standard
Professione: perito meccanico
Software: Inventor-Autocad
Regione: Emilia-Romagna
#4
infatti come dicevo io , operi una sostituzione di files e quindi perdi i vincoli che si ancorano agli ID delle facce selezionate !
A questo punto opera con gli iMates e tutto resta aggangiato , altrimenti cambia il tuo flusso di lavoro .., nell' assieme
inserisci solamente i members