Impostare un equazione con Solidworks 2013

JJLegends

Utente Junior
Professione: Freelance Prototyper CAD 3D Design
Software: Solidworks 2013 Premium - SolidEdge V20
Regione: Veneto
#1
Salve a tutti , volevo esporre il mio problema alla community , praticamente ho questa flangia che vedete negli screenshot , la quale ha tre quote per definire l'equazione. La definizione dell' equazione deve fare in modo che i quattro fori sul pezzo , mantengano una posizione centrale rispetto ai bordi esterni del mozzo-tozzo centrale e della parte esterna della flangia, quando noi andremo a variare il diametro esterno del nostro disegno.


flange.jpg


L'equazione e' gia' bella e che pronta e' gia l'ho discussa in aula.

( flange_OD - hub_OD )/2 +hub_OD =valore variabile distanza 4 fori

Fin qui tutto bene ... adesso la si inserisce in solidworks , metto 2 screenshot senno nn si vede per intero ....


equazioni2.jpg equazioni3.jpg

come vedete non riesco poi a inserire il valore dopo il + , e qui non capisco il motivo !! Mi manca la sintassi esatta.
non era questione di variabile globale.....penso

equazioni3_vrglb.jpg


anche reimpostando l'errore precedente sull'equazione il risultato non cambia....

no_plus2.jpg

se qualcuno ha qualche dritta.

:4460: :4460: :4460:
 

marcof

Utente Senior
Professione: appiccico francobolli con lo schiacciasassi
Software: solidworks 2013 SP 5.0
Regione: Modena
#2
Dalle schermate mi pare che manchino le parentesi, ma non credo questo c'entri, se non per il fatto che il risultato dell'equazione poi non è quello corretto
Non sono riuscito a capire dove stia il problema, nel senso che a me le "funzioni funzionano" :tongue: e non riesco a creare la situazione in cui non mi lascia inserire una quota. Per capire in questi casi dove si sbaglia serve o il file originale o un video nel quale si vede esattamente dove cai a cliccare. Siccome parli di equazione preparata, da inserire in solidworks, non ho ben capito se tu digiti a mano i nomi da inserire nell'equazione; nel caso ti ricordo che basta fare click sulle quote del modello e aggiungere solamente parentesi, operatori ecc. Forse scrivendo i nomi delle quote hai sbagliato qualcosa.
 

JJLegends

Utente Junior
Professione: Freelance Prototyper CAD 3D Design
Software: Solidworks 2013 Premium - SolidEdge V20
Regione: Veneto
#3
i nomi equazioni li clicco dalle quote

non riesco a definire il + dopo l'equazione iniziale nn so come mai .. pensavo alla sintassi ma mi dici di no
 

JJLegends

Utente Junior
Professione: Freelance Prototyper CAD 3D Design
Software: Solidworks 2013 Premium - SolidEdge V20
Regione: Veneto
#4
Ah ok , tutto bene ho risolto , il problema era come avevo intuito prima nella sintassi dell'equazione , la quale andava scritta lasciando uno spazio tra il + sia prima che dopo la sua scrittura. Ecco come si andra' a presentare ....

Equazione_OK.jpg

il risultato e' quello sperato .....
Prova.jpg


:36_1_11: :36_1_11:
 

presariog

Utente Junior
Professione: doc.
Software: Solidworks 2017
Regione: lombardia
#5
Sono novello ma ho capito che l'equazione non la inserisci in quella finestra, devi creare una quota con l'equazione che hai descritto nello schizzo della parte poi in quella finestra puoi solo richiamare variabili che puoi descrivere con del testo. Per variabili intendo le quote di un determinato schizzo con la giusta sintassi oppure, aprire prima lo schizzo dove c'è la quota che ti interessa poi aprire la finestra cliccare dove vuoi venga inserita la variabile della quota, tornare nelle schizzo e cliccare sulla quota che ti interessa.
Fammi sapere.
 

JJLegends

Utente Junior
Professione: Freelance Prototyper CAD 3D Design
Software: Solidworks 2013 Premium - SolidEdge V20
Regione: Veneto
#6
beh e' nella finestra che scrivi l'equazione e nella stessa ti si presentano i vari valori delle quote ...e ke nn mi ricordo