Icona aggiorna sempre attiva

Professione: ingegnerizzatore prodotto-automotive (dream cars)
Software: SW 2009 - Pro/E WF4 - Catia V5 R20 - Matlab - Ansys - TC7 - VPM
Regione: Veneto - Austin (TX)
#1
Ciao ragazzi, ho un problema che mi affligge.
Apro un Product e mi viene fuori l'icona Aggiorna, aggiorno e sparisce l'icona, salvo il Product.
Quando lo riapro mi torna fuori l'icona. Non riesco a capire il perchè:confused::confused:

Ho provato a vedere prima di aggiornare se c'erano vincoli con l'iconcina aggiorna ma niente.
Il Product è composto da una cinquantina di componenti. Ho fatto una prova. Ho cancellato circa una quarantina di componenti, l'ho salvato e alla riapertura mi dice ancora di aggiornarlo:confused:
 

silente

Utente Standard
Professione: Uff. tecnico
Software: CREO 1.0
Regione: Novara
#2
ciao stef...

sei sicuro che i componenti siano a loro volta aggiornati?
a me a volte capita quando ho una parte o un sotto assieme non aggiornato.
io ho pero impostato su aggiorna manuale.
se vai in strumenti->opzioni->mechanical design->assembly design->generale..
prova a impostare:
aggiorna->Automatico
profondità di propagazione->tutti i livelli
calcolo esatto.... ->automatico

salutoni
silente
 
Professione: ingegnerizzatore prodotto-automotive (dream cars)
Software: SW 2009 - Pro/E WF4 - Catia V5 R20 - Matlab - Ansys - TC7 - VPM
Regione: Veneto - Austin (TX)
#3
ciao stef...

sei sicuro che i componenti siano a loro volta aggiornati?
a me a volte capita quando ho una parte o un sotto assieme non aggiornato.
io ho pero impostato su aggiorna manuale.
se vai in strumenti->opzioni->mechanical design->assembly design->generale..
prova a impostare:
aggiorna->Automatico
profondità di propagazione->tutti i livelli
calcolo esatto.... ->automatico

salutoni
silente
Io ho queste impostazioni in Assembly Design. Tieni conto che apro gli assiemi con cache e poi passo in Design Mode.
Cosa intendi per "i componenti siano a loro volta aggiornati?" Se magari ho salvato alcune parti senza salvare?!?
Ma anche se fosse, quando apro e aggiorno dovrebbe aggiornare anche i componenti e quando salvo il Product salvare anche i componenti singoli. No:confused:
grazie:)
 

Allegati

silente

Utente Standard
Professione: Uff. tecnico
Software: CREO 1.0
Regione: Novara
#4
ti faccio un esempio.

io ho un assieme di una "cartuccia" che va inserito nei nostri pezzi.

la cartuccia è formata da parti.
un mio collega ha fatto un apiccola modifica (aggiunto un raggio) a uno di questi parti.
questo non inficiava in alcun modo l'assieme sel componenete (vincoli battute e qunt'altro).... ma purtroppo il mio collega non ha aggiornato l'assieme

quando aprivo i complessivi i quali contenevano la cartuccia non aggiornata io davo l'aggiorna, ma in realtà catia non aggiornave l'assieme della cartuccia.

ho dovuto aprire il complessivo della cartuiccia aggiornare e il problema si è risolto.

l'unica differenza che ho con il tuo problema e che a me non spariscono i componeneti..

salutoni
silente
 
Professione: ingegnerizzatore prodotto-automotive (dream cars)
Software: SW 2009 - Pro/E WF4 - Catia V5 R20 - Matlab - Ansys - TC7 - VPM
Regione: Veneto - Austin (TX)
#5
ti faccio un esempio.

io ho un assieme di una "cartuccia" che va inserito nei nostri pezzi.

la cartuccia è formata da parti.
un mio collega ha fatto un apiccola modifica (aggiunto un raggio) a uno di questi parti.
questo non inficiava in alcun modo l'assieme sel componenete (vincoli battute e qunt'altro).... ma purtroppo il mio collega non ha aggiornato l'assieme

quando aprivo i complessivi i quali contenevano la cartuccia non aggiornata io davo l'aggiorna, ma in realtà catia non aggiornave l'assieme della cartuccia.

ho dovuto aprire il complessivo della cartuiccia aggiornare e il problema si è risolto.

l'unica differenza che ho con il tuo problema e che a me non spariscono i componeneti..

salutoni
silente
Esempio chiaro. Pensavo che quando apri i complessivi contenenti la cartuccia e aggiorni, Catia aggiornasse anche l'assieme della cartuccia. E una volta che salvi l'assieme "grande" ti salva anche l'assieme della cartuccia.
 

silente

Utente Standard
Professione: Uff. tecnico
Software: CREO 1.0
Regione: Novara
#6
ora bisogna capire se è possibile far aggiornare "tutto"..
confesso la mia ignoranza.... non so se si può!

silente
 
Professione: ingegnerizzatore prodotto-automotive (dream cars)
Software: SW 2009 - Pro/E WF4 - Catia V5 R20 - Matlab - Ansys - TC7 - VPM
Regione: Veneto - Austin (TX)
#7
ora bisogna capire se è possibile far aggiornare "tutto"..
confesso la mia ignoranza.... non so se si può!

silente
Secondo la mia piccola esperienza se sulle opzione si seleziona "Aggiorna profondità a tutti i livelli", Catia aggiorna tutto compersi Part e Product dell'assieme generale. Inoltre penso che al salvataggio, Catia salvi tutto.
Sentiamo anche gli altri utenti cosa dicono.
ciao silente e thanks:)
 

MAXUS

Utente Junior
Professione: Meccanica
Software: V4-V5 / SE v14
Regione: F.V.G.
#8
Secondo la mia piccola esperienza se sulle opzione si seleziona "Aggiorna profondità a tutti i livelli", Catia aggiorna tutto compersi Part e Product dell'assieme generale. Inoltre penso che al salvataggio, Catia salvi tutto.
Sentiamo anche gli altri utenti cosa dicono.
ciao silente e thanks:)
Ciao Stef,

penso che tu abbia i settaggi a posto. Quoto Silente per tutti i suggerimenti.
Mi vengono in mente 2 cose che ogni tanto capitano anche a noi, non so se é il tuo caso:
1- ci puó essere dentro ad un part una qualche geometria non allacciata al solido (di nessun utilizzo) dimenticata e non cancellata oppure della geometria associativa con altre parti nell'assieme.
2- ci possono essere dei permessi su alcuni files dell'assieme che impediscono il salvataggio di tutto, ma in tal caso dovrebbe avvertirti di questo quando salvi. (ogni tanto alla sera spazzola il direttorio cache e rilancia l'assieme per aggiornare i cgr.
3- se lavori con la cache e geometria associativa (o dimenticata associativa) ma non ho mai verificato il caso:confused:.

Forza con altri consigli!!!!
CIAO :)
 
Professione: ingegnerizzatore prodotto-automotive (dream cars)
Software: SW 2009 - Pro/E WF4 - Catia V5 R20 - Matlab - Ansys - TC7 - VPM
Regione: Veneto - Austin (TX)
#9
Ciao Stef,

penso che tu abbia i settaggi a posto. Quoto Silente per tutti i suggerimenti.
Mi vengono in mente 2 cose che ogni tanto capitano anche a noi, non so se é il tuo caso:
1- ci puó essere dentro ad un part una qualche geometria non allacciata al solido (di nessun utilizzo) dimenticata e non cancellata oppure della geometria associativa con altre parti nell'assieme.
2- ci possono essere dei permessi su alcuni files dell'assieme che impediscono il salvataggio di tutto, ma in tal caso dovrebbe avvertirti di questo quando salvi. (ogni tanto alla sera spazzola il direttorio cache e rilancia l'assieme per aggiornare i cgr.
3- se lavori con la cache e geometria associativa (o dimenticata associativa) ma non ho mai verificato il caso:confused:.

Forza con altri consigli!!!!
CIAO :)
Ciao Maxus, grazie per le idee.
Riguardo al punto 1 alla geometria associativa, ho notato che spesso in Catia che se nel Product modifichi un Part e prendi come riferimento geometrico o di quota un altro Part Catia ti chiede se vuoi mantenere il collegamento con l'oggetto selezionato. Se clicco NO e salvo l'assieme. Alla successiva riapertura ho l'icona aggiorna attiva; questo ad ogni riapertura dell'assieme.

Ma se ti dico NO è no. Non dovrebbe chiedermi l'aggiornamento:confused:
 

Allegati

Professione: ingegnerizzatore prodotto-automotive (dream cars)
Software: SW 2009 - Pro/E WF4 - Catia V5 R20 - Matlab - Ansys - TC7 - VPM
Regione: Veneto - Austin (TX)
#10
Ciao Stef,

penso che tu abbia i settaggi a posto. Quoto Silente per tutti i suggerimenti.
Mi vengono in mente 2 cose che ogni tanto capitano anche a noi, non so se é il tuo caso:
1- ci puó essere dentro ad un part una qualche geometria non allacciata al solido (di nessun utilizzo) dimenticata e non cancellata oppure della geometria associativa con altre parti nell'assieme.
2- ci possono essere dei permessi su alcuni files dell'assieme che impediscono il salvataggio di tutto, ma in tal caso dovrebbe avvertirti di questo quando salvi. (ogni tanto alla sera spazzola il direttorio cache e rilancia l'assieme per aggiornare i cgr.
3- se lavori con la cache e geometria associativa (o dimenticata associativa) ma non ho mai verificato il caso:confused:.

Forza con altri consigli!!!!
CIAO :)
Ho trovato la soluzione al mio problema, dell'incona Aggiorna sempre attiva.
Se aprite un Product, aggiornate e salvate e alla successiva riapertura del Product compare di nuovo l'icona Aggiorna dovete:
- andare sul menu Strumenti > Aggiorna...
- appare il menu Analisi vincoli (che vi dice quale vincolo o componente non è aggiornato)
- mettete a posto il file, aggiornate, salvate.

In questo modo l'icona aggiorna non dovrebbe più comparire:)
 

Allegati