• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

Gestione "medium" assembly

stef_design

Utente Senior
Professione: ingegnerizzatore prodotto-automotive (dream cars)
Software: SW 2009 - Pro/E WF4 - Catia V5 R20 - Matlab - Ansys - TC7 - VPM
Regione: Veneto - Austin (TX)
#1
Ciao ragazzi,
ho un pc HP XW4400 con le seguenti caratteristiche:
- Intel Core 2Duo 6400 (2.13GHz)
- Ram 2Gb
- Nvidia Quadro FX 1500 (256Mb)
- WinXP sp2 Pro

- Catia V5 r18 sp3

1- carico l'assieme con cache attivata (circa 250 componenti);
2- una volta caricato l'assieme, "tento" di aggiornarlo;
3- al 30% dell'aggiornamento, Catia si chiude senza alcuna avvertenza;

Come potete vedere (allego uno screenshot fatto pochi secondi prima del crash) la memoria allocata non raggiunge mai il limite da me impostato (5 Gb). Infatti Catia si chiude a poco più di 2Gb.

Qualche suggerimento per gestire assiemi di circa 250-300 componenti:confused:

P.S. dimenticavo, il problema succede su tutte le nostre macchine.
 

Allegati

Ultima modifica:

andrea71

Utente Standard
Professione: ingegnere
Software: Catia v5, Solidworks, I-deas, MSC...ed altri
Regione: FVG
#2
Sa più di assieme corrotto che problema di gestione di assiemi.
Proverei:
1) Catdua
2) Apertura condizionale (la gestisci da Opzioni): apri solo l'assy senza il caricamento di alcun componente, e man mano carichi un po' di componenti alla volta. E speri di trovare quello che manda in crash Catia
 

stef_design

Utente Senior
Professione: ingegnerizzatore prodotto-automotive (dream cars)
Software: SW 2009 - Pro/E WF4 - Catia V5 R20 - Matlab - Ansys - TC7 - VPM
Regione: Veneto - Austin (TX)
#3
2) Apertura condizionale (la gestisci da Opzioni): apri solo l'assy senza il caricamento di alcun componente, e man mano carichi un po' di componenti alla volta. E speri di trovare quello che manda in crash Catia
Interessante la soluzione 2. Ma dove la trovo, perchè non l'ho mai fatto:confused:
grazie:)
 

andrea71

Utente Standard
Professione: ingegnere
Software: Catia v5, Solidworks, I-deas, MSC...ed altri
Regione: FVG
#4
Prova:
- Generale -> Carica documenti referenziati NO
- Infrastructure -> Visualizzazione di prodotto -> Non attivare le forme predefinite all'apertura
 
Ultima modifica:

falonef

Moderatore CATIA V5
Staff Forum
Professione: PLM Support Expert (Consumer Goods)
Software: CATIA V5 / PARTsolutions / QA-Report / Q-Checker / Type3toCatia / Agile-PLM / Windows 10
Regione: Svizzera
#5
aggungo che per accellerare caricherei dapprima la prima metà del tuo assieme cosi sai subito se il tuo problema é con una componente caricata. Se si fai di nuovo un tentativo con la metà della mmetà ecc.

Se nel primo tentativo non hai il problema allora carica la seconda metà e analizzi come descrito prima.
 

stef_design

Utente Senior
Professione: ingegnerizzatore prodotto-automotive (dream cars)
Software: SW 2009 - Pro/E WF4 - Catia V5 R20 - Matlab - Ansys - TC7 - VPM
Regione: Veneto - Austin (TX)
#6
aggungo che per accellerare caricherei dapprima la prima metà del tuo assieme cosi sai subito se il tuo problema é con una componente caricata. Se si fai di nuovo un tentativo con la metà della mmetà ecc.

Se nel primo tentativo non hai il problema allora carica la seconda metà e analizzi come descrito prima.
Grazie, adesso provo e poi vi aggiorno. Ieri sera avevo provato a fare il CATDua di tutto l'assieme (da Desk), ma ovviamente per farlo deve caricare l'assieme e arrivato a metà esce. Allora ho provato a fare il CATDua di ogni singolo sotto-assieme e funziona. Ovviamente segnala degli errori, ma non è facile capire la tipologia dell'errore (anche leggendo il file LOG che genera Catia).

Adesso provo caricando l'assieme e aggiornandolo "a blocchi".
ciao e grazie:)

Cursiosità: voi con che tipologia di assiemi lavorate?!? Anche grossi (500-800parti)?!?
E la messa in tavola avviene senza problemi o dovete Approssimare le viste?!?
 

stef_design

Utente Senior
Professione: ingegnerizzatore prodotto-automotive (dream cars)
Software: SW 2009 - Pro/E WF4 - Catia V5 R20 - Matlab - Ansys - TC7 - VPM
Regione: Veneto - Austin (TX)
#7
aggungo che per accellerare caricherei dapprima la prima metà del tuo assieme cosi sai subito se il tuo problema é con una componente caricata. Se si fai di nuovo un tentativo con la metà della mmetà ecc.

Se nel primo tentativo non hai il problema allora carica la seconda metà e analizzi come descrito prima.
Ciao,
1) per prima cosa ho settato le opzioni di catia con:
Generale -> Carica documenti referenziati NO e Infrastructure -> Visualizzazione di prodotto -> Non attivare le forme predefinite all'apertura.
2) Poi ho aperto l'assieme e caricato uno a uno i sotto-assiemi.
3) Una volta caricato il primo sotto-assieme, passavo in modalità Progettazione e Attivavo i Nodi Terminali.
4) Una volta fatto questo guardavo se compariva l'icona Aggiorna.

Sono riuscito a caricare tutti i sotto-assiemi fintanto che la RAM mi ha abbandonato. A quel punto Catia si chiude senza nessun messaggio d'errore.

Non so cosa fare:confused::confused:

Dalla prima immagine si vede che la cache è settata a 2000mb e con il segno di spunta su "Verifica Ampiezza MAssima", può dipendere da questo?!? 2000mb dovrebbe corrispondere ai 2Gb della mia RAM
 
Ultima modifica:

torniaccio

Utente Standard
Professione: Tra un'interruzione e l'altra modello qualcosa, ma cosa?
Software: CatiaV5 ProE AutoCAD Inventor 2013 64bit
Regione: Lazio
#8
Ciao stef, è un pò che nn partecipo (mancanza di tempo) ma ti leggo sempre con piacere.

Prima di chiamare il 118 il 112 la guardia nazionale e i ghost buster, prova a:

- svuotare (cancellare il contenuto) della cartella in cui appoggi i file di cash di catia.

- lasciar gestire al sistema la ram e il file di paging

- fare il catduav5 non dal desk (a volte nn funziona come dovrebbe) ma da strumenti > utilità; se guardi nel forum ho fatto una specie di tutorial al riguardo.

--- remota possbilità ma consideriamola---- se hai attivato in strumenti>opzioni>visualizza>prestazioni> ...openGL e openGL shader , disattivalo.

Un problema simile al tuo, se non lo stesso, mi è capitato poche settimane fa, ed il problema era generato da un caso di omonimia da parte di alcuni componenti di un sotto assieme, risolta l'incongruenza, risolto il problema.


Ciao e facci sapere. ;)
 

stef_design

Utente Senior
Professione: ingegnerizzatore prodotto-automotive (dream cars)
Software: SW 2009 - Pro/E WF4 - Catia V5 R20 - Matlab - Ansys - TC7 - VPM
Regione: Veneto - Austin (TX)
#9
Ciao stef, è un pò che nn partecipo (mancanza di tempo) ma ti leggo sempre con piacere.

Prima di chiamare il 118 il 112 la guardia nazionale e i ghost buster, prova a:

- svuotare (cancellare il contenuto) della cartella in cui appoggi i file di cash di catia.

- lasciar gestire al sistema la ram e il file di paging
- fare il catduav5 non dal desk (a volte nn funziona come dovrebbe) ma da strumenti > utilità; se guardi nel forum ho fatto una specie di tutorial al riguardo.

--- remota possbilità ma consideriamola---- se hai attivato in strumenti>opzioni>visualizza>prestazioni> ...openGL e openGL shader , disattivalo.
Un problema simile al tuo, se non lo stesso, mi è capitato poche settimane fa, ed il problema era generato da un caso di omonimia da parte di alcuni componenti di un sotto assieme, risolta l'incongruenza, risolto il problema.


Ciao e facci sapere. ;)
Ciao, ho fatto i passaggi in grassetto.

Ho aperto l'assieme con cache attivata. Ho caricato SOLO i sotto-assiemi più pesanti e questa volta è venuta fuori una finestra di errore (VEDI IMMAGINE).
Ho cliccato su OK e Catia si è chiuso.:mad:
 

Allegati

torniaccio

Utente Standard
Professione: Tra un'interruzione e l'altra modello qualcosa, ma cosa?
Software: CatiaV5 ProE AutoCAD Inventor 2013 64bit
Regione: Lazio
#10
Perche nn hai fatto il catduav5 ??
 

torniaccio

Utente Standard
Professione: Tra un'interruzione e l'altra modello qualcosa, ma cosa?
Software: CatiaV5 ProE AutoCAD Inventor 2013 64bit
Regione: Lazio
#12
si, se hai problemi nell'esecuzione fatti sentire.
 

torniaccio

Utente Standard
Professione: Tra un'interruzione e l'altra modello qualcosa, ma cosa?
Software: CatiaV5 ProE AutoCAD Inventor 2013 64bit
Regione: Lazio
#14
il messaggio testualmente dice che sei a corto di memoria.
dice pure che gli manca circa 1 mega per completare il suo lavoro.

sei sicuro di avere abbastanza memoria?
puoi provare a fare catduav una porzione di file alla volta? che so in 2 parti?
ora vedo come ho impostato la mia memoria e ti faccio sapere.
 

torniaccio

Utente Standard
Professione: Tra un'interruzione e l'altra modello qualcosa, ma cosa?
Software: CatiaV5 ProE AutoCAD Inventor 2013 64bit
Regione: Lazio
#15
con un s.o. tipo winXp io ho fatto così:
tasto dx su risorse computer
>proprietà>avanzate>prestazioni (intanto qui gli ho impostato di spingere al max le prestazioni , chi se ne frega della grafica e delle carinerie di win...)>impostazioni>avanzate>memoria virtuale>cambia>spunta dimensioni gestite dal sistema.

Il Pc dove lavoro ha impotato in automatico tra i 4 ei 5 Gb. (si vabbè è un quad core con 4gb di ram .....)

prova a smanettare li. fammi sapere.
 

stef_design

Utente Senior
Professione: ingegnerizzatore prodotto-automotive (dream cars)
Software: SW 2009 - Pro/E WF4 - Catia V5 R20 - Matlab - Ansys - TC7 - VPM
Regione: Veneto - Austin (TX)
#16
il messaggio testualmente dice che sei a corto di memoria.
dice pure che gli manca circa 1 mega per completare il suo lavoro.

sei sicuro di avere abbastanza memoria?
puoi provare a fare catduav una porzione di file alla volta? che so in 2 parti?
ora vedo come ho impostato la mia memoria e ti faccio sapere.
Per memoria intendi RAM o cosa?!? perchè ho 2Gb di RAM.
Non ho mica il computer del "nonno":D
 

torniaccio

Utente Standard
Professione: Tra un'interruzione e l'altra modello qualcosa, ma cosa?
Software: CatiaV5 ProE AutoCAD Inventor 2013 64bit
Regione: Lazio
#17
intendo memoria complessiva: RAM (i tuoi 2gb hardware) e Virtuale (di paging, quella che il pc utilizza scrivendo sull'hdd) prova a smanettare lì dove ti ho detto.
 

stef_design

Utente Senior
Professione: ingegnerizzatore prodotto-automotive (dream cars)
Software: SW 2009 - Pro/E WF4 - Catia V5 R20 - Matlab - Ansys - TC7 - VPM
Regione: Veneto - Austin (TX)
#18
intendo memoria complessiva: RAM (i tuoi 2gb hardware) e Virtuale (di paging, quella che il pc utilizza scrivendo sull'hdd) prova a smanettare lì dove ti ho detto.
Mi fai un piacere ENORME.
Puoi mettere due screen-shots:
- uno con le impostazioni che hai messo sulla memoria virtuale di Win.
( Risorse del computer > Proprietà > Avanzate > Impostazioni > Avanzate > Memoria Virtuale )
- uno con le tue impostazioni della Cache di Catia ( Strumenti > Opzioni >Infrastructure > Gestione della cache )

Grazie mille:)