Generatore telaio non aggiorna profili

GianniM

Utente Standard
Professione: studente
Software: bo
Regione: italia
#1
Ciauz! Questa sarebbe da strapparsi tutti i capelli, ma tantè!
Ho creato un telaio tramite schizzo (generatore telai), poi ho messo i profili in degli assiemi saldati tramite il comando "demote".
Inizialmente funzionava tutto bene, ma ora, dettagliando sempre più il progetto, se faccio una modifica allo schizzo i profili non si aggiornano più!
Bella sfortuna:mad: perchè adesso come faccio ad aggiornare il tutto!

Mi sa che mi tocca rifare da capo! Certo che è un bel limite se inventor si inceppa in questi aspetti
 

Tarkus

Utente Senior
Professione: Progettista,Disegnatore
Software: Autocad Mechanical,Inventor 2017,HyperMill2012
Regione: Toscana
#2
Ciauz! Questa sarebbe da strapparsi tutti i capelli, ma tantè!
Ho creato un telaio tramite schizzo (generatore telai), poi ho messo i profili in degli assiemi saldati tramite il comando "demote".
Inizialmente funzionava tutto bene, ma ora, dettagliando sempre più il progetto, se faccio una modifica allo schizzo i profili non si aggiornano più!
Bella sfortuna:mad: perchè adesso come faccio ad aggiornare il tutto!

Mi sa che mi tocca rifare da capo! Certo che è un bel limite se inventor si inceppa in questi aspetti
Tranquillo, lo fa lo fa.
Purtroppo e' un difetto che anch'io ho riscontrato da almeno 3 releases.
Però si risolve quasi sempre in assieme, mettendo l'adattività allo schizzo e riaggiornando.
Magari dopo qualche altra modifica si riblocca, allora si toglie l'adattività.
Sembra quasi che abbia bisogno di una "scrollata" ogni tanto.:biggrin:
 

GianniM

Utente Standard
Professione: studente
Software: bo
Regione: italia
#3
Alla fine si è aggiornato, con questa semplice e logica procedura

Aperto assiemi a caso, premuto su “aggiorna”, chiuso il programma.
Riavviato il pc
Aperto inventor, aperto assiemi a caso, premuto su “aggiorna”, chiuso il programma.
Riavviato il pc
Aperto inventor, aperto assiemi a caso, premuto su “aggiorna”


E per non so quale motivo, alla fine si è aggiornato.
 

Ilario

Utente Senior
Professione: Disegnatore CAD
Software: Inventor, AutoCAD
Regione: E. Romagna
#4
Io dico la mia, anche se probabilmente impopolare, visto che non è la prima volta che sento di questa cosa e che la utilizzate in diversi:
a mio avviso, anche se simili, a ogni telaio corrisponde il proprio schizzo e la propria cartella con i propri profili nel proprio assieme di Generatore Telaio. Non toglierei mai i profili dall'interno con il comando "promuovi" e "abbassa livello".

Infatti ho sempre pensato che se potesse anche funzionare a tratti, poi mi sarei trovato ad avere problemi di questo tipo.
Sembra di fare "prima", ma poi alla fine non mi pare così funzionale la cosa IMHO.
 

Catafratto

Utente Standard
Professione: Disegnatore/progettista
Software: Inventor 2016
Regione: Veneto
#5
Ilario, io la penso come te e mai ho fatto promozioni o abbassamenti di livello: tuttavia, a onor del vero, ciò non mi ha salvato dai problemi di GianniM :wink:
 

Ilario

Utente Senior
Professione: Disegnatore CAD
Software: Inventor, AutoCAD
Regione: E. Romagna
#6
Mai successo che non mi aggiornasse i profili dopo una modifica allo scheletro.
Altri tipi di problemi, tipo sulle iProperties personalizzate che non si aggiornano o perdono dei parametri si, ma aggionamenti dopo modifiche mai.
 

Catafratto

Utente Standard
Professione: Disegnatore/progettista
Software: Inventor 2016
Regione: Veneto
#7
Mi è successo solo un paio di volte, e comunque è bastato chiudere l'assieme e poi riaprirlo: comunque il problema c'è stato... vedremo con la 2015 :rolleyes:
 

GianniM

Utente Standard
Professione: studente
Software: bo
Regione: italia
#8
Bè Ilario, anche io farei volentieri a meno di quei comandi. Ma se dentro un assieme ci devo mettere un saldato, saldato di cui voglio poi fare la messa in tavola separatamente dal resto, in quale altro modo posso fare?
 

Ilario

Utente Senior
Professione: Disegnatore CAD
Software: Inventor, AutoCAD
Regione: E. Romagna
#9
- Assieme Principale (Codificato)
-----|-> Assieme Saldato (Codificato, che sarà il tuo riferimento da intavolare come saldato)
-----------|-> Scheletro.ipt (Struttura distinta componenti "nascosta", sarà il tuo "pilota" da modificare)
-----------|-> Assieme generato dal generatore telaio (di default è già un'assieme nascosto quindi non devi promuovere niente
-----------|-> Altri pezzi vari se necessari da vincolare al telaio

In tavola metti l' Assieme Saldato e la pallinatura funziona normalmente.
 

Catafratto

Utente Standard
Professione: Disegnatore/progettista
Software: Inventor 2016
Regione: Veneto
#10
Quello è un'altro discorso: bisogna partire con già in testa come si andranno a dividere gli assiemi. Lo schizzo, messo dentro una parte che farà da "scheletro", può comunque essere inserito dentro più assiemi e guidare così più di un telaio; e ad ogni tavola può corrispondere un assieme diverso. Se poi vuoi mettere in tavola un particolare di un assieme ricorda che puoi anche creare delle configurazioni di vista e "nascondere" ciò che in tavola non vuoi che si veda.
Spero di essere stato chiaro...

Ecco, mi sono sovrapposto a Ilario: la sua spiegazione è più chiara :redface:
 

Tarkus

Utente Senior
Professione: Progettista,Disegnatore
Software: Autocad Mechanical,Inventor 2017,HyperMill2012
Regione: Toscana
#11
Resta il fatto che a qualcuno (me compreso) non aggiorna sempre e a qualcuno non succede mai.
E' strana questa diversità.:confused:
 

GianniM

Utente Standard
Professione: studente
Software: bo
Regione: italia
#12
- Assieme Principale (Codificato)
-----|-> Assieme Saldato (Codificato, che sarà il tuo riferimento da intavolare come saldato)
-----------|-> Scheletro.ipt (Struttura distinta componenti "nascosta", sarà il tuo "pilota" da modificare)
-----------|-> Assieme generato dal generatore telaio (di default è già un'assieme nascosto quindi non devi promuovere niente
-----------|-> Altri pezzi vari se necessari da vincolare al telaio

In tavola metti l' Assieme Saldato e la pallinatura funziona normalmente.
Io questa spiegazione non lo mica capita. Mi pare che ogni saldato ha il suo scheletro (telaio geratore), in questo modo poi devo usare i vincoli sulle parti per mettere assieme i saldati. Ho capito bene?

Io invece vorrei fare il contrario. Il telaio contiene tutto. Poi lo divito al suo interno in saldati così evito eventuali problemi di vincolamento che si possono verificare modificando fortemente il telaio.
 

Ilario

Utente Senior
Professione: Disegnatore CAD
Software: Inventor, AutoCAD
Regione: E. Romagna
#13
Resta il fatto che a qualcuno (me compreso) non aggiorna sempre e a qualcuno non succede mai.
E' strana questa diversità.:confused:
Resta anche il fatto che quelli che hanno più spesso il problema sono quelli che "promuovono" e "abbassano livello".

Io questa spiegazione non lo mica capita. Mi pare che ogni saldato ha il suo scheletro (telaio geratore), in questo modo poi devo usare i vincoli sulle parti per mettere assieme i saldati. Ho capito bene?

Io invece vorrei fare il contrario. Il telaio contiene tutto. Poi lo divito al suo interno in saldati così evito eventuali problemi di vincolamento che si possono verificare modificando fortemente il telaio.
Puoi lavorare come ti pare, ma se lavori in modo diverso da come il modulo è stato concepito, poi i problemi possono insorgere.
A mio avviso se modifichi "fortemente" il telaio vuol dire che stai facendo un altro disegno, succede anche senza il generatore telaio che devi "tribolare" per rimettere le cose a posto come con qualsiasi altro assieme.
I vincoli, se messi in modo corretto e intelligente (non sto dicendo che tu non lo sia, è solo un aggettivo) ci vuole un po' di tempo, ma si sistemano, come con qualsiasi altro assieme.
Se sono i problemi di vincolamento a spaventarti, io mi spaventerei di più se dovessi riavviare il pc 2 volte per sistemare un aggiornamento di profilo.

Resta inteso che non voglio insegnarti a lavorare; hai esposto un problema e ti ho proposto una soluzione che a me non ha mai dato problemi, e di telai a più pezzi ne faccio un bel po', però questo comporta che forse dovresti rivedere il tuo metodo. Non è la verità assoluta quella che ti propongo, però poi decidi tu che strada percorrere e qual'è la più indolore.
 

Tarkus

Utente Senior
Professione: Progettista,Disegnatore
Software: Autocad Mechanical,Inventor 2017,HyperMill2012
Regione: Toscana
#14
Veramente uso pochissimo promuovere o abbassare di livello in generale, MAI fatto su un telaio FG.
E a volte non si aggiorna a semplice cambio di lunghezza di una linea di schizzo...e' per questo che non so spiegarmi perché a qualcuno sì e a qualcuno no. Forse è nel DNA di inventor ............comunque, ripeto, andando a "stuzzicare" l'adattivita' dello schizzo, il mio Inventor pare risvegliarsi e riesce aggiornare.
 
Ultima modifica: