Filettature

doriano

Utente Standard
Professione: progettista
Software: catia v5, solid edge, inventor
Regione: toscana
#1
buonasera a tutti
lavorando con solid edge st4 ho un piccolo problema (non so se è già stato trattato)
Ho eseguito una filettatura trapezia fine 32x3 nel modello, ma sulla tavola se la vado a quotare non me la riconosce in automatico come per esempio le M32
qualcuno sa se devo settare qualcosa o altro.
grazie a tutti
 

radio

Moderatore
Staff Forum
Professione: Progettista (credevo...)
Software: Solid Edge ST7
Regione: Lombardia
#2
buonasera a tutti
lavorando con solid edge st4 ho un piccolo problema (non so se è già stato trattato)
Ho eseguito una filettatura trapezia fine 32x3 nel modello, ma sulla tavola se la vado a quotare non me la riconosce in automatico come per esempio le M32
qualcuno sa se devo settare qualcosa o altro.
grazie a tutti
Non dovrebbe succedere, in tavola vengono riportate le caratteristiche definite nel modello; l'unico motivo che mi viene in mente è che ti sia dimenticato di assegnare il perfisso %TS alla quota, ma mi sembra troppo semplice....

Ciiao.
 

doriano

Utente Standard
Professione: progettista
Software: catia v5, solid edge, inventor
Regione: toscana
#3
ciao
Forse le cose più semplici sono quelle che ci dimentichiamo, infatti non avevo messo nella quota della filettatura (dello schizzo) il suffisso come mi hai suggerito.
Però dopo che l'ho messo sono andato in tavola e sulla filettatura mi mette solo la quota nominale.Ma nel suffisso oltre a mettere %TS si scrive qualcosaltro?
ti saluto
 

radio

Moderatore
Staff Forum
Professione: Progettista (credevo...)
Software: Solid Edge ST7
Regione: Lombardia
#4
ciao
Forse le cose più semplici sono quelle che ci dimentichiamo, infatti non avevo messo nella quota della filettatura (dello schizzo) il suffisso come mi hai suggerito.
Però dopo che l'ho messo sono andato in tavola e sulla filettatura mi mette solo la quota nominale.Ma nel suffisso oltre a mettere %TS si scrive qualcosaltro?
ti saluto
??? Non ho capito che passaggi fai, e poi, perché suffisso? Sarà l'orario... :smile:
Il flusso di lavoro corretto è
- Nel modello crei il foro filettato e/o l'elemento filettato, assegni le caratteristiche della filettature che vuoi (diam.-event. passo-profondità) e nient'altro.
- In tavola quoti il diametro e poi, immediatamente o in un secondo momento, azioni il comando "Quota associativa-Prefisso" e nel menu relativo definisci il prefisso %TS con l'apposito comando (che non fa altro che richiamare le dimensioni della fil. che hai definito nel modello); infine per evitare di avere una quota del tipo M20x2 20, nascondi il valore nominale con "Quota associativa-Tipo quota --> Vuoto.
Ho scritto tutto passo-passo per verificare di avere inteso correttamente quello che vuoi fare.

Ciao.
 

doriano

Utente Standard
Professione: progettista
Software: catia v5, solid edge, inventor
Regione: toscana
#5
grazie radio
Ho seguito quello che mi hai detto ed è tutto giusto ma ho fatto di più, cioè siccome la mia filettatuta era una TpF 32 e sul disegno mi metteva Tr 32x3 (dicitura non esatta) sono andato nel file Hole.txt e ho modificato il testo.
Nel disegno mi viene scritto correttamente 32 TpF 32 solo che non riesco a togliere il 32 finale perchè non trovo questa "quota associativa"
Su quale icona devo andare?
ti ringrazio
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#6
Nel disegno mi viene scritto correttamente 32 TpF 32 solo che non riesco a togliere il 32 finale perchè non trovo questa "quota associativa"
Su quale icona devo andare?
ti ringrazio
E' una domanda straricorrente, sicuramente trovi la risposta nell'archivio del forum, comunque guarda l'immagine allegata.
 

Allegati

doriano

Utente Standard
Professione: progettista
Software: catia v5, solid edge, inventor
Regione: toscana
#7
grazie per la risposta
Ho provato a guardare nel forum ma non ho trovato niente se mi dai una mano ti sarei grato.
Per il problema quota filettature in tavola ho risolto il problema della dimensione della filettatura ( Tr 32x3 ) ma quando vado a quotare la profondità mi ripete la stessa dicitura,cioè Tr 32x3,cosa c'è da settare
p.s. il modello è costruito correttamente con filettatura e profondità
grazie
 

radio

Moderatore
Staff Forum
Professione: Progettista (credevo...)
Software: Solid Edge ST7
Regione: Lombardia
#8
grazie per la risposta
Ho provato a guardare nel forum ma non ho trovato niente se mi dai una mano ti sarei grato.
Per il problema quota filettature in tavola ho risolto il problema della dimensione della filettatura ( Tr 32x3 ) ma quando vado a quotare la profondità mi ripete la stessa dicitura,cioè Tr 32x3,cosa c'è da settare
p.s. il modello è costruito correttamente con filettatura e profondità
grazie
Non ho capito se vai a quotare direttamente la profondità di filettatura, o se vuoi che il valore di tale profondità sia indicato assieme al diametro di filettatura.
Nel primo caso devi togliere il prefisso %TS e riabilitare la quotatura normale.
Nel secondo caso accanto a %TS devi inserire %TD.

Ciao.
 

doriano

Utente Standard
Professione: progettista
Software: catia v5, solid edge, inventor
Regione: toscana
#9
grazie radio
Il problema è che vorrei quotare la filettatura in automatico (e quello funziona ) mentre la profondità la posso mettere anche manualmente.
Ma se in automatico funziona in manuale no neppure facendo come mi hai suggerito.Infatti appena quotato la filettatura vado a quotare la profondità e purtroppo mi mette la stessa quota della filettatura, e se tolgo dalla finestrina "prefisso" %TS sparisce la quota, mi spiace insistere su questa discussione ma conoscendo poco st4 non riesco a risolverlo senza aiuto.
p.s. cosa intendi per riabilita la quotatura normale?
ti saluto
 

Tequila

Utente Senior
Professione: teorico del paleocontatto
Software: Solid Edge ST7, scarabocchi su carta
Regione: Veneto (PD)
#10
grazie radio
Il problema è che vorrei quotare la filettatura in automatico (e quello funziona ) mentre la profondità la posso mettere anche manualmente.
Ma se in automatico funziona in manuale no neppure facendo come mi hai suggerito.Infatti appena quotato la filettatura vado a quotare la profondità e purtroppo mi mette la stessa quota della filettatura, e se tolgo dalla finestrina "prefisso" %TS sparisce la quota, mi spiace insistere su questa discussione ma conoscendo poco st4 non riesco a risolverlo senza aiuto.
p.s. cosa intendi per riabilita la quotatura normale?
ti saluto
Fai una prova togliendo i %TS e %TD ma mettendo solamente %HC
Questo è un richiamo automatico per qualsiasi tipo di foro, la cosa importante è che devi preconfigurare i tipi di richiamo su "profondità smart" e "richiamo foro". Funziona anche su prefisso quota.
 

Allegati

radio

Moderatore
Staff Forum
Professione: Progettista (credevo...)
Software: Solid Edge ST7
Regione: Lombardia
#11
Vabbè, facciamo un po' un riepilogo:

grazie radio
Il problema è che vorrei quotare la filettatura in automatico (e quello funziona ) mentre la profondità la posso mettere anche manualmente....
E fin qui ci siamo, di default SE quota la dimensione nominale dell'elemento ("Quota associativa-Tipo quota --> Nominale, "X" nera), v.fig.1; mentre quando vuoi quotare la dim. di una filettatura vai ad inserire come prefisso "%TS", e disabiliti la quota nominale ("Quota associativa-Tipo quota --> Vuoto, "X" grigia), v.fig.2.
Se vuoi puoi anche istruire il programma affinchè ti notifichi anche la profondità della filettatura, inserendo come prefisso "%TS x %TD" (sempre "X" grigia), v.fig.3

...Ma se in automatico funziona in manuale no neppure facendo come mi hai suggerito.Infatti appena quotato la filettatura vado a quotare la profondità e purtroppo mi mette la stessa quota della filettatura...
Certo, se hai ancora attivo come prefisso "%TS" (oppure "%TS x %TD"), e "X" grigia, quindi SE "sente" che stai quotando una filettatura e ti restituisce i valori relativi, v.fig.4. (mentre se quoti un elemento rettilineo questo non succede e la quota sarà quella nominale).

....e se tolgo dalla finestrina "prefisso" %TS sparisce la quota...
Questo succede perchè ti sei scordato di riabilitare la quotatura nominale: "Quota associativa-Tipo quota --> Nominale, "X" nera, v.fig.5

...
p.s. cosa intendi per riabilita la quotatura normale?
ti saluto
"Quota associativa-Tipo quota --> Nominale, "X" nera.

Ciao.
 

Allegati

  • 171.7 KB Visualizzazioni: 6
  • 174.9 KB Visualizzazioni: 4
  • 172 KB Visualizzazioni: 6
  • 171.2 KB Visualizzazioni: 4
  • 170.9 KB Visualizzazioni: 7

doriano

Utente Standard
Professione: progettista
Software: catia v5, solid edge, inventor
Regione: toscana
#12
grazie radio
Il segreto era tutto in quella X spenta o accesa.
Ti ringrazio per il tempo che mi hai dedicato, la tua competenza ha risolto il mio problema.
ti saluto