• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

File asm collegato ad Excel: problemi all'apertura

Xenon136

Utente Junior
Professione: Disegnatore
Software: Solid Edge
Regione: Marche
#1
Ciao a tutti!
Ho un problema con i file asm. Nel dettaglio ho un file d'assieme con 3 variabili (vincoli di accoppiamento fra parti) collegate ad un file excel.
Il problema è all'apertura del file asm. Avvio il pc, ed apro il file asm. Nel 90% dei casi il file non si apre. Ho una schermata bianca in solid edge come se rimanesse in attesa e può passare molto tempo e non si apre.
Guardando i processi all'apertura del file asm, vedo che si avvia Excel, in particolare 32excel. Terminando tale processo forzatamente, questo si ripresenta subito e terminato per tre volte (quante le variabili collegate, un caso?) il file asm si apre!

Eliminando i collegamenti con il file excel non si verifica assolutamente il problema.

Inoltre una volta aperto il file asm (terminando i processi excel), aprendo il file excel con doppio click dalla tabella delle variabili,il tutto funziona, ovvero posso modificare 2 variabili da excel e il 3D si aggiorna e leggo il valore della terza variabile nella cella excel che si aggiorna correttamente.


Alcune volte però il file si apre bene (di rado) e qualche volta non riesco proprio ad aprirlo. Per aprirlo nei casi peggiori, devo togliere il file excel in modo da rompere il collegamento.

Il problema si presenta anche ad altre persone con altri file asm ed altri file excel, non collegati ai miei.

Ora che ho provato a spiegare il problema, vi chiedo:
è mai capitato anche a voi?
Sbaglio qualcosa?
Devo impostare qualche opzione? Devo avere delle accortezze particolari per l'asm, per excel...ecc ?

Ci sono modi alternativi per modificare alcune variabili e leggere il valore di altre? (anche senza excel)

Grazie
 

delki

Utente Standard
Professione: Tecnical Support e Formazione su Solid Edge e SolidRules
Software: Solid Edge, Visual Basic .NET, SolidRules: InCentro, Desk, Configurator Manufactoring, Studio
Regione: Veneto
#2
Il comportamento che segnali è particolarmente anomalo.
Per scrupolo verifica il maintenance pack di Solid Edge (ST5 MP7). Se è tutti in ordine, ti suggerisco due strade:
1) elimina tutti i collegamenti excel dal file ASM, rifai/salva con nome, il file excel e ricostruisci i collegamenti e verifica.
2) contatta il rivenditore, che al massimo può poi contattare il supporto Siemens.
 

Xenon136

Utente Junior
Professione: Disegnatore
Software: Solid Edge
Regione: Marche
#3
Grazie della risposta.
Cosa è il maintenance pack? Cosa dovrei verificare?
Per quanto riguarda il punto 1 ho provato ad eliminare i collegamenti e rifarli. Riproverò a fare un salva con nome o rifare il file da nuovo.
Ultima cosa però che non mi spiego. Perché ai colleghi succede un comportamento simile?
Il file excel può contenere macro in vba?
 

morgan65

Utente Standard
Professione: Progettista Cad
Software: Solid Edge
Regione: Piacenza
#4
Hai dei collegamenti al foglio excel anche nei files .par che compongono l'assieme?
Penso succeda perche' alcuni files puntano allo stesso file excel
 

Xenon136

Utente Junior
Professione: Disegnatore
Software: Solid Edge
Regione: Marche
#5
Veramente no.
In parte ho risolto, o meglio, ho capito cosa da errore e cerco di evitarlo, ovvero ci sono problemi se nello stesso file ci sono celle in lettura da SE assieme a celle che legge invece SE.