• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

Famiglia di parti

fabio71

Utente Junior
Professione: Ingegnere Progettista
Software: Pro Engineer - Autocad - SE
Regione: Marche
#1
Buon giorno
Ho un problema con la famiglia di parti che non riesco a risolvere: mi sono creato una famiglia di parti di un componente tramite tabella, ma poi quando voglio inserire in un'assieme un "sottocomponente" di questa famiglia, il programma (Solid Edge ST) non mi da la possibilità di scegliere ma prende sempre il componente "padre". Dove sbaglio? Deve essere settata qualche opzione? Ho provato a cercare nel forum discussioni inerenti ma non ho trovato nulla che fa al mio caso. Grazie
 

Tequila

Utente Senior
Professione: teorico del paleocontatto
Software: Solid Edge ST7, scarabocchi su carta
Regione: Veneto (PD)
#2
Buon giorno
Ho un problema con la famiglia di parti che non riesco a risolvere: mi sono creato una famiglia di parti di un componente tramite tabella, ma poi quando voglio inserire in un'assieme un "sottocomponente" di questa famiglia, il programma (Solid Edge ST) non mi da la possibilità di scegliere ma prende sempre il componente "padre". Dove sbaglio? Deve essere settata qualche opzione? Ho provato a cercare nel forum discussioni inerenti ma non ho trovato nulla che fa al mio caso. Grazie
io uso la ST2 è non mi crea problemi del genere. Mi viene il dubbio che tu abbia solo creato la tabella con le varianti e non riempito le varianti stesse, ossia generato anche i modelli 3D di queste partendo dal padre.
Se non lo fai quando inserisci il componente padre nell'assieme poi non ti fa comparire la finestrella per scegliere quale utilizzare della lista di varianti che hai creato.

Se invece hai anche generato i modelli 3D e non ti lascia cambiare allora non saprei neanch'io dove sta il problema. ciao
 

fabio71

Utente Junior
Professione: Ingegnere Progettista
Software: Pro Engineer - Autocad - SE
Regione: Marche
#3
Ops, credo che il problema era proprio questo. Comunque con il comando riempi varianti il programma mi genera "n" sottocomponenti e non mi fa comparire la finestrella per scegliere quella da utilizzare. Grazie mille Tequila
 

Tequila

Utente Senior
Professione: teorico del paleocontatto
Software: Solid Edge ST7, scarabocchi su carta
Regione: Veneto (PD)
#4
Ops, credo che il problema era proprio questo. Comunque con il comando riempi varianti il programma mi genera "n" sottocomponenti e non mi fa comparire la finestrella per scegliere quella da utilizzare. Grazie mille Tequila
la finestra ti compare quando vai a fare sostituisci componente all'interno dell'assieme e non sul file par. Inserisci il componente padre in un assieme, poi da pathfinder fai click destro/sostituisci componente ed allora li si che ti apre una finestra tra cui scegliere tra i vari figli generati rispetto a quel padre.
 

vespa_83

Utente Standard
Professione: disegnatore
Software: Solid Edge
Regione: Romagna
#6
attenzione se rinomini i file. (non ricordo cosa succede ma se rinomini selvaggiamente incombe il pericolo di perdere i collegamenti tra le parti)

si cambi solo , ripeto solo, delle quote valuta l'uso delle parti regolabili (vedi guida).

GV
 

fabio71

Utente Junior
Professione: Ingegnere Progettista
Software: Pro Engineer - Autocad - SE
Regione: Marche
#7
ma anche se lo rinomino con revision manager ci possono essere dei problemi con i collegamenti padre figli?
 

Leso

Utente Standard
Professione: Ufficiale tecnico
Software: Solid Edge ST9
Regione: Veneto
#8
Per ogni file che rinomini devicercare con la funzione "Dove usato" i file che sono collegati e solo dopo rinomini il file. Se non dimentichi niente non dovresti avere problemi.
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#10
Per ogni file che rinomini devicercare con la funzione "Dove usato" i file che sono collegati e solo dopo rinomini il file. Se non dimentichi niente non dovresti avere problemi.
Una domanda semplice ma non ho mai usato queste famiglie di parti. Le parti cosi' generate sono solo dei link alla parte master o esistono effettivamente nel file system?

La domanda nasce da questo: se tramite RM faccio un pacchetto di un progetto da mandare al cliente, gli devo mandare anche il master o il membro della famiglia vive ugualmente anche senza il suo master?
 

Tequila

Utente Senior
Professione: teorico del paleocontatto
Software: Solid Edge ST7, scarabocchi su carta
Regione: Veneto (PD)
#11
Una domanda semplice ma non ho mai usato queste famiglie di parti. Le parti cosi' generate sono solo dei link alla parte master o esistono effettivamente nel file system?

La domanda nasce da questo: se tramite RM faccio un pacchetto di un progetto da mandare al cliente, gli devo mandare anche il master o il membro della famiglia vive ugualmente anche senza il suo master?
ti rispondo io... al momento le famiglie di parti non le uso (son comode e ne ho visto il reale beneficio in termini di tempo). Un nostro collaboratore esterno quando mi inviava degli assiemi con all'interno componenti generati da famiglie di parti il master non c'era mai. In RM ti compare il figlio con il collegamento fallito al master, ma se apri il modello la feature copia della parte c'è, solo che al posto del catenino c'è il punto interrogativo rosso, ma comunque il membro della famiglia vive ugualmente pur tagliando il cordone ombelicale :)
 

fabio71

Utente Junior
Professione: Ingegnere Progettista
Software: Pro Engineer - Autocad - SE
Regione: Marche
#12
quindi non si creano casini con il collegamento al padre che non trova, giusto?
 

Tequila

Utente Senior
Professione: teorico del paleocontatto
Software: Solid Edge ST7, scarabocchi su carta
Regione: Veneto (PD)
#13
quindi non si creano casini con il collegamento al padre che non trova, giusto?
in pratica rimane il file 3d del modello con la feature "copia della parte" solo che non ha il catenino che la collega al padre. Il file ed il modello fisicamente c'è e si può utilizzare, l'unica cosa che si riscontra è che se apri l'assieme dove è montato questo figlio o anche il singolo file figlio con revision manager ti fa vedere il link in rosso del "file non trovato" del collegamento al padre.

Per rendere pulito l'eventuale copia che si da al cliente è quella di copiare sia figlio e padre, di seguito disabilitare il collegamento al padre per rendere autonomo il figlio e poi cancellare il file padre, ma diventa un lavoraccio che secondo me non ha senso, visto che ugualmente funziona.

NB: questa procedura di disabilitare il collegamento al padre la si deve fare solo su una copia di padre e figlio, perchè se la si fa sull'originale poi si perde l'automatismo di cambio che c'è nell'assieme quando si va a sostituirlo
 

fabio71

Utente Junior
Professione: Ingegnere Progettista
Software: Pro Engineer - Autocad - SE
Regione: Marche
#14
grazie tequila, sei stato molto chiaro; la cosa non bella, come già detto da cacciatorino, è se consegno un backup di un'assieme ad un cliente, lui si ritrova con tutti questi punti esclamativi (di famiglie di parti) sul pathfinder, che non è il massimo da vedere. Sarebbe molto utile se il programma svincolasse completamente la parte dal suo master, ma comunque ci accontentiamo lo stesso.
 

Tequila

Utente Senior
Professione: teorico del paleocontatto
Software: Solid Edge ST7, scarabocchi su carta
Regione: Veneto (PD)
#15
grazie tequila, sei stato molto chiaro; la cosa non bella, come già detto da cacciatorino, è se consegno un backup di un'assieme ad un cliente, lui si ritrova con tutti questi punti esclamativi (di famiglie di parti) sul pathfinder, che non è il massimo da vedere. Sarebbe molto utile se il programma svincolasse completamente la parte dal suo master, ma comunque ci accontentiamo lo stesso.
aspetta un attimo, io non ho detto sul pathfinder ma andando a vedere su revision manager. Sul pathfinder del modello ti ritrovi solo il punto interrogativo sulla feature. In RM vedi che manca il link al padre.
Sull'assieme dove è inserito il modello non ci sono problemi.
 

Allegati

vespa_83

Utente Standard
Professione: disegnatore
Software: Solid Edge
Regione: Romagna
#16
i collegamenti di solito è meglio che siano "vivi" per aggiornamenti automatici futuri.

Se comunque l'utente decide di interrompere i collegamenti 'al padre' si apre il part figlio, tasto destro su Copia parte, quindi -> scollega.
 

fabio71

Utente Junior
Professione: Ingegnere Progettista
Software: Pro Engineer - Autocad - SE
Regione: Marche
#17
grazie tequila, avevo interpretato male la tua risposta, ora è tutto chiaro.