estrema lentezza applicazione vincoli

Atreiou

Utente Junior
Professione: impiegato
Software: Solidworks Premium 2017 sp.4.1
Regione: Veneto
#21
configurazione.png

con scheda Quadro 4200 e SSD principale da 125 Gb e disco meccanico da 1 TB dove risiede la libreria e i progetti
 

Atreiou

Utente Junior
Professione: impiegato
Software: Solidworks Premium 2017 sp.4.1
Regione: Veneto
#22
ecco alcuni screenshot dell'albero, mi sembrava eccessivo fotografarlo tutto perchè sarebbe ripetitivo.
se serve altro chiedete pure

01.png

02.png
 

drake

Utente Standard
Professione: Ingegnere strutturista
Software: SW 2017 sp5.0
Regione: Marche
#23
View attachment 43183

con scheda Quadro 4200 e SSD principale da 125 Gb e disco meccanico da 1 TB dove risiede la libreria e i progetti
Capito. L'assistenza mi ha detto che l'indice delle prestazioni win non è indicativo, in quanto non è in grado di valutare le reali prestazioni grafiche...riporto quello che dicono...
 

Atreiou

Utente Junior
Professione: impiegato
Software: Solidworks Premium 2017 sp.4.1
Regione: Veneto
#24
l'indice di velocità Win non era quello che volevo far vedere, mi interessava di più il processore e la ram

la scheda grafica si vede bene che funziona a dovere, quando fai girare l'assieme non ha nessun rallentamento.

il problema è nell'applicazione dei "mates", che è ben lungi da richiedere calcolo grafico, visto che in quel momento il tutto è statico e di solito zommato per scegliere bene facce o profili
 

drake

Utente Standard
Professione: Ingegnere strutturista
Software: SW 2017 sp5.0
Regione: Marche
#25
Si ok...ho preso spunto x riportare quello che mi hanno detto, magari può servire a qualcuno.
C'è sicuramente qualcos'altro allora...Il tuo albero sembra ok, con tutti i componenti ben vincolati.
Forse mi è sfuggito... Hai provato a fare le stesse operazioni caricando l'assieme a peso leggero?
 

Atreiou

Utente Junior
Professione: impiegato
Software: Solidworks Premium 2017 sp.4.1
Regione: Veneto
#26
i componenti dell'assieme vengono utomaticamente caricati a peso leggero.
come vedi la maggiorparte delle parti ha la "piuma" sull'iconcina
 

drake

Utente Standard
Professione: Ingegnere strutturista
Software: SW 2017 sp5.0
Regione: Marche
#28
Detto questo, mi sembra evidente la conclusione...
La cosa che più mi lascia basito è che secondo l'assistenza quasi tutti i problemi di sw siano legati a problemi di installazione, probabilmente dovranno migliorare l'interfaccia di installazione.
Ciao
 

Atreiou

Utente Junior
Professione: impiegato
Software: Solidworks Premium 2017 sp.4.1
Regione: Veneto
#29
Quindi a parer tuo sono "mancanze" del software stesso, non della macchina o del modo di approcciare gli assieme, ho capito bene ?
 

drake

Utente Standard
Professione: Ingegnere strutturista
Software: SW 2017 sp5.0
Regione: Marche
#30
Quindi a parer tuo sono "mancanze" del software stesso, non della macchina o del modo di approcciare gli assieme, ho capito bene ?
Si hai capito bene, anche se non sarebbero proprio mancanze ma più che altro "false attese di prestazioni".
Mi spiego meglio... Prima lavoravo con la versione 2012 con due macchine su xp a 32 2 64 bit. Ovvio che quella a 64 era maggiormente performante solo quando le operazioni richiedevano memoria, tipo nelle messe in tavola. In quella a 32 avevo una vecchissima quadro FX1500 ed in quella a 64 ho una quadro 600. Quest'ultima la uso ancora e l'ho aggiornata a win7 x lavorarci con la 2016. HO acquistato anche altra macchina che dicevo prima. Bene detto ciò non posso assolutamente dire che la macchina recente sia notevolmente più performante della vecchia ws. Davanti ad hardware di livello non mi aspettavo così poca differenza.
Credo che x la tipologia di strutture che facciamo si debba soffrire qui davanti e basta. Non riesco ad immaginare come sia possibile progettare ad esempio autovetture, quindi progettazione meccanica x la quale il software è nato, come debbano essere performanti i pc....
 

drake

Utente Standard
Professione: Ingegnere strutturista
Software: SW 2017 sp5.0
Regione: Marche
#31
Aggiungo questo... prima i vecchi pc con la vecchia versione di sw soffrivano particolarmente in fase di messa in tavola altrimenti no, riuscendo a lavorare più o meno agevolmente...
 
Professione: disegnatore
Software: autocad 2013; solidworks 2014 e 2017
Regione: Friuli Venezia Giulia
#32
attenzione ad una cosa però...
ad una presentazione dell'ultima release ci è stato detto che una pratica che crea spesso problemi di crash e prestazioni è quella di importare le impostazioni della precedente versione tramite la copia guidata impostazioni.
questo perché, cito a memoria, la copiatura ripristina tutte le voci di registro della versione precedente, anche quelle che non ci sono più o hanno un indirizzo di sistema diverso nelle nuova versione.
quindi con aggiornamentio di sistema, driver o altro è palese che solid avendo nel registro di sistema voci falsate si impunti in certi passaggi. ma a parità di macchina e installazione cerdo succeda la stessa cosa ipotizzando un rimaneggiamento di librerie dll tra una versione e l'altra.

se mi smentite su questa cosa ben venga così non dovrò settare tutto a mano ogni volta
 

drake

Utente Standard
Professione: Ingegnere strutturista
Software: SW 2017 sp5.0
Regione: Marche
#33
Quello che dici tu effettivamente potrebbe essere e forse non conviene importare un bel nulla e rifare i settaggi manualmente.
In effetti io nella nuova macchina ho installato prima la versione 2012 poi la 2016 come nuova installazione e non come aggiornamento. Poi mi sono comunque accorto che lui aveva importato le impostazioni anche se io non gli avevo detto nulla.
Mi confermi che anche questo potrebbe influire? Mi chiedo se ci sia anche qualche altra impostazione x win che sarebbe meglio fare, tipo (dico x dire) un file di swap o cosa del genere...
 
Professione: disegnatore
Software: autocad 2013; solidworks 2014 e 2017
Regione: Friuli Venezia Giulia
#34
non parlo di aggiornamento o di nuova installazione, bensì della copiatura guidata che non è altro che la copia delle voci di registro riguardanti solid dove ci sono tutti i settaggi e tutte le variabili della versione.
per esempio se giri le impostazioni da una stazione con user Annibale ad una stazione con user Scipione ci sarà sicuramente qualche voce di registro che punta ad Annibale e qualche cacca di elefante salta ben fuori
 

drake

Utente Standard
Professione: Ingegnere strutturista
Software: SW 2017 sp5.0
Regione: Marche
#35
Ho capito bene quello che intendi, ma ho visto che anche non copiando nulla delle impostazioni le ha prese ugualmente da solo.
Quindi ti confermo che non ho importato manualmente alcuna impostazione.
 
Professione: disegnatore
Software: autocad 2013; solidworks 2014 e 2017
Regione: Friuli Venezia Giulia
#36
dalle immagini che hai postato si capisce poco, quindi ti giro un pdf con un'idea di come lo farei io.
ovviamente la gestione dei sottoassiemi deve seguire prima di tutto la logica commerciale della commessa. se ci sono già dei macrogruppi di montaggio (silos, telai in fondazione, pompa di raffreddamento...) quelli diventano automaticamente sottoassiemi, poi seguire un ragionamento per componenti preassemblati (coperchi silos, basamentino per motore...)ed eventuali gruppi di componenti ripetuti (curva a 90 + flangia + guarnizione, cerniera per rcoperchio...)
ma soprattutto semplica al massimo i compnenti commerciali come i motori con alette che prosciugano la memoria perché devono essere ricalcolati ad ogni spostamento che fai. fai un quadro per la cassa e un tondo per il motore che rappresentino l'ingombro. poi se ti serve anche la grafica per fare presentazioni o altro fai due configurazioni; una semplificata con cancellati o sospesi i corpi importati per modellare e l'altra per fare lo sciccoso col cliente

View attachment 02.pdf
 

Atreiou

Utente Junior
Professione: impiegato
Software: Solidworks Premium 2017 sp.4.1
Regione: Veneto
#37
grazie Massi per il tempo che mi hai dedicato nel preparare quel pdf.
allora..
il telaio è diviso in 4 assiemi, le due basi, il traliccio e dei traversini, sono in realtà parti strutturali
i vessels verticali sono un altro assieme
il serbatoio è un assieme perchè così lo devo ordinare al fornitore

le varie linee tipo ingresso, uscita, ecc faccio degli assiemi virtuali all'interno dell'assieme totale

di base gli assiemi effettivi non virtuali determinano un oggetto che va ordinato al fornitore, quindi pompa, valvola, ecc
la raccorderia è un assieme a sua volta, in cui ogni giunzione che è formata da un minimo di due componenti ad un massimo di 4, è un assieme con 4 configurazioni diverse, e ogni diametro ha un assieme diverso.
 

drake

Utente Standard
Professione: Ingegnere strutturista
Software: SW 2017 sp5.0
Regione: Marche
#38
Continuo la discussione x dire che ora sto facendo la messa in tavola di una tettoia, della quale allego immagine della tavola,
che non ha nulla di complicato, ma in realtà i tempi x mettere delle semplici quote e spostarsi nel disegno con gli zoom e con il pan sono biblici...
Tettoia.JPG
 
Professione: disegnatore
Software: autocad 2013; solidworks 2014 e 2017
Regione: Friuli Venezia Giulia
#39
Continuo la discussione x dire che ora sto facendo la messa in tavola di una tettoia, della quale allego immagine della tavola,
che non ha nulla di complicato, ma in realtà i tempi x mettere delle semplici quote e spostarsi nel disegno con gli zoom e con il pan sono biblici...
View attachment 43206
forse non complicato come modellazione, ma graficamente direi di si. ogni volta che sposti la vista ogni linea e arco deve essere ricalcolato, ti sembra poco? non è un disegno statico, quando sposti una vista gli vanno dietro anche le altre, eventuali dettagil e sezioni. se metti una quota deve relazionarsi con la parte, insomma lavora in continuo...
 

drake

Utente Standard
Professione: Ingegnere strutturista
Software: SW 2017 sp5.0
Regione: Marche
#40
forse non complicato come modellazione, ma graficamente direi di si. ogni volta che sposti la vista ogni linea e arco deve essere ricalcolato, ti sembra poco? non è un disegno statico, quando sposti una vista gli vanno dietro anche le altre, eventuali dettagil e sezioni. se metti una quota deve relazionarsi con la parte, insomma lavora in continuo...
Risentita appena adesso assistenza e mi prospettano sempre che forse c'è stato un problema in fase di installazione.. non so se mettermi a ridere o piangere. Io capisco che ogni volta deve ricalcolare ma che alla fine con hardware recente e molto più performante aspetto anche forse più di prima, è questo che proprio non capisco o meglio sono convinto che sia una situazione voluta! Quindi credo che alla fine io abbia buttato dei soldi e mi sento di averlo preso in quel posto, tanto di moda oggi. Comunque appena posso disinstallo tutto, sia la 2016 che la 2012 con la pulizia dei registri. Reinstallerò solo la 2016 facendo attenzione a disattivare antivirus, installare come amministratore e poi lo personalizzo di nuovo senza importare alcuna vecchia configurazione e poi vediamo. Non sono affatto convinto che si risolva tutto. Aggiornerò la discussione.