errore nelle equazioni dello schizzo

skia51

Utente Junior
Professione: ingegnere meccanico progettista
Software: solidworks 2016, AUTOCAD 2016, INVENTOR 2016
Regione: campania
#1
salve a tutti
non ho ben capito cosa è successo ma una parte multi corpo fatta con i membri strutturali, ottenuta come modifica di un altro file, mi da continuamente errore per le equazioni. Come posso riparare questo errore?
allego il file
grazie achi mi aiuterà View attachment 24- BRACCIO 2.zip
 

Mike1967

Moderatore CAM
Staff Forum
Professione: Pane e lamiera
Software: Solidworks 2016 sp 5 X 2017 sp 0
Regione: Lombardia, Varese-Canton Ticino, Svizzera
#2
salve a tutti
non ho ben capito cosa è successo ma una parte multi corpo fatta con i membri strutturali, ottenuta come modifica di un altro file, mi da continuamente errore per le equazioni. Come posso riparare questo errore?
allego il file
grazie achi mi aiuterà View attachment 38132
Le quote che guidavano quella equazione non esistono più, quindi la via più breve è quello di cancellarla.
A priori non posso dirti a cosa si riferiva però guadando le altre equazioni sono rimasto perplesso:
mettere delle equazioni per i profili dei membri strutturali penso si superfluo oltre che pesante per il
progetto.
 

skia51

Utente Junior
Professione: ingegnere meccanico progettista
Software: solidworks 2016, AUTOCAD 2016, INVENTOR 2016
Regione: campania
#3
Ciao mike, grazie della risposta. Non so dirti queste equazioni da dove escano fuori ho semplicemente usato I profili che uso di solito. Ora come faccio a cancellare l'equazione che crea problemi? Ho provato a visualizzarla ma non riesco a cancellarla, anche tutti gli schizzi non hanno problemi e non saprei quale cancellare e rifare.
 
Professione: disegnatore
Software: autocad 2013; solidworks 2014 e 2017
Regione: Friuli Venezia Giulia
#4
Ora come faccio a cancellare l'equazione che crea problemi? Ho provato a visualizzarla ma non riesco a cancellarla, anche tutti gli schizzi non hanno problemi e non saprei quale cancellare e rifare.
tasto destro sulla cartella equazioni, selezioni gestisci equazioni e cancelli quelle che danno errore. nelle formule c'è scritto a quale quota si riferisce e a quale schizzo appartiene
 

skia51

Utente Junior
Professione: ingegnere meccanico progettista
Software: solidworks 2016, AUTOCAD 2016, INVENTOR 2016
Regione: campania
#5
Grazie massi proverò domani mattina. Ma la cancellazione dell'equazione comporta la cancellazione dello schizzo? Oppure non ci sono conseguenze?
 
Professione: disegnatore
Software: autocad 2013; solidworks 2014 e 2017
Regione: Friuli Venezia Giulia
#6
Ma la cancellazione dell'equazione comporta la cancellazione dello schizzo?
se così fosse stato non te lo avrei suggerito. le equazioni nei profili di solito gestiscono il rapporto dei raggi rispetto allo spessore dell'elemento, oppure nei trafilati quadri che un lato è uguale all'altro, in linea di massima perché non so cosa hai usato. se cancelli l'equazione succede che se vai a cambiare un valore nello schizzo del profilo probabilmente qualcosa si perde per strada. ma come detto se cancelli l'equazione non cancelli le quote gestite da essa
 

Mike1967

Moderatore CAM
Staff Forum
Professione: Pane e lamiera
Software: Solidworks 2016 sp 5 X 2017 sp 0
Regione: Lombardia, Varese-Canton Ticino, Svizzera
#7
Ciao mike, grazie della risposta. Non so dirti queste equazioni da dove escano fuori ho semplicemente usato I profili che uso di solito. Ora come faccio a cancellare l'equazione che crea problemi? Ho provato a visualizzarla ma non riesco a cancellarla, anche tutti gli schizzi non hanno problemi e non saprei quale cancellare e rifare.
Scusa se non ti ho risposto ma ero fuori.
Lo ha fatto egregiamente Massi. :smile:
 

skia51

Utente Junior
Professione: ingegnere meccanico progettista
Software: solidworks 2016, AUTOCAD 2016, INVENTOR 2016
Regione: campania
#8
risolto il problema della parte ora ilparticolare non mi da più problemi ed anche l'assieme, grazie a mike e massi. la cosa strana però e che l'assieme generale continua a dirmi che c'è un roblema con il sottoassieme in cui è presente la parte di cui parlavo prima, eppure se apro l'assieme e la parte corrispondente non ci sono errori :frown:, forse miconviene cancellare il sotto assieme e reinserirlo.
ciao a tutti
 

Max-C

Utente Standard
Professione: Mechanical designer
Software: Siemens NX - Solidworks - Inventor - Autocad
Regione: Piemonte-Provincia TO
#9
risolto il problema della parte ora ilparticolare non mi da più problemi ed anche l'assieme, grazie a mike e massi. la cosa strana però e che l'assieme generale continua a dirmi che c'è un roblema con il sottoassieme in cui è presente la parte di cui parlavo prima, eppure se apro l'assieme e la parte corrispondente non ci sono errori :frown:, forse miconviene cancellare il sotto assieme e reinserirlo.
ciao a tutti
è un sottoassieme flessibile? Hai delle ripetizioni/specchiature di parti che si muovono in questo sottoassieme? Puoi darci uno screen capture?
 

skia51

Utente Junior
Professione: ingegnere meccanico progettista
Software: solidworks 2016, AUTOCAD 2016, INVENTOR 2016
Regione: campania
#10
si è un assieme flessibile, posto due screenshot, uno dell'assieme generale in cui si vede l'errore nel sotto assieme e nel secondo screenshot lo stesso stotto assieme non rivela alcun errore
spero sia chiaro
 

Allegati

Max-C

Utente Standard
Professione: Mechanical designer
Software: Siemens NX - Solidworks - Inventor - Autocad
Regione: Piemonte-Provincia TO
#11
si è un assieme flessibile, posto due screenshot, uno dell'assieme generale in cui si vede l'errore nel sotto assieme e nel secondo screenshot lo stesso stotto assieme non rivela alcun errore
spero sia chiaro
Prva a sopprimere il sottoassieme->ricostruisci->riattiva il sottoassieme->ricostruisci
 
Professione: disegnatore
Software: autocad 2013; solidworks 2014 e 2017
Regione: Friuli Venezia Giulia
#12
anche in un assieme flessibile devi avere una parte fissa. quel sottoassieme è una mina vagante; inoltre parti non bloccate rallentano il programma.
fare più parti fisse, cioè bloccate indipendentemente da altre, non è una buona idea.
non mi stupisce che ti dia errori e che tu non riesca ad identificarli se lavori in quella maniera; fai i tutorial
 

Max-C

Utente Standard
Professione: Mechanical designer
Software: Siemens NX - Solidworks - Inventor - Autocad
Regione: Piemonte-Provincia TO
#13
anche in un assieme flessibile devi avere una parte fissa. quel sottoassieme è una mina vagante; inoltre parti non bloccate rallentano il programma.
fare più parti fisse, cioè bloccate indipendentemente da altre, non è una buona idea.
non mi stupisce che ti dia errori e che tu non riesca ad identificarli se lavori in quella maniera; fai i tutorial
Scusa ma questo argomento interessa anche a me.
Io molte volte lavoro con assiemi che haano molti pezzi "mobili". Secondo te tenerli vincolati e svincolarlli solo quando devo simulare il movimento può essere una buona soluzione?
 

skia51

Utente Junior
Professione: ingegnere meccanico progettista
Software: solidworks 2016, AUTOCAD 2016, INVENTOR 2016
Regione: campania
#14
anche in un assieme flessibile devi avere una parte fissa. quel sottoassieme è una mina vagante; inoltre parti non bloccate rallentano il programma.
fare più parti fisse, cioè bloccate indipendentemente da altre, non è una buona idea.
non mi stupisce che ti dia errori e che tu non riesca ad identificarli se lavori in quella maniera; fai i tutorial

ciao massi,
l'assieme è totalmente vincolato nell'assieme generale, che rallenti il sistema non è n problema deve rimanere flessibile solo per verificare gli ingombri poi sarà rigido. ho provato a toglierlo e rimetterlo nell'assieme ma l'errore rimane.