• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

Eliminare linee di parti non visibili che "riaffiorano"

reggio

Utente Senior
Professione: ...
Software: autocad11+swx16 sp4 w7 x64+Ready2W2012
Regione: Emilia - Modena
#1
... non sapevo come titolare questo post ...
In pratica mi chiedevo se avete un trucco o un comando (render a parte) che impedisca alle linee delle parti/assiemi non visibili di divenire invece visibili da lontano...

Allego un esempio che mi aiuterà a spiegarmi meglio,
in pratica se guardiamo ai piedi del semaforo blu con piedistallo grigio in figura DX non riusciamo a vedere i profili in alluminio che sono correttamente nascosti dalla lamiera che li ricopre, invece se guardiamo nella figura di SX, che vede da più lontano, ecco affiorare (ed essere selezionabili) le linee dei profili in alluminio che NON dovrebbero vedersi...

Real view graph, ombre, occlusione ambientale (occlusione ambientale ...no comment :frown:), rimozione linee nascoste, ... non mi aiutano, avete una soluzione alternativa?
 

Allegati

Ivan1990

Utente Standard
Professione: disegnatore
Software: SolidWorks 2013
Regione: lombardia (brescia)
#2
... non sapevo come titolare questo post ...
In pratica mi chiedevo se avete un trucco o un comando (render a parte) che impedisca alle linee delle parti/assiemi non visibili di divenire invece visibili da lontano...

Allego un esempio che mi aiuterà a spiegarmi meglio,
in pratica se guardiamo ai piedi del semaforo blu con piedistallo grigio in figura DX non riusciamo a vedere i profili in alluminio che sono correttamente nascosti dalla lamiera che li ricopre, invece se guardiamo nella figura di SX, che vede da più lontano, ecco affiorare (ed essere selezionabili) le linee dei profili in alluminio che NON dovrebbero vedersi...

Real view graph, ombre, occlusione ambientale (occlusione ambientale ...no comment :frown:), rimozione linee nascoste, ... non mi aiutano, avete una soluzione alternativa?
questo è un problema che capita spesso anche a me, se la lamiera che copre è sottile allontanando il dettaglio si vede il corpo a contatto sotto(più è sottile più si vede il corpo o la parte a contatto sotto) ho provato di tutto, rendering a parte anche con le impostazioni di tutto(a livello grafico) impostato sui massimi valori di qualità, niente da fare, io di mio o ignoro questo problema o faccio il render, oppure se necessito aumento lo spessore della lamiera, oppure do qualche stacco tra lamiera e parte sotto.... ovviamente sono soluzioni blande, se qualcuno avessa soluzioni migliori sarei contento di trovarle :biggrin:.. anche se dubito ci sia qualche metodo :mad:
 

eboss

Utente Standard
Professione: progettista
Software: SWX 2013 sp.5 - SWX 2013 SP.3 - factory design suite 2012 - inventor 2014 - mechanical 2012
Regione: Veneto
#3
Ciao dall'immagine mi sembra affiorino i bordi trateggiati...
Banalmente prova a verificare le impostazioni nascondendo i bordi "mostra bordo tangente di parte/assieme" .
Ti allego l'immagine.
 

Allegati

reggio

Utente Senior
Professione: ...
Software: autocad11+swx16 sp4 w7 x64+Ready2W2012
Regione: Emilia - Modena
#4
Ciao dall'immagine mi sembra affiorino i bordi trateggiati...
Banalmente prova a verificare le impostazioni nascondendo i bordi "mostra bordo tangente di parte/assieme" .
Ti allego l'immagine.
Ahimè no, non si tratta di bordi tratteggiati e "mostra bordo tangente di parte/assieme" non aiuta ...

Grazie ugualmente... ho già renderato :(
 

Mike1967

Moderatore CAM
Staff Forum
Professione: Pane e lamiera
Software: Solidworks 2016 sp 5 X 2017 sp 0
Regione: Lombardia, Varese-Canton Ticino, Svizzera
#5
Ahimè no, non si tratta di bordi tratteggiati e "mostra bordo tangente di parte/assieme" non aiuta ...

Grazie ugualmente... ho già renderato :(
Quando sono costretto, creo uno stato di visualizzazione ad hoc in modo da nascondere quei componenti in modo da
eliminare quelle antiestetiche linee.
 

re_solidworks

Moderatore Solidworks
Staff Forum
Professione: Progettista
Software: Swx2016-R2W2016-Power Surfacing 2.1-Creo 2.0- PDSU 2016 - Composer 2016
Regione: Veneto
#7
.... io non li sò usare, le prossime volte 'sconderò le parti interessate ...

Grazie e ciao :D
ecco... se prima di "sconderle" crei uno stato di visualizzazione con un nome tuo puoi passare da uno stato all'altro con un doppio click e senza metterti a nascondere e visualizzare a mano.
 

Mike1967

Moderatore CAM
Staff Forum
Professione: Pane e lamiera
Software: Solidworks 2016 sp 5 X 2017 sp 0
Regione: Lombardia, Varese-Canton Ticino, Svizzera
#8
.... io non li sò usare, le prossime volte 'sconderò le parti interessate ...

Grazie e ciao :D
Re ti ha dato indicazioni su come usarle... io ti suggerisco la visione di questo... speravo lo avessi già visionato.
Lo avevo fatto con la 2011 ma la procedura è identica.
Facci sapere... :smile:

[youtube]57U95Q0LDZU[/youtube]
 

reggio

Utente Senior
Professione: ...
Software: autocad11+swx16 sp4 w7 x64+Ready2W2012
Regione: Emilia - Modena
#9
Re ti ha dato indicazioni su come usarle... io ti suggerisco la visione di questo... speravo lo avessi già visionato.
Lo avevo fatto con la 2011 ma la procedura è identica.
Facci sapere... :smile:

[youtube]57U95Q0LDZU[/youtube]

... hai ragione ...
... e infatti funziona ;P
... debbo installarmi un banco di ram di memoria .. :D

Grazie e alla prossima!!
 

Mike1967

Moderatore CAM
Staff Forum
Professione: Pane e lamiera
Software: Solidworks 2016 sp 5 X 2017 sp 0
Regione: Lombardia, Varese-Canton Ticino, Svizzera
#10
... hai ragione ...
... e infatti funziona ;P
... debbo installarmi un banco di ram di memoria .. :D

Grazie e alla prossima!!
BENEEEEE !!!!! :biggrin:

Di quanta RAM disponi ?
Io ho 4 GB (fino a 6 mesi fà usavamo XP), ma ho fatto richiesta al mio titolare di finanziarmi 8 GB di ram
per 3 WS, domani dovrebbe darmi il nulla osta (danèè)... :mixed:
 
Professione: piegatore e disegnatore notturno...
Software: Solidworks 2012 sp5
Regione: Toscana
#11
Quando sono costretto, creo uno stato di visualizzazione ad hoc in modo da nascondere quei componenti in modo da
eliminare quelle antiestetiche linee.
Sai che ho fatto cosi anche io per un assieme e quanto sono andato a fare la sezione (4-5 componenti legati) mi ha detto che la sezione non la poteva e mi dava errore, o meglio tutto l'assieme con tutti i componenti di colore marrone...
Ho risolto creando una configurazione aggiuntiva alla "default" dove ho semplicemente nascosto i componenti che non mi interessava vedere. Con questo sistema la sezione risulta corretta!
....è sbagliato il procedimento o il concetto?
 

reggio

Utente Senior
Professione: ...
Software: autocad11+swx16 sp4 w7 x64+Ready2W2012
Regione: Emilia - Modena
#12
BENEEEEE !!!!! :biggrin:

Di quanta RAM disponi ?
Io ho 4 GB (fino a 6 mesi fà usavamo XP), ma ho fatto richiesta al mio titolare di finanziarmi 8 GB di ram
per 3 WS, domani dovrebbe darmi il nulla osta (danèè)... :mixed:
nel pc ho 6gb, ma io parlavo della mia memoria :biggrin: