Doppio Giunto Cardanico

crestus

Utente poco attivo
Professione: studente
Software: Solidworks 2010 sp2.1 Catia v5 R20
Regione: Piemonte
#1
Salve gente!

Vi scrivo perchè ho bisogno di aiuto!

Sto modellando uno schema di principio di un giunto Cardanico doppio, ma sto incontrando grosse difficoltà con lo studio di movimento.

Ho già cercato ma non ho trovato altro che questa discussione... Purtroppo avendo la versione 2010 Sp 2.1 non posso vedere i file :frown:

Detto questo ho provato tutto quello che mi viene in mente (giunto cardanico, riduzione degli accoppiamenti, utilizzo di un asse aggiuntivo al posto della simmetria tra i due alberi agli estremi, impostando un movimento punto per punto manualmente e qualcuna che non mi viene in mente),ma con lo studio di movimento proprio non si vuole muovere...(sfarfalla un po' all'inizio, ma poi si blocca...) Al contrario, ruotandolo manualmente gira che è un piacere indipentenmente dalla parte "cliccata"....

Stesso comportamento con un cardanico singolo o semplice...


chiedo umilmente il vostro aiuto....
 

Allegati

Ivan1990

Utente Standard
Professione: disegnatore
Software: SolidWorks 2013
Regione: lombardia (brescia)
#2
Salve gente!

Vi scrivo perchè ho bisogno di aiuto!

Sto modellando uno schema di principio di un giunto Cardanico doppio, ma sto incontrando grosse difficoltà con lo studio di movimento.

Ho già cercato ma non ho trovato altro che questa discussione... Purtroppo avendo la versione 2010 Sp 2.1 non posso vedere i file :frown:

Detto questo ho provato tutto quello che mi viene in mente (giunto cardanico, riduzione degli accoppiamenti, utilizzo di un asse aggiuntivo al posto della simmetria tra i due alberi agli estremi, impostando un movimento punto per punto manualmente e qualcuna che non mi viene in mente),ma con lo studio di movimento proprio non si vuole muovere...(sfarfalla un po' all'inizio, ma poi si blocca...) Al contrario, ruotandolo manualmente gira che è un piacere indipentenmente dalla parte "cliccata"....

Stesso comportamento con un cardanico singolo o semplice...


chiedo umilmente il vostro aiuto....
punto 1- vincolare a caso non aiuta mai devi farti un seguenza logica da seguire.
Punto 2- ho risolto il tuo problema, il principale problema è accoppiamento del giunto attivo nel movimento(inutile in questo caso), e accoppiamenti angolari, e accoppiamenti degli assi sui piani, come ho risolto, crei un cilindro lo accoppi con gli alberi rossi esterni e li fissi(uno da una parte uno dall altra), togli i vecchi vincoli angolari e accoppi i nuovi componenti fissi con l ' alberi rossi, poi apri la parte verde e su ogni faccia piana fai un triangolo, poi apri la parte rossa e sui piani dove va la verde fai dei triangoli anche li, uguale per la parte oro dove entra la verde fai dei triangoli, ora spiego il perchè, in questo modo non metti vincoli che sovvradefiniscono assieme creando problemi poi nel motion, (il triangoli devono partire dal centro del cerchio) , ora vincoli i vertici dei triangoli corrispondenti al centro coincidenti, poi vincoli asse di uno coincidente all'asse dell'altro, cosi vincoli il verde col rosso e l'oro, ora nascondi i due cilindri fissi, fai un nuovo motion metti il motore al centro sull albero oro imposti la velocità che preferisci... e vedrai tutto andare perfettamente :finger:
allego comunque la mia parte anche se non credo che con la versione 2010 la puoi aprire in quanto uso la 2011
 

Allegati

crestus

Utente poco attivo
Professione: studente
Software: Solidworks 2010 sp2.1 Catia v5 R20
Regione: Piemonte
#3
Innanzitutto Grazie mille! :finger: Davvero!

Purtroppo no, non riesco ad aprire i file...
Il problema è che non sono riuscito a capirci molto dalla tua descrizione... :frown:

Oggi pomeriggio dovrei passare in università... magari lì hanno la versione aggiornata e riesco a vederli... Nel caso, posso poi chiederti di farmi un paio di screenshot? almeno descrizione alla mano e immagini sotto il naso mi studio quello che hai fatto..

Solo per spiegare una cosa: gli accoppiamenti non li ho fatti a caso! (è vero, per fare lo stesso accoppiamento da una parte e dall'altra non ho usato il medesimo sistema)... Sono tutti derivati da idee differenti... sono in realtà 3 configurazioni diverse di accoppiamenti... bisognava spegnere alcuni accoppiamenti per poter ad esempio far funzionare l'accoppiamento "giunto universale"... :wink:

Di nuovo Grazie ! :smile:
 

Ivan1990

Utente Standard
Professione: disegnatore
Software: SolidWorks 2013
Regione: lombardia (brescia)
#4
di niente comunque fammi sapere in caso ti faccio qualche screen, diciamo che accoppiamento del giunto era attivo nell' animazione, magari l hai dimenticato, poi accoppiare un' asse su due piani per vincolarlo in centro, non è il massimo, se devi creare un qualcosa che va nell animazione devi cercare di fare accoppiamenti piu semplici possibili, e che non si contrastino fra loro, in quel caso era sufficente chiudere solo i gradi di libertà che non servivano, cercando di non chiudere più volte gli stessi, per non sovradefinire assieme.

comunque in caso fammi sapere che ti faccio 3 o 4 passi di immagini con piccole e brevi descrizioni.
 

Ivan1990

Utente Standard
Professione: disegnatore
Software: SolidWorks 2013
Regione: lombardia (brescia)
#5
imagine 1/3 triangolo semplice(in teoria servirebbe solo 1 punto nel centro ma Sld non legge il punto come legge il vertice).

immagine assiemeprv accoppi i vertici dei triangoli corrispondenti ai centri dei cilindri con la coincidenza, verde-rosso e verde-oro. accoppi gli assi fra loro coincidenti (al posto di usare il concentrico), per essere più chiaro vertice verde con rosso da una parte poi prendi asse dove hai preso il vertice verde e lo accoppi con asse del foro nel rosso, uguale procedura per l' oro.

fatto questo attivi i tuoi vincoli per inclinazione dei alberi rossi, lasci attivi anche quelli nella cartella posizionamento. metti i due cilindri di "aiuto" accoppi asse del cilindro nuovo con la parte del cilindro rosso, poi metti fissi i due cilindri, disattivi accoppiamenti angolari e l' accoppiamenti con i piani-asse dell' albero intermedio

e ora vai in animazione e metti un motore sull albero intermedio, ora dovrebbe funzionare tutto perfettamente.
 

Allegati

Mike1967

Moderatore CAM
Staff Forum
Professione: Pane e lamiera
Software: Solidworks 2016 sp 5 X 2017 sp 0
Regione: Lombardia, Varese-Canton Ticino, Svizzera
#6
Ho cancellato un paio di chili di accoppiamenti.... non ne capisco nulla
di movimenti, ma prova con questo...
Ciao.


[youtube]AqkNfFUYEPU[/youtube]
 

Allegati

Mike1967

Moderatore CAM
Staff Forum
Professione: Pane e lamiera
Software: Solidworks 2016 sp 5 X 2017 sp 0
Regione: Lombardia, Varese-Canton Ticino, Svizzera
#7
@crestus, dato che non hai la verisone 2011, guarda il video, può darsi che
riesci a risolvere.
[youtube]bBnhIrSkGxs[/youtube]
 

Ivan1990

Utente Standard
Professione: disegnatore
Software: SolidWorks 2013
Regione: lombardia (brescia)
#8
@crestus, dato che non hai la verisone 2011, guarda il video, può darsi che
riesci a risolvere.
[youtube]bBnhIrSkGxs[/youtube]
più che altro con questi accoppiamenti quando i movimenti cominciano a essere di più può creare problemi(esempio robot 6 assi, per quello che in caso di movimenti uso assi e creo triangoli con schizzi per usare i vertici) escono accoppiamenti più precisi che tolgono solo i gradi di libertà inutili, infatti la differenza è con i concentrici se prendi un punto per muoverlo(già a mano si vede) si muove tutto, trammite gli assi e vertici si muove solo asse che tocchi te.
 

crestus

Utente poco attivo
Professione: studente
Software: Solidworks 2010 sp2.1 Catia v5 R20
Regione: Piemonte
#9
Scusate se non ho risposto.... non ho avuto modo di lavorarci ieri....ma ho visto!

Ho ricreato la situazione della prima risposta (per fortuna il poli ha la 2011) però non mi sono ancora messo a "giocare" con gli accoppiamenti...

Adesso mi aggiorno su quello che avete postato e mi metto a lavorare! :D
 

Ivan1990

Utente Standard
Professione: disegnatore
Software: SolidWorks 2013
Regione: lombardia (brescia)
#10
Scusate se non ho risposto.... non ho avuto modo di lavorarci ieri....ma ho visto!

Ho ricreato la situazione della prima risposta (per fortuna il poli ha la 2011) però non mi sono ancora messo a "giocare" con gli accoppiamenti...

Adesso mi aggiorno su quello che avete postato e mi metto a lavorare! :D
buon divertimento xD
 

crestus

Utente poco attivo
Professione: studente
Software: Solidworks 2010 sp2.1 Catia v5 R20
Regione: Piemonte
#11
Alla fine ho scelto una via ibrida!

L'idea vincente è stata quella dei supporti! :finger: accoppiando i loro centri su una circonferenza, i loro assi con due punti coincidenti con i centri dei 2 semi giunti ( ma non referenziati ai pezzi fisici! anche questi sono stati uno schizzo a parte!), impostando l'angolo tra i due assi dei supporti e rendendoli simmetrici: questo è il risultato! :tongue:

[youtube]ZH8f0_pMezE[/youtube]

Uno screen!
 

Allegati

Ultima modifica: