Data creazione files per cartiglio

disperso

Utente Junior
Professione: Disegnatore componenti per l'illuminazione e l'arredamento
Software: Solid Edge ST9
Regione: Toscana
#1
Buonasera a tutti,
spiego meglio il titolo: ad aprile 2014 ho dovuto cambiare macchina per un problema ai dischi, fortunatamente avevo una copia aggiornata di tutti i disegni in SE fino al giorno prima.
Arrivata la nuova WS, copia e incolla e via... "rimasto" come sono, non mi accorgo che tutti i disegni copiati prendono come data di creazione quella della copia, di conseguenza anche quelli ad es del 2006 prendono come data per il cartiglio quella di aprile 2014.
Nel cartiglio, nella sezione data, ho sempre usato "%{Creato|R1}" che è l'unica istruzione che mi ha sempre dato la data giusta.
Ovviamente per i disegni successivi, nessun problema.
Come posso fare per risolvere?
Grazie mille.
 

zeigs

Utente Standard
Professione: Progettista
Software: Solid Edge
Regione: Emilia-Romagna
#2
strano, la copia l'hai fatta con esplora risorse o revision manager? perché con esplora risorse dovrebbe preservare la data di creazione del file.
non è che è la copia di backup ad avere la data di creazione al famoso giorno?
se il backup ha la data giusta, prova a farne una copia da linea di comando con XCOPY usando come opzione /K (mi pare)
 

disperso

Utente Junior
Professione: Disegnatore componenti per l'illuminazione e l'arredamento
Software: Solid Edge ST9
Regione: Toscana
#3
Allora... bischero io che non ci avevo fatto caso... la copia l'avevo fatta direttamente con esplora risorse dal disco su cui avevo fatto il backup... ed in effetti se faccio proprietà su i disegni vecchi, mi viene proprio la famosa data... che poi è la stessa della copia.
Il problema l'ho parzialmente risolto andando a modificare il file del cartiglio e mettendo %{Data di origine|R1} al posto di "data creazione"; quindi se io prendo un 3D di qualsiasi componente vecchio e creo un nuovo disegno la data è quella corretta... però se apro direttamente un draft vecchio, bisogna comunque che visualizzi lo sfondo e che modifichi volta volta la stringa di istruzione.
A questo punto bisogna che scopra se c'è un modo per risolvere la situazione...

Grazie in anticipo.
 

zeigs

Utente Standard
Professione: Progettista
Software: Solid Edge
Regione: Emilia-Romagna
#4
guarda, l'unico modo che abbiamo trovato qua per risolvere la questione della data dei cartigli è metterla a mano, specialmente se nei disegni ci mettono mano diversi disegnatori e, come nel nostro caso, è stato necessario aggiornare diverse volte il server di conseguenza tutti i link (a ora il 90% dei file riporta come data di salvataggio il 2014...). basta creare una proprietà custom nel file (noi abbiamo scelto nel 3D, poi il dft la eredita, ma lo puoi fare anche direttamente nel dft) e ci metti 3 secondi in più, tanto nel cartiglio ci vanno inseriti altri dati sempre a mano, non è un campo in più da riempire che spasta.
unica sfiga: ognuno ha il suo formato preferito per scriverla, ma purtroppo la frusta non è ben vista dalle risorse umane
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
#5
Nei vari spostamenti fatti da noi la data di creazione non è mai cambiata.
E dire che è quella che usiamo sul cartiglio.

Credo dipenda proprio da come vengono spostati i file dalle varie cartelle.

Ciao
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#6
Io utilizzo : %{Data di origine} e non ho mai visto comportamenti strani.
 

disperso

Utente Junior
Professione: Disegnatore componenti per l'illuminazione e l'arredamento
Software: Solid Edge ST9
Regione: Toscana
#7
Prima usavo %{Creato|R1} e non ho mai avuto problemi, nemmeno con gli spostamenti.
Con il problema che si è verificato ho fatto delle prove e sono passato a %{Data di origine|R1} (se non metto R1 non mi funziona), così funziona e l'ho inserito sul template predefinito con il cartiglio in vari formati, però quando vado ad aprire un disegno vecchio si vede che utilizza il template (che poi è lo stesso) vecchio con la dicitura "sbagliata" con cui è stato salvato... quindi mi tocca visualizzare lo sfondo giusto e modificare la stringa della data...
C'è un modo per risolvere questo inconveniente?
 

disperso

Utente Junior
Professione: Disegnatore componenti per l'illuminazione e l'arredamento
Software: Solid Edge ST9
Regione: Toscana
#8
scusate, ho scritto di corsa e non mi sono accorto di aver usato un italiano da teenagers..
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
#9
Io mi sono fatto un programma per aggiornare al volo il cartiglio.

Oggi sono in ferie, domani lo posto.


Ciao