Creazione guidata fori

c._mauro

Utente Junior
Professione: Progettista meccanico
Software: SolidWorks Simulation Premium + Mastercam, MatLab
Regione: Lombardia
#1
Ho questo alberino di una mola pneumatica ed è ultimato, non fosse che devo fare un foro diametro 4 per poi mettere un esagono per poter avvitare con una brugola (Ovviamente dal lato non ancora forato); sta di fatto che posso mettere fori ovunque su quella faccia, tranne che al centro e proprio al centro devo metterlo io.
Non riesco a capire come mai i fori alcune volte me li fa mettere, altre volte no, altre volte solo in posizioni assurde (Anche al di fuori delle superfici).
Consigli? (Magari essendo relativamente nuovo del software sbaglio qualcosa, il corso che la mia azienda mi fornisce purtroppo parte tra un mese ed io intanto non posso non lavorare...).
Grazie, Mauro
 

Allegati

Skywalker

Utente poco attivo
Professione: hmmm
Software: Solidworks2007, AlphacamV7
Regione: Bari
#2
Ho questo alberino di una mola pneumatica ed è ultimato, non fosse che devo fare un foro diametro 4 per poi mettere un esagono per poter avvitare con una brugola (Ovviamente dal lato non ancora forato); sta di fatto che posso mettere fori ovunque su quella faccia, tranne che al centro e proprio al centro devo metterlo io.
Non riesco a capire come mai i fori alcune volte me li fa mettere, altre volte no, altre volte solo in posizioni assurde (Anche al di fuori delle superfici).
Consigli? (Magari essendo relativamente nuovo del software sbaglio qualcosa, il corso che la mia azienda mi fornisce purtroppo parte tra un mese ed io intanto non posso non lavorare...).
Grazie, Mauro
purtroppo non posso vedere il disegno in quanto ho la versione 2007, non ti nascondo che questo problema si presenta anche sulla mia versione ho risolto con un piccolo artifizio: crea un piano parallelo alla faccia su cui devi fare il foro e distanzialo di 1mm dopo di che inserisci lo schizzo sul piano e quando dai la profondità del foro (a meno che non sia passante) ricordati che il piano è distante dalla superficie di 1mm e vedrai che risolvi.
Se poi qualcuno più esperto sa un metodo migliore ben venga :biggrin:
 

c._mauro

Utente Junior
Professione: Progettista meccanico
Software: SolidWorks Simulation Premium + Mastercam, MatLab
Regione: Lombardia
#3
Ho risolto in un altro modo: piazzo il foro a caso sulla superficie da dove deve partire e metto due quote intelligenti dando "0" come valore e quindi vincolandolo al centro, in questo caso ha funzionato.
Detto ciò è una cosa strana che se per esempio metto il primo foro a caso il secondo me lo fa mettere anche al centro... è forse un bug?
 

meccanicamg

Utente Senior
Professione: ♔ Technical manager - Mechanical engineer ♚
Software: SolidWorks, DraftSight, Me10, Freecad, KissSoft, Excel
Regione: Lombardia
#4
Per fare i fori NON DEVI fare lo schizzo prima.

Il comanco creazione guidata fori lavora in due modi:
- cliccare sulla superficie e poi cliccare su creazione guidata fori (foratura definita in 2d)
- cliccare su creazione guidata fori e poi cliccare sulla superficie (foratura definita 3d)

Quando si completa la definizione foro e si passa alla scheda per il posizionamento ovviamente il primo foro è lì piantato laddove nella foratura 2d avete cliccato sul piano. Quindi eliminare quel puntino e riattivare la matita e posizionare il punto al centro dell'albero.

Funziona tutto correttamente, sia sul modello che come procedura. Nessun bug. Eventualmente leggere la guida ci creazione guidata fori.
 

c._mauro

Utente Junior
Professione: Progettista meccanico
Software: SolidWorks Simulation Premium + Mastercam, MatLab
Regione: Lombardia
#5
Per fare i fori NON DEVI fare lo schizzo prima.

Il comanco creazione guidata fori lavora in due modi:
- cliccare sulla superficie e poi cliccare su creazione guidata fori (foratura definita in 2d)
- cliccare su creazione guidata fori e poi cliccare sulla superficie (foratura definita 3d)

Quando si completa la definizione foro e si passa alla scheda per il posizionamento ovviamente il primo foro è lì piantato laddove nella foratura 2d avete cliccato sul piano. Quindi eliminare quel puntino e riattivare la matita e posizionare il punto al centro dell'albero.

Funziona tutto correttamente, sia sul modello che come procedura. Nessun bug. Eventualmente leggere la guida ci creazione guidata fori.
Perfetto, darò un occhiata alla guida allora.
 

sampom

Moderatore SWX, Navale
Staff Forum
Professione: Progettazione/Costruzione macchine e impianti
Software: SolidWorks 2015 SP5/2016 SP2, AutoCAD (poco)
Regione: Piemonte (CN)
#6
Ho risolto in un altro modo: piazzo il foro a caso sulla superficie da dove deve partire e metto due quote intelligenti dando "0" come valore e quindi vincolandolo al centro, in questo caso ha funzionato.
Anche senza mettere le quote;
metti il punto del foro dove vuoi su quella faccia (ma senza fare dei punti in altri schizzi esterni, lavora tutto nella creazione fori) poi lo selezioni e trascini sul centro (che è anche origine), lì si blocca e prende i vincoli.. e funziona.

Saluti
Marco
 

c._mauro

Utente Junior
Professione: Progettista meccanico
Software: SolidWorks Simulation Premium + Mastercam, MatLab
Regione: Lombardia
#7
Anche senza mettere le quote;
metti il punto del foro dove vuoi su quella faccia (ma senza fare dei punti in altri schizzi esterni, lavora tutto nella creazione fori) poi lo selezioni e trascini sul centro (che è anche origine), lì si blocca e prende i vincoli.. e funziona.

Saluti
Marco
Provato, si funziona ed è questa la soluzione più intuitiva e rapida!
Ottimo!
Grazie mille.