Creazione di parametri nelle parti di un assemblato

Checco 79'

Utente Junior
Professione: Meccanico
Software: Pro-Engineer Wildfire 5.0
Regione: rincorro il lavoro
#1
Ciao a tutti.

Ho la necessità di inserire dei parametri identici in tutte le parti e i sotto assiemi che compongono il progetto.
Poichè sono parecchi elementi, esiste un modo per farlo direttamente dall'assemblato generale senza aprire le parti una ad una e scrivere i singoli parametri per ogni file.

Grazie
 

Checco 79'

Utente Junior
Professione: Meccanico
Software: Pro-Engineer Wildfire 5.0
Regione: rincorro il lavoro
#3
Ciao.


Ho provato a fare la macro ma devo aprire ogni modello e sono riuscito a generare i parametri attivando i modelli e lanciando la macro.
esiste un modo per fare una macro si lancia in automatico su tutti i modelli di un assemblato?

Grazie.
 

Ozzy

Guest
#4
Ciao.


Ho provato a fare la macro ma devo aprire ogni modello e sono riuscito a generare i parametri attivando i modelli e lanciando la macro.
esiste un modo per fare una macro si lancia in automatico su tutti i modelli di un assemblato?

Grazie.
No non esiste il modo per fare quello che vuoi tu come ti ho detto bisogna configurarsi modelcheck.
 

zimmy

Utente Standard
Professione: non l'ho mai capito
Software: icone e menu
Regione: lombardia
#5
si può modificare la finestra dell'albero modello relativo all'assieme
Impostazioni / Colonne albero /
Tipo = Param Model
e scegli i parametri dei modelli che vuoi vedere nell'albero modello
poi puoi scrivere direttamente nel campo che vedi nell'albero modello per modificare il parametro della parte.
Può andare ?
 
Ultima modifica:

Ozzy

Guest
#6
si può modificare la finestra dell'albero modello relativo all'assieme
Impostazioni / Colonne albero /
Tipo = Param Model
e scegli i parametri dei modelli che vuoi vedere nell'albero modello
poi puoi scrivere direttamente nel campo che vedi nell'albero modello per modificare il parametro della parte.
Può andare ?
Il problema è che deve averlo il parametro zimmy, se non ce l'ha non può scrivere nulla e deve crearselo prima.
 

whitet

Guest
#7
Il problema è che deve averlo il parametro zimmy, se non ce l'ha non può scrivere nulla e deve crearselo prima.
basta crearli per il top assembly, per i sottocomponenti, al click in colonna, viene creato da proe :wink:
purtroppo ogni volta ti chiede il tipo dato se ricordo bene....
 
Ultima modifica:

whitet

Guest
#10
Comunque... una macro si può fare però bisogna disattivare la nuova interfaccia dei parametri...
nell'ordine

Macro dis_parametri
Macro att_parametri
Macro crea_parametri

Macro di lancio che concatena le le macro sopra nell'ordine:
Macro dis_parametri
Macro crea_parametri
Macro att_parametri

così funziona!
 

zimmy

Utente Standard
Professione: non l'ho mai capito
Software: icone e menu
Regione: lombardia
#11
si avevo dimenticato di dire che (arrivo tardi ?), se mancanti, i parametri si possono creare ... al volo , ma sempre rimanendo in ambiente assembly e senza aprire le parti.
Mi è sempre sembrato un sistema semplice, comodo e efficace.
Ciao
 

AK-47

Utente Standard
Professione: searching...
Software: SolidWorks -ProE
Regione: Lombardia
#12
si può modificare la finestra dell'albero modello relativo all'assieme
Impostazioni / Colonne albero /
Tipo = Param Model
e scegli i parametri dei modelli che vuoi vedere nell'albero modello
poi puoi scrivere direttamente nel campo che vedi nell'albero modello per modificare il parametro della parte.
Può andare ?
Ma i parametri personalizzati (quelli aggiunti da me) non riesco a trovarli. Ci sono solo quelli impostati di default dal sistema (per intenderci del tipo PTC_....)

E già che ci sono, come faccio a impostare l'albero in modo che compaiano sempre all'apertura della parte/assieme?

Ciao e buon lavoro
 

Ozzy

Guest
#13
i parametri definiti da utente li devi scrivere tu nella colonna info e poi ti compaiono.
Per salvarli, fai salva impostazione dell'albero(tree.cfg) lo gestisce la chiave:
mdl_tree_cfg_file con il suo percorso nel config, punti il file che hai salvato nel disco locale.
 

AK-47

Utente Standard
Professione: searching...
Software: SolidWorks -ProE
Regione: Lombardia
#14
Ciao ozzy,

intanto grazie, ma non capisco come posso scriverli nella colonna info.

Non posso scrivere nulla come vedi nell'immagine allegata. Posso solo spostare verso dx e viceversa i parametri che mi visualizza

Per il tree config avevo risolto dopo aver messo il commento.

Ciao
 

Allegati

AK-47

Utente Standard
Professione: searching...
Software: SolidWorks -ProE
Regione: Lombardia
#15
Risolto. Non avevo messo gli stessi parametri delle parti anche nell'assieme, e quindi non me li vedeva.

Grazie a tutti e buona giornata!