corretto utilizzo di Set con i rispettivi vincoli

falonef

Moderatore CATIA V5
Staff Forum
Professione: PLM Support Expert (Consumer Goods)
Software: CATIA V5 / PARTsolutions / QA-Report / Q-Checker / Type3toCatia / Agile-PLM / Windows 10
Regione: Svizzera
#1
salve a tutti,
ho un problem che mi attanaglia da un po' di tempo.

Come posso utilizzare i Set con i rispettivi vincoli in modo corretto?

Ecco una documentazione
 

Allegati

Ultima modifica:

falonef

Moderatore CATIA V5
Staff Forum
Professione: PLM Support Expert (Consumer Goods)
Software: CATIA V5 / PARTsolutions / QA-Report / Q-Checker / Type3toCatia / Agile-PLM / Windows 10
Regione: Svizzera
#2
salve,
nessuno ha lo stesso mio problema?
 

barlafus

Utente Standard
Professione: chairwarmer
Software: utilizzato dal CAD
Regione: .
#3
Ciao Falonef,
premetto che non me ne intendo molto di tematiche di assembly, quindi una castronata bella e buona ci puo' stare, pero': guardando il tuo documento, secondo me catia non sbaglia, ovvero, spostando i componenti in un set, catia ti sposta i vincoli tra i componenti interessati ma non e' in grado (e secondo me non e' un errore) di spostare ache i vincoli che legano i tre componenti spostati con i tre componenti che restano al livello del product padre; ho notato che "rinomina i vincoli rimanenti in "set1"- F 2... , quindi sta vincolando non piu' i componenti tra loro ma il set con un componente.

...se poi ho capito bene, continuo...

ovviamente con un "errore" di questa natura, quando provi a posizionare/duplicare con la matrice, si porta dietro l'errore.

Siccome il problema nasce dai vincoli non-spostabili, prova a
verificare se il set puo' diventare flessibile, magari e' una soluzione...
 

falonef

Moderatore CATIA V5
Staff Forum
Professione: PLM Support Expert (Consumer Goods)
Software: CATIA V5 / PARTsolutions / QA-Report / Q-Checker / Type3toCatia / Agile-PLM / Windows 10
Regione: Svizzera
#4
Ciao Barlafus,
grazie per il tuo interessamento.
Hai ben afferrato il concetto.
Io ho provato di tutto, rigido, flessibile. publicazioni, sets ...

ma niente, al momento di duplicare gli oggetti ho degli errori con i vincoli.

Se qualcun'altro ha un idea...
 
Ultima modifica:
Professione: Progettista meccanico
Software: Catia, Think3
Regione: Marche
#5
io di solito uso questi settaggi.

ciao
 
Ultima modifica:

falonef

Moderatore CATIA V5
Staff Forum
Professione: PLM Support Expert (Consumer Goods)
Software: CATIA V5 / PARTsolutions / QA-Report / Q-Checker / Type3toCatia / Agile-PLM / Windows 10
Regione: Svizzera
#6
ciao ferrezio,
la matrice l'hai creata con un operazione circolare o lineare?
 

falonef

Moderatore CATIA V5
Staff Forum
Professione: PLM Support Expert (Consumer Goods)
Software: CATIA V5 / PARTsolutions / QA-Report / Q-Checker / Type3toCatia / Agile-PLM / Windows 10
Regione: Svizzera
#8
io l'ho creata in modo circolare e pensavo che per questo avevo il problema
 

falonef

Moderatore CATIA V5
Staff Forum
Professione: PLM Support Expert (Consumer Goods)
Software: CATIA V5 / PARTsolutions / QA-Report / Q-Checker / Type3toCatia / Agile-PLM / Windows 10
Regione: Svizzera
#10
salve,
per chi avesse il mio stesso problema, si tratta di settare un'opzione.
Io avevo "Always with assembly constraints":
 

Allegati

MAXUS

Utente Junior
Professione: Meccanica
Software: V4-V5 / SE v14
Regione: F.V.G.
#11
salve,
per chi avesse il mio stesso problema, si tratta di settare un'opzione.
Io avevo "Always with assembly constraints":
Ciao a tutti,

trovo utile anche la terza opzione, in modo particolare quando si ha bisogno di riorganizzare un prodotto composto da un grande numero di parti giá vincolate tra loro in sottoprodotti piú piccoli.
CIAO :)