• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

Configurazione GBG Draftmaker V7.0

damarino

Utente poco attivo
Professione: Progettista
Software: GBG v.6
Regione: Italia
#1
Buongiorno a tutti,
sono un disegnatore di una piccola azienda metalmeccanica dove utiliziamo GBG 6.0.

Ho attivato la versione DM V7.0D del software che si avvia correttamente.
Quando però dal menu file, lancio il comando "Carica Vista File", non si apre alcuna finestra di dialogo e la finestra di supporto di GBG (quello dove compare il listato dei comandi eseguiti) si blocca obbligandomi a chiudere forzatamente il programma da "Avvia gestione attività" di Windows 7.

Spero che qualcuno possa aiutarmi a configurare il programma, consentendogli di accedere al percorso dove i ns. disegni sono archiviati.

Grazie a tutti per l'aiuto. :smile:
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#2
Spero che qualcuno possa aiutarmi a configurare il programma, consentendogli di accedere al percorso dove i ns. disegni sono archiviati.

Grazie a tutti per l'aiuto. :smile:
Hai disabilitato UAC?

Dove hai installato il programma? Mi sembra di ricordare che sotto c:\programmi (x86) non funziona, invece avendolo messo in c:\think3\ funziona bene (pero' io ho la versione 8.1, anche se non credo faccia una gran differenza). Gia' che ci sei prova a dare all'utente corrente i permessi completi sulla cartella di installazione del programma....
 

damarino

Utente poco attivo
Professione: Progettista
Software: GBG v.6
Regione: Italia
#3
Ciao Cacciatorino,
grazie per la risposta.

Ho fatto come hai detto.

Dopo aver disabilitato in Win 7 Professional 64 bit la UAC, GBG 7.0 mi ha chiesto di nuovo la registrazione del programma (DM Run Time + inserimento nome + inserimento password) e si è avviato, ma il problema persiste.

Riguardo agli attributi cartella (che si trova nella radice del disco C: al seguente percorso C:\CADLAB\DM70), ho notato che Win 7 mi evidenzia con un quadrato azzurro l'attributo LETTURA: ho provato a toglierlo, ma nonostante le credenziali di Amministratore, continua a ricomparire. Tuttavia, nella cartella C:\CADLAB\DM60 c'è GBG60, che però funziona anche se rimane puntato l'attributo lettura.

Ho provato a cercare un file .ini da modificare ma l'unico che trovo (dm.ini)
ha le stesse istruzioni di quello di GBG 6.0 (tranne ovviamente che per i nomi delle sottocartelle): questo è quanto riporta:

GBG V7.0
*
** ESEMPIO di file di inizializzazione per PC WINDOWS NT - 95
** (per usare tale file, sostituire DIRCAD con la radice
** d'installazione, quindi inserire le chiavi desiderate
** scommentando le varie righe ed aggiungere alla stringa
** di lancio la chiave -INI <path-name file di ini> )
*
* MSG DIRCAD\dm70\files\dm.msg
* MSG 1 DIRCAD\dm70\files\parl.msg
* MSG 2 DIRCAD\dm70\files\prm.msg
* DRC \disegni
* TOL 0 0.6 0.2
* QVP 1
* UNI DIRCAD\dm70\files\uni.tab
*
* PRO GBG
* PLD DIRCAD\dm70\files\dmini
* PRC init
* END

Hai altri suggerimenti?
Grazie
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#4
Riguardo agli attributi cartella (che si trova nella radice del disco C: al seguente percorso C:\CADLAB\DM70), ho notato che Win 7 mi evidenzia con un quadrato azzurro l'attributo LETTURA: ho provato a toglierlo, ma nonostante le credenziali di Amministratore, continua a ricomparire. Tuttavia, nella cartella C:\CADLAB\DM60 c'è GBG60, che però funziona anche se rimane puntato l'attributo lettura.

Piu' che togliere l'attributo lettura, dovresti aggiungere quello "scrittura"....

Ma il problema e' relativo al "UI-Server"? Vado a memoria, l'ho risolto tanto tempo fa e poi non si e' mai piu' verificato. non ricordo di aver fatto altro speciale.

Puoi scrivere cosa ti appare nella finestra di I/O quando il programma si pianta?
I driver della chiave hardware sono aggiornati?
 

damarino

Utente poco attivo
Professione: Progettista
Software: GBG v.6
Regione: Italia
#5
In allegato file relativo alla finestra di dialogo bloccata.

Ho controllato anche i driver della chiavetta (la mia è di tipo USB) e risultano aggiornati:
- SafeNet Inc. Hardlock Key 6.22.0.0 del 01/12/2011
- SafeNet Inc. USB Key 6.22.0.0 del 01/12/2011
 

Allegati

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#6
In allegato file relativo alla finestra di dialogo bloccata.

Ho controllato anche i driver della chiavetta (la mia è di tipo USB) e risultano aggiornati:
- SafeNet Inc. Hardlock Key 6.22.0.0 del 01/12/2011
- SafeNet Inc. USB Key 6.22.0.0 del 01/12/2011

anche io ho una chiavetta USB. comunque se fosse un problema di mancato riconoscimento della chiave, ti apparirebbe un messaggio nella finestra.

Dalla schermata non si vede niente di strano. Forse il problema e' nella versione V7.0 che non va e invece la 8.1 si?

come'e' la stringa di lancio che trovi nell'icona da cui fai partire il programma? la mia e':

Codice:
C:\think3\dm81\bin\dm.exe -lang i
Se tu invece hai cose aggiunte, cioe' indirizzi a file di personalizzazione vari, prova a rimuoverli, e rilanciare il cad.

P.S. per caso hai trasportato le personalizzazioni dell'utente che anticamente alla CadLAB mettevano sotto c:\user\nome_utente? Questo percorso su seven e' gia' occupato dal sistema operativo, per cui le cartelle relative all'utente di GBG-DM si disperdono in mezzo agli altri file dell'utente (poco male).
Prova a creare un nuovo utente di windows e vedi se con quello funziona.
 

damarino

Utente poco attivo
Professione: Progettista
Software: GBG v.6
Regione: Italia
#7
anche io ho una chiavetta USB. comunque se fosse un problema di mancato riconoscimento della chiave, ti apparirebbe un messaggio nella finestra.

Dalla schermata non si vede niente di strano. Forse il problema e' nella versione V7.0 che non va e invece la 8.1 si?

come'e' la stringa di lancio che trovi nell'icona da cui fai partire il programma? la mia e':

Codice:
C:\think3\dm81\bin\dm.exe -lang i
Se tu invece hai cose aggiunte, cioe' indirizzi a file di personalizzazione vari, prova a rimuoverli, e rilanciare il cad.

P.S. per caso hai trasportato le personalizzazioni dell'utente che anticamente alla CadLAB mettevano sotto c:\user\nome_utente? Questo percorso su seven e' gia' occupato dal sistema operativo, per cui le cartelle relative all'utente di GBG-DM si disperdono in mezzo agli altri file dell'utente (poco male).
Prova a creare un nuovo utente di windows e vedi se con quello funziona.
La mia stringa di lancio non ha parametri aggiuntivi
C:\cadlab\dm70\bin\dm.exe

Circa la cartella delle personalizzazioni ho trovato il seguente file nel percorso
C:\Users\Utente\dm70\dm_conf.prc di cui allego il contenuto:

#PROCEDURE SET_SETAMBIENTE
*
gb_s_pc(P_CDIRD,"c:/cadlab/dm70")
gb_s_pc(P_CDIRP," ")
gb_s_pc(P_CLIBR,"c:/cadlab/dm70/libsim.dl")
gb_s_pc(P_UNIFIL,"c:/cadlab/dm70/files/uni.tab")
gb_s_pc(DMP_ASNAME,"DMautosv.d")
gb_s_pc(dmp_cnfrepl,1)
*
#END

Ho inoltre notato che nella maschera "Ambiente" della maschera Preferenze (attivabile dal menù Opzioni del programma), c'è il campo Cartelle che ha due sottocampi:
- il primo si chiama "Disegni:" e contiene il seguente percorso c:/cadlab/dm70
- il secondo si chiama "Procedure:" ed è vuoto.
Mi viene da pensare che si debba mettere qualcosa in "Procedure" per dire a GBG come gestire il percorso riportato nel campo "Disegni".

Ho provato anche a creare un nuovo utente, ma non funziona. :mad: