• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

Come si fa ad impostare i settaggi personalizzati di default????

Noda

Utente poco attivo
Professione: Responsabile tecnico
Software: ProE WF3/4 solidworks2008
Regione: Lombardia
#1
Ciao a tutti ,vi sembrerà una domanda da principiante ma potete dirmi come si fa a salvare tutte le impostazioni grafiche tipo colore di sfondo ecc. e le impostazioni dei menu' in modo che quando riapro il programma me le carichi di default????

in + come si fa a creare funzioni particolari e renderle praticabili tramite un icona nel menu (es:mi avevano fatto un icona che se selezionata spegneva o accendeva tutti gli elementi di riferimento come i piani i punti i sysco gli assi ecc.)???

il tipo che mi ha insegnato ad usare proe mi aveva gia caricato tutte le sue impostazioni e mi trovavo benissimo ma adesso che ho cambiato ditta e ho le impostazioni di default non riesco + fare molte cose perchè non trovo i comandi o per lo meno devo andare a spulciare tutti i menu' prima di trovarli.

grazie per le future risp.

il software che uso è ProE Wf4
 

apple

Utente Standard
Professione: in sviluppo
Software: Spider FreeCell Pro_E
Regione: Lombardia
#2
Ciaio
-1- il file config.win contiene tutte le configurazioni delle finestre pro_e.
-2-crei una macro (strumenti > macro). Vai in strumenti > personalizza schermo > comandi > categoria macro e trasli l'icona nelle barra dei comandi. L'icona può essere personalizzata. Ricordati di salvare il config.win per non perdere le nuove impostazioni.
-3-non ti sei portato via il config.win, il config. pro ecc.?
-4- prova e fare una ricerca nella sezione Pro/e configurazione; utilizza come chiave "config". Dovresti trovare informazioni interessanti.
Ciao
 

Noda

Utente poco attivo
Professione: Responsabile tecnico
Software: ProE WF3/4 solidworks2008
Regione: Lombardia
#3
Grazie x la risp.
purtroppo non ho portato via il config. sia xkè non ci ho pensato sia xkè quando ho cambiato pensavo di usare "solo" solidworks,in + la "sfig.@" è che prima avevo il WF3 e adesso ho il WF4 quindi non sò se sarebbe andato bene lo stesso,,,,,,cmq meglio cosi' almeno imparo qualcosa di nuovo!!!!
stassera provo a mettere in opera i consigli,grazie!!!
 

apple

Utente Standard
Professione: in sviluppo
Software: Spider FreeCell Pro_E
Regione: Lombardia
#4
Generalmente i files di configurazione vanno sempre bene; potrebbero esserci alcuni problemi con le macro salvate nel config.pro
 

Ozzy

Guest
#5
Generalmente i files di configurazione vanno sempre bene; potrebbero esserci alcuni problemi con le macro salvate nel config.pro
Esatto, ma solitamente da un passaggio solo di versione all'altro WF3/WF4, non ci sarebbero stati problemi,diverso se fosse stato da proe2001 a WF4.:D
 

Noda

Utente poco attivo
Professione: Responsabile tecnico
Software: ProE WF3/4 solidworks2008
Regione: Lombardia
#6
Ciao ho appena finito di provare a mettere in opera i consigli,e x quanto riguarda il fare macro da mettere nei menu' ho risolto alla grande,e mi tiene tutto in memoria nel rientrare.

Mi rimane xò il problema x le impostazioni di visualizzazione cioè:

vado su visualizza>imp. vis.>colori sistema>personalizzo i colori>salvo un file syscool.scl
poi vado anche su visualizzazioni modello e personalizzo alcune cose tipo il tempo di animazione e che voglio vedere i riferimenti mentre muovo il pezzo ma li non ho possibilità di salvare alcun file.

Per sicurezza dopo aver fatto tutte le modifiche vado a salvare il config.win

Poi tutto contento della "customizzazione" esco e nel rientrare... ta-taaa.. mi ritorna ancora come prima,ke culØ!!!

Se non avete voglia di rispondere a questi problemini da poco vi capisco e andrò a cercare in giro nel forum cmq grazie ancora x le risp.
 
Ultima modifica:

maxopus

Mod. Creo e Reverse Eng.
Staff Forum
Professione: Progettista meccanico
Software: Creo Parametric
Regione: Marche (PU)
#7
Grazie x la risp.
purtroppo non ho portato via il config. sia xkè non ci ho pensato sia xkè quando ho cambiato pensavo di usare "solo" solidworks,in + la "sfig.@" è che prima avevo il WF3 e adesso ho il WF4 quindi non sò se sarebbe andato bene lo stesso,,,,,,cmq meglio cosi' almeno imparo qualcosa di nuovo!!!!
stassera provo a mettere in opera i consigli,grazie!!!
Il fatto che tu debba usare Pro/E non considerarla una sfiga.
Un disegnatore/progettista che sappia utilizzare diversi programmi è molto più appetibile e dimostra più elasticità mentale e volontà di apprendimento.

La WF4 differisce molto poco dalla WF3 in questo senso e l'interfaccia è rimasta sostanzialmente la stessa.

Imparare a saper settare un programma secondo le proprie esigenze è importante ... quindi piano piano cerca di capire come si fa, perchè ad ogni nuovo progetto potrebbero cambiare le tue esigenze e sarà importante saperle tradurre in modalità operative.
 

Ozzy

Guest
#8
Ciao ho appena finito di provare a mettere in opera i consigli,e x quanto riguarda il fare macro da mettere nei menu' ho risolto alla grande,e mi tiene tutto in memoria nel rientrare.

Mi rimane xò il problema x le impostazioni di visualizzazione cioè:

vado su visualizza>imp. vis.>colori sistema>personalizzo i colori>salvo un file syscool.scl
poi vado anche su visualizzazioni modello e personalizzo alcune cose tipo il tempo di animazione e che voglio vedere i riferimenti mentre muovo il pezzo ma li non ho possibilità di salvare alcun file.

Per sicurezza dopo aver fatto tutte le modifiche vado a salvare il config.win

Poi tutto contento della "customizzazione" esco e nel rientrare... ta-taaa.. mi ritorna ancora come prima,ke culØ!!!

Se non avete voglia di rispondere a questi problemini da poco vi capisco e andrò a cercare in giro nel forum cmq grazie ancora x le risp.
I colori di sfondo non centrano con il config.win, quello appunto è gestito dal file :
syscol.scl

Per farlo funzionare correttamente devi settare nel config.pro questa chiave:
system_colors_file e come valore gli dai il percorso nel tuo hd dove l'hai salvato, al prossimo riavvio vedrai che ti prende anche quello.
Saluti Ozzy
 

maxopus

Mod. Creo e Reverse Eng.
Staff Forum
Professione: Progettista meccanico
Software: Creo Parametric
Regione: Marche (PU)
#9
Ciao ho appena finito di provare a mettere in opera i consigli,e x quanto riguarda il fare macro da mettere nei menu' ho risolto alla grande,e mi tiene tutto in memoria nel rientrare.

Mi rimane xò il problema x le impostazioni di visualizzazione cioè:

vado su visualizza>imp. vis.>colori sistema>personalizzo i colori>salvo un file syscool.scl
poi vado anche su visualizzazioni modello e personalizzo alcune cose tipo il tempo di animazione e che voglio vedere i riferimenti mentre muovo il pezzo ma li non ho possibilità di salvare alcun file.

Per sicurezza dopo aver fatto tutte le modifiche vado a salvare il config.win
Poi tutto contento della "customizzazione" esco e nel rientrare... ta-taaa.. mi ritorna ancora come prima,ke culØ!!!

Se non avete voglia di rispondere a questi problemini da poco vi capisco e andrò a cercare in giro nel forum cmq grazie ancora x le risp.
Il config.win .... lo salvi nella directory giusta ?
Perchè se lo salvi in una directory diversa da quella di partenza del programma ... le modifiche non vengono lette.
 

Noda

Utente poco attivo
Professione: Responsabile tecnico
Software: ProE WF3/4 solidworks2008
Regione: Lombardia
#10
Il fatto che tu debba usare Pro/E non considerarla una sfiga.
Un disegnatore/progettista che sappia utilizzare diversi programmi è molto più appetibile e dimostra più elasticità mentale e volontà di apprendimento.

La WF4 differisce molto poco dalla WF3 in questo senso e l'interfaccia è rimasta sostanzialmente la stessa.

Imparare a saper settare un programma secondo le proprie esigenze è importante ... quindi piano piano cerca di capire come si fa, perchè ad ogni nuovo progetto potrebbero cambiare le tue esigenze e sarà importante saperle tradurre in modalità operative.

Scusa ma mi sa ke non mi sono espresso bene,
non intendevo che è una sfiga che debba usare anche ProE anzi!!!!!! ne sono stracontento,anche perchè concordo con quello che dici riguardo al sapere usare + programmi,pensavo solo che cambiando dalla WF3 alla WF4 non sarebbe andato bene il config.

Cmq facendo stampi,trovandomi a litigare con matematiche aperte e a togliere i fastidiosi raggi per poter sformare il pezzo,ho visto dei cambiamenti notevoli nella Wf4,fosse uscita prima chissà le ore di sclero che potevo risparmiarmi!!!!!!!!!!!!!

Ciao Noda
 

Noda

Utente poco attivo
Professione: Responsabile tecnico
Software: ProE WF3/4 solidworks2008
Regione: Lombardia
#11
I colori di sfondo non centrano con il config.win, quello appunto è gestito dal file :
syscol.scl

Per farlo funzionare correttamente devi settare nel config.pro questa chiave:
system_colors_file e come valore gli dai il percorso nel tuo hd dove l'hai salvato, al prossimo riavvio vedrai che ti prende anche quello.
Saluti Ozzy

-Infatti lo sospettavo ma non sapevo + dove andare a sbattere!!!


-Allora stasse provo a smanettare il config.pro

Grazie 1000 !!
 

Noda

Utente poco attivo
Professione: Responsabile tecnico
Software: ProE WF3/4 solidworks2008
Regione: Lombardia
#12
Ok per i colori ho risolto mettendo a posto il config.pro

rimane tuttavia il problema in visualizza>imp. di vis.>visualiz.modello
non mi tiene in memoria le impostazioni,ho controllato che il config.win sia salvato nella dir. giusta e lo prova il fatto che mi carica i menu personalizzati

booo non saprei cosa pensare .... qualk1 ha consigli?????

grazie a tutti x la collaborazione!!!!


ciao Noda
 

Ozzy

Guest
#13
Per le altre impostazioni sempre nel config.pro setta queste chiavi:

Per il tempo di animazione:
max_animation_time e valore quello che desideri esempio 0.5
Per la visibilità dei riferimenti mentre ruoti:
spin_with_part_entities su yes

Ozzy
 

Noda

Utente poco attivo
Professione: Responsabile tecnico
Software: ProE WF3/4 solidworks2008
Regione: Lombardia
#14
Riiiiiiiiiisoltoooooo
grazie mille ora va tutto alla perfezione!!!!

ma x curiosità ,in caso servisse in futuro,dove trovo i vari comandi per personalizzare il config.pro?????


grazie ancora!!
 

maxopus

Mod. Creo e Reverse Eng.
Staff Forum
Professione: Progettista meccanico
Software: Creo Parametric
Regione: Marche (PU)
#15
Nella directory
C:\DIRECTORY_DI_INSTALLAZIONE\html\italian\proe\helpSysTop\siteset
c'è il file configoptions.pdf
contenente l'elenco di tutte le opzioni