• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

Cartiglio

Prima

Utente Junior
Professione: Progettista
Software: Solid Edge; Autocad, Jetcam, Alphacam
Regione: Toscana
#1
Buongiorno,

Ho rifatto il mio cartiglio aziendale, ma ho un problemino. Passando indistintamente tra part e sheet metal ci sono delle variabili che ci sono in un ambiente e non ci sono nell'altro.....

Esempio veloce: Lo spessore della lamiera , o il suo sviluppo non ci possono essere in ambiente part ( a meno che non mi crei delle variabili di comodo ).
A questo punto nel cartiglio mi appare al posto di spessore lamiera e sviluppo
" Errore : Nessun Riferimento " , cosa a me molto sgradita. E' possibile far si che nel caso in cui si verifichi questa condizione invece del messaggio di errore mi appaia un simbolo qualsiasi? Tipo un punto interrogativo o simile


Ciao
e Grazie
 

Tequila

Utente Senior
Professione: teorico del paleocontatto
Software: Solid Edge ST7, scarabocchi su carta
Regione: Veneto (PD)
#2
in teoria se imposti le stesse voci dovrebbe mostrarti il valore se c'è, e se non c'è ti lascia la casella vuota, senza nessun messaggio di errore.

Per dirti io per indicare le dimensioni sul cartiglio sulle variabili dei modelli quando spunto la voce sul nome esposto la rinomino con SPESSORE.
Nel draft la voce di richiamo sarà %{SPESSORE|R1}.

Se faccio un modello par e non espongo nessuna variabile, se metto in tavola e richiamo la voce %{SPESSORE|R1} mi lascia la casella vuota
 

ilbruni

Utente Junior
Professione: Disegnatore CAD
Software: SolidEdge, Autocad
Regione: Sicilia
#3
Io ho creato cartigli diversi. Avevo lo stesso problema esposto da Prima, ed in più quando richiamavo gli ASM mi ritrovavo con il tipo di materiale che si incasinava.
Adesso ho vari cartigli, ma attendo di passare a breve alla versione ST2 (sono abbastanza terrorizzato).
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#4
Buongiorno,

Ho rifatto il mio cartiglio aziendale, ma ho un problemino. Passando indistintamente tra part e sheet metal ci sono delle variabili che ci sono in un ambiente e non ci sono nell'altro.....

Esempio veloce: Lo spessore della lamiera , o il suo sviluppo non ci possono essere in ambiente part ( a meno che non mi crei delle variabili di comodo ).
A questo punto nel cartiglio mi appare al posto di spessore lamiera e sviluppo
" Errore : Nessun Riferimento " , cosa a me molto sgradita. E' possibile far si che nel caso in cui si verifichi questa condizione invece del messaggio di errore mi appaia un simbolo qualsiasi? Tipo un punto interrogativo o simile


Ciao
e Grazie
Hai provato a creare la variabile "spessore" nel template normal.par? Magari poi gli assegni un valore nullo o un segno "-".

cosi' tutte le nuove parti create a partire dal normal.par erediteranno quella variabile.

Invece quando crei una parte da un template normal.psm lavorerai come al solito.