• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

BACO SOLIDWORKS O NORMATIVA CAMBIATA - FILETTATURE

meccanicamg

Utente Senior
Professione: ♔ Technical manager - Mechanical engineer ♚
Software: SolidWorks, DraftSight, Me10, Freecad, KissSoft, Excel
Regione: Lombardia
#1
Vorrei postare una cosa singolare.

VERSIONE: SolidWorks 2009 x64 sp 4.0 e su Solidworks 2010 x64 sp 2.0

PROBLEMA: le filettature STANDARD dell'ISO e della DIN metriche hanno le diciture diverse dalle normative (direi che sono sbaglaite!). La normativa dice di indicare con M... e basta la filettatura metrica a passo grosso (passo magigore) mentre con M...x... il valore nominale x il passo fine.

Da M33 in su si hanno indicazioni strane. L'M33 ha passo 3.5 a passo grosso, quindi deve esserci scritto solo M33. Se ha passo 2 sarà da scrivere M33x2 non il contrario. Così per alcune misure successive.

L'unico standard che sembra esente da questi errori è l'ANSI METRIC.

Strano che vi siano questi errori GRAVISSIMI su questo software. Eppure secondo UNI 4535 e 4536 e cataloghi vari in internet e manuali di ogni genere non sono gisute queste indicazioni.

Attendo vostro riscontro. Grazie per la collaborazione.
 

Allegati

meccanicamg

Utente Senior
Professione: ♔ Technical manager - Mechanical engineer ♚
Software: SolidWorks, DraftSight, Me10, Freecad, KissSoft, Excel
Regione: Lombardia
#3
nel frattempo cerco la procedura per sistemare il database...a mio rischio e pericolo. Un anno fa ho letto all'interno del DB che c'era la dicitura che ho tradotto: puoi aggiungere e modificare i contenuti e i valori nel DB ma potrebbe capitare che facendo l'aggiornamento al SP successivo tu perda le modifiche.

Consolante....
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#4
Anche la 2009 SP5.1 32bit soffre del problema.
 

meccanicamg

Utente Senior
Professione: ♔ Technical manager - Mechanical engineer ♚
Software: SolidWorks, DraftSight, Me10, Freecad, KissSoft, Excel
Regione: Lombardia
#5
Allora...vediamo un po'.

Nella cartella di default \SolidWorks Data\lang\English c'è il file SWBrowser.MDB e all'interno ci sono le configurazioni base. Nella scheda Version_update_Instruction ci sono le idicazioni... mah proviamo a vedere se riusciamo a non far più andare nulla. Addirittura UpdateBrowserData.exe parte... si ma che database gli devo dare??? Non c'è più il configuratore standard integrato.... uff.
A mano le modifiche non hanno efficacia perchè non riesco a trovare tutti i riferimenti nel DB
 

re_solidworks

Moderatore Solidworks
Staff Forum
Professione: Progettista
Software: Swx2016-R2W2016-Power Surfacing 2.1-Creo 2.0- PDSU 2016 - Composer 2016
Regione: Veneto
#6
Io non ci ho mai messo le mani nei suoi db. Fatti almeno una copia dei file che vai a ritoccare...
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#7
Io li manderei all'assistenza con l'esortazione a rimandarli corretti entro domattina alle 8! :biggrin:

Queste effettivamente sono sviste abbastanza ingiustificabili....
 

meccanicamg

Utente Senior
Professione: ♔ Technical manager - Mechanical engineer ♚
Software: SolidWorks, DraftSight, Me10, Freecad, KissSoft, Excel
Regione: Lombardia
#8
Io li manderei all'assistenza con l'esortazione a rimandarli corretti entro domattina alle 8! :biggrin:

Queste effettivamente sono sviste abbastanza ingiustificabili....
ma soprattutto: da quanti anni va avanti questa storia? E' come il fatto che sulle versioni di qualche anno fa si poteva copiare lo standard tipo ISO DIN ecc rinominarlo e modificarlo. Adesso è tutto blindato.

L'assistenza... bella parola...già in un mondo ideale funziona!
 

cacciatorino

Moderatore SolidEdge
Staff Forum
Professione: Ingegnere meccanico
Software: SolidEdge CoCreate Salome-Meca
Regione: Porto Recanati, ma con l'appennino nel cuore
#9
ma soprattutto: da quanti anni va avanti questa storia? E' come il fatto che sulle versioni di qualche anno fa si poteva copiare lo standard tipo ISO DIN ecc rinominarlo e modificarlo. Adesso è tutto blindato.

L'assistenza... bella parola...già in un mondo ideale funziona!
Pero' non ho capito la necessita' di usare un file MDB per gestire le filettature, SE lo fa con un file txt di pochi kb e funziona perfettamente.

La tabella delle filettature comunque e' ISO_DATA_THRD, ma con Openoffice me la fa solo visualizzare ma senza poterla modificare.
 

meccanicamg

Utente Senior
Professione: ♔ Technical manager - Mechanical engineer ♚
Software: SolidWorks, DraftSight, Me10, Freecad, KissSoft, Excel
Regione: Lombardia
#10
Pero' non ho capito la necessita' di usare un file MDB per gestire le filettature, SE lo fa con un file txt di pochi kb e funziona perfettamente.

La tabella delle filettature comunque e' ISO_DATA_THRD, ma con Openoffice me la fa solo visualizzare ma senza poterla modificare.
Ho visto la ISO_DATA_THRD ma anche modificandola non basta, infatti poi mi dice che non è definito lo standard.

Era così bello Inventor con il suo foglio excel di 3 schede o qualcosa del genere, molto semplice...3 4 colonne: identificativo, dimensione, profondità... basta

Per ora ho risolto nel seguente modo:
visto che ISO e DIN sono sbaglaite ho aperto il configuratore Toolbox e deselezionato le forature da M33 in poi sugli standard ISO e DIN. Userò le ANSI METRIC che sono giuste. Problema aggirato ma non risolto. :angry:
 

re_solidworks

Moderatore Solidworks
Staff Forum
Professione: Progettista
Software: Swx2016-R2W2016-Power Surfacing 2.1-Creo 2.0- PDSU 2016 - Composer 2016
Regione: Veneto
#11
ma soprattutto: da quanti anni va avanti questa storia? E' come il fatto che sulle versioni di qualche anno fa si poteva copiare lo standard tipo ISO DIN ecc rinominarlo e modificarlo. Adesso è tutto blindato.

L'assistenza... bella parola...già in un mondo ideale funziona!
Però bisogna chiamarli e insistere, altrimenti non hanno chiamate e per loro è perchè il software va bene, non perchè tutti si arrangiano in qualche modo.
 

Ste_d

Utente Standard
Professione: Ingegnere Meccanico
Software: Solidworks 2014 SP4
Regione: Toscana
#12
è vero ho controllato anche io!!! che roba, begli errori davvero per un programma potente come SW... vanno a cascare su queste cose!
 

lelepanz

Utente Standard
Professione: Ingegnere
Software: aclt-sw2010
Regione: Lombardia
#13
mandato richiesta alla mia assistenza. penso che apriranno qualcosa ... sempre se non sono l'unico ad averlo segnalato.
Mai fatto caso di questo errore perchè mi fermo al max al M20!

EDIT : la figura della prima tabella da dove l'hai presa?
 

lelepanz

Utente Standard
Professione: Ingegnere
Software: aclt-sw2010
Regione: Lombardia
#14
mandato richiesta alla mia assistenza. penso che apriranno qualcosa ... sempre se non sono l'unico ad averlo segnalato.
Mai fatto caso di questo errore perchè mi fermo al max al M20!

EDIT : la figura della prima tabella da dove l'hai presa?
EDIT2 : trovata.

Su sw 2010 sp.3.1 il problema è presente anche sull'M45.
 

lelepanz

Utente Standard
Professione: Ingegnere
Software: aclt-sw2010
Regione: Lombardia
#16
Cosa e dove?:smile:


Ho appena aggiornato all' SP 4.0 ed è sempre tutto uguale.

Saluti
Marco:smile:
la tabella mostrata nel primo post è uno snapshot della tabella del configura del toolbox.
Aggiornamento -> assistenza.
sw 2009 -> muore li così. E' così e basta.
sw 2010 -> forse potrebbe esserci speranza.

Workaround : -> i formati standard non si possono modificare. Si può fare una copia del formato standard e modificare quindi nella copia la dicitura del filetto.
Quando poi si usa la foratura guidata occorre scegliere lo standard "copiato".

Forse e dico forse , si potrebbe togliere la spunta di "sola lettura" dalla cartella delle toolbox e "forse" si potrebbe modifcare sempre nel configuratore delle toolbox. Il tutto forse. Dico forse perchè mi è venuto in mente adesso mentre scrivevo.

Cmq io mi trovo davvero malissimo con le toolbox! :/
 

lelepanz

Utente Standard
Professione: Ingegnere
Software: aclt-sw2010
Regione: Lombardia
#18
Questo e' totalmente assurdo! :confused:
Si può fare una copia dello standard e modificare quello.
Concordo che è totalmente assurdo non prendere più in mano un prodotto vecchio perchè a fine sp! Pensa al sw2009 in sp5.0 quando hanno cappellato la possibilità di aprire una finestra browser quando si cambio il riferimento i un disegno drwg.
Su sw2010 funzionava ancora e l'assistenza mi ha detto -> "se 6 fortunato lo sistemano, altrimenti attaccati!".

Tra l'altro non è detto che lo sistemino su sw2010!
 

meccanicamg

Utente Senior
Professione: ♔ Technical manager - Mechanical engineer ♚
Software: SolidWorks, DraftSight, Me10, Freecad, KissSoft, Excel
Regione: Lombardia
#19
la tabella mostrata nel primo post è uno snapshot della tabella del configura del toolbox.
Aggiornamento -> assistenza.
sw 2009 -> muore li così. E' così e basta.
sw 2010 -> forse potrebbe esserci speranza.

Workaround : -> i formati standard non si possono modificare. Si può fare una copia del formato standard e modificare quindi nella copia la dicitura del filetto.
Quando poi si usa la foratura guidata occorre scegliere lo standard "copiato".

Forse e dico forse , si potrebbe togliere la spunta di "sola lettura" dalla cartella delle toolbox e "forse" si potrebbe modifcare sempre nel configuratore delle toolbox. Il tutto forse. Dico forse perchè mi è venuto in mente adesso mentre scrivevo.

Cmq io mi trovo davvero malissimo con le toolbox! :/
Grazie a tutti quelli che stanno collaborando!

Ciao lelepanz, non sono riuscito a fare una copia di uno standard dal pannello di configurazione Toolbox. Nella versione 2008 si riusciva, si cliccava col destro e usciva copia standard... adesso come si fa?
Il database generale si può modificare ma non son riuscito a trovare tutte le modifiche da fare... negli standard singoli il database è modificabile anche li ma sembra nona vere effetto.
 

lelepanz

Utente Standard
Professione: Ingegnere
Software: aclt-sw2010
Regione: Lombardia
#20
Grazie a tutti quelli che stanno collaborando!

Ciao lelepanz, non sono riuscito a fare una copia di uno standard dal pannello di configurazione Toolbox. Nella versione 2008 si riusciva, si cliccava col destro e usciva copia standard... adesso come si fa?
Vado a memoria perchè non ono al lavoro.
Entra nella pagina di configurazione.
Poi Vai sulla prima pagina (1).
Seleziona lo standard da cui vuoi partire.
Clicca.
In alto a sx avrai 2 icone.
1 è quella classica per salire di livello, l'ltra è per copiare lo standard.