• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

AutoCAD & malfunzionamenti vari

aupaz

Utente Junior
Professione: ingegnere
Software: Autocad, Solid Edge, Solidworks 2009, Edilclima
Regione: Friuli Venezia Giulia
#1
-il tasto CANC non cancella più, se seleziono un entità,
-non mi si apre più la tabella delle proprietà e non mi dà più il layer/colori/spessori/ di tale entità come prima, ma mi mostra solamente in che layer in cui mi trovo
-per cambiare colore a qualsiasi cosa devo andare sul tasto proprietà e poi a mano cambaire da lì...

Insomma, dopo aver fatto pizzi e merletti per impostare un template come si deve, ora non so perchè, ma i comandi funzionano malissimo... Devo mica reinstallare vero?!?!
 

Shape

Utente Senior
Professione: Disegnatore Carpenteria
Software: Autocad, VBA-AutoLisp, Tecnometal4D, GIMP
Regione: Friuli
#2
-il tasto CANC non cancella più, se seleziono un entità,
-non mi si apre più la tabella delle proprietà e non mi dà più il layer/colori/spessori/ di tale entità come prima, ma mi mostra solamente in che layer in cui mi trovo
-per cambiare colore a qualsiasi cosa devo andare sul tasto proprietà e poi a mano cambaire da lì...

Insomma, dopo aver fatto pizzi e merletti per impostare un template come si deve, ora non so perchè, ma i comandi funzionano malissimo... Devo mica reinstallare vero?!?!
mmm strana sta cosa.. non mi è mai capitato.

Bhè il ripristino dell'installazione sicuramente qlc risolve, ma sarebbe curioso capire da dove è partito il tutto.

Non è che hai modificato/editato dei file di configurazione come menu,pgp etc ? se sono danneggiati o corrotti può essere che non funzionino i tasti caldi e le variabili oggetto quando è selezionato

es. ***BUTTONS1
// Simple + button
// if a grip is hot bring up the Grips Cursor Menu (POP 500), else send a carriage return
// If the SHORTCUTMENU sysvar is not 0 the first item (for button 1) is NOT USED.
$M=$(if,$(eq,$(substr,$(getvar,cmdnames),1,5),GRIP_),$P0=ACAD.GRIPS $P0=*);
$P0=SNAP $p0=*
^C^C
^B
^O
^G
^D
^E
^T

inoltre visto che so che stavi cercando di utilizzare percorsi specifici per standardizzare il tutto sei sicuro di non aver tolto qlc percorso di sistema ?
 

Zanna91

Utente Standard
Professione: ---
Software: AutoCAD
Regione: Deutschland
#3
La soluzione per risolvere il problema del comando proprietà è cosi strutturata:

1) Lanciare il programma e caricare un disegno.
2) Scrivere sulla riga di comando OPMSTATE ed annotare il valore che viene restituito dopo aver confermato con il tasto invio.
3) Scrivere sulla riga di comando _PROPERTIES e confermare con il tasto invio.
4) Se la finestra di proprietà non appare scrivere sulla riga di comando OPMSTATE ed annotare il valore che viene restituito dopo aver confermato con il tasto invio.

- Di solito al terzo punto della procedura di diagnosi la finestra delle proprietà potrebbe apparire un errore: l'icona di comando non lancia il comando correttamente.

A) In tal caso si dovrebbe mettere le mani all'interfaccia grafica, modificando il "cui", per risistemare il comando compilando la sezione macro con la scritta:
_properties;
Se non avete mai messo mano ai file "cui" di AutoCAD si consiglia di utilizzare il comando da tastiera ed fare risistemare il tutto ad un tecnico competente.

- Se al quarto punto della riga di comando, quindi anche dopo aver lanciato il comando _properties, la variabile OPMSTATE è rimasta a zero:

B) Potrebbe essere causa di una sovrascrittura del comando proprietà tramite un applicativo VBA, LISP, ARX od altro. Per ovvie ragioni tela causa è più probabile se il problema si è manifestato dopo una personalizzazione od aver caricato un applicativo. In tal caso bisogna provare a "scaricare" l'applicativo problematico.
- Tramite il comando _APPLOAD si possono caricare e scaricare gli applicativi di AutoCAD.
- Tramite il comando _MENULOAD si possono caricare e scaricare le interfacce utente caricate.

C) Potrebbe essersi danneggiato qualche file, in tal caso la procedura è quella di riparare l'installazione di AutoCAD.

- Se al quarto punto della riga di comando, quindi anche dopo aver lanciato il comando _properties, la variabile OPMSTATE viene valorizzata a 1:

D) Anche se può sembrare una banalità consiglio di verificare che la finestra non sia "nascosta" ovvero posizionata quasi del tutto fuori dallo schermo o che sia stata ridotta talmente in piccolo che non si nota. Da verificarsi anche che la risoluzione video non sia troppo passa (per esempio 800x600).

E) Alcune schede video, soprattutto quelle integrate in piastra che sfruttano la ram come VRam in condivisione, possono non riuscire a visualizzare correttamente la finestra di proprietà. Questo problema è verificabile riavviando il P.C.
in modalità VGA. Se in tale modalità il problema non si presenta si consiglia vivamente di cambiare i driver della scheda video o, ancora meglio, di cambiare la scheda video.

Se tutto questo non funziona la buona vecchia disinstallazione, pulizia del sistema e reinstallazione può risolvere il problema.


Fonte: cad-consulting.blogspot.com

Mentre per quanto riguarda la soluzione del tasto CANC:

1) Verificare che l'oggetto non sia un associato ad un layer bloccato.
2) Se la versione di AutoCAD od AutoCAD LT è precedente alla 2005 verificare che l'oggetto si cancelli selezionandolo e cliccando sul comando cancella. In tal caso probabilmente si tratta di un oggetto "Object Linking and Embedding" solitamente generato da un copia/incolla. Le vecchie versioni di AutoCAD ed AutoCAD LT possono cancellare tali oggetti tramite il comando cancella e non con il CANC da tastiera.
3) Per gli altri casi suggerisco di verificare nella scheda "Selezione" della finestra opzioni che la spunta "Selezione nome verbo" sia attiva.

Fonte: cad-consulting.blogspot.com


Saluti,
Giacomo
 
Ultima modifica:

aupaz

Utente Junior
Professione: ingegnere
Software: Autocad, Solid Edge, Solidworks 2009, Edilclima
Regione: Friuli Venezia Giulia
#4
ammazza oh, ma siete dei draghi!!! Ma come fate a sapere tutte ste cose?! Smanettate notte e giorno con autocad???? Ora provo!
 

aupaz

Utente Junior
Professione: ingegnere
Software: Autocad, Solid Edge, Solidworks 2009, Edilclima
Regione: Friuli Venezia Giulia
#5
sono arrivato al punto 3 e mi scrive "durante la ricerca sono stati ignorati i seguenti collegamenti non validi: c:\program files\Autocad....\plot styles\adda plot style table wizard.lnk .......
Ora cerco di ripristinarlo da un altro pc qui in ufficio, sperando sia lo stesso...
 

aupaz

Utente Junior
Professione: ingegnere
Software: Autocad, Solid Edge, Solidworks 2009, Edilclima
Regione: Friuli Venezia Giulia
#6
che casino.... praticamente, avevo installato autocad 2007 in inglese e in italiano, e ora ho disinstallato la versione inglese. Alcune cartelle di quella in italiano erano nella directory comune si VISTA(che schifoooo) c:\program files... e avendo disinstallato una versione dei 2 ,mi ha cancellato i files comuni... che palle, meglio che reinstallo la versione italiana... altrimenti devo cambiare tutti i link di puntamento dei singoli file che non vanno più.... Solo Vista poteva avere ste cagate con le sue directory sdoppiate per non si sà che motivo...
 

aupaz

Utente Junior
Professione: ingegnere
Software: Autocad, Solid Edge, Solidworks 2009, Edilclima
Regione: Friuli Venezia Giulia
#7
Ho ripristinato il collegamento al file spostando e ricambiando il link corretto, per i ltasto canc avevi ragionissimo Giacomo, la spunta VERBO mancava, ma non ho idea perchè!!!!!!!!! GRAZZZIEEEEEEEEEEEEE!!!!!!!!!!!!!!!!!!

Come cavolo sapete certe cose?!?!?!
 

aupaz

Utente Junior
Professione: ingegnere
Software: Autocad, Solid Edge, Solidworks 2009, Edilclima
Regione: Friuli Venezia Giulia
#8
pensavo questo problema non fosse comune e quind inon ho googlato!
Meglio così!!!! Grazieeeeeeeeeeeee :)
 

Shape

Utente Senior
Professione: Disegnatore Carpenteria
Software: Autocad, VBA-AutoLisp, Tecnometal4D, GIMP
Regione: Friuli
#9
che casino.... praticamente, avevo installato autocad 2007 in inglese e in italiano, e ora ho disinstallato la versione inglese. Alcune cartelle di quella in italiano erano nella directory comune si VISTA(che schifoooo) c:\program files... e avendo disinstallato una versione dei 2 ,mi ha cancellato i files comuni... che palle, meglio che reinstallo la versione italiana... altrimenti devo cambiare tutti i link di puntamento dei singoli file che non vanno più.... Solo Vista poteva avere ste cagate con le sue directory sdoppiate per non si sà che motivo...
Il problema non è di vista.... questa volta non è colpa sua... ( ma solo questa volta :D)

Autocad utilizza su documents&settings delle cartelle per poter permettere a utenti diversi di avere personalizzazioni diverse. ora non sono sicurissimo ma versione inglese ed italiana per il sistema non cambia nulla è sempre una R17 per esempio.. quindi vengono salvati li i file di personalizzazione quali menu pgp etc.etc...

Disinstallando una la versione R17 toglie tutto ovviamente.
 

Shape

Utente Senior
Professione: Disegnatore Carpenteria
Software: Autocad, VBA-AutoLisp, Tecnometal4D, GIMP
Regione: Friuli
#10
"basta girare in internet,

è scritto dappertutto"



Per quanto riguarda la battutina di qcl... non è una ricerca su internet... ma semplicemente aver già visto queste situazioni e averci già perso le notti per risolverle...

Altrimenti ci sarebbe stato un LINK :confused:
 

PlannerRoad

Moderatore
Staff Forum
Professione: Variabile
Software: AutoCAD 2016
Regione: Italia
#12
Il problema non è di vista.... questa volta non è colpa sua... ( ma solo questa volta :D)

Autocad utilizza su documents&settings delle cartelle per poter permettere a utenti diversi di avere personalizzazioni diverse. ora non sono sicurissimo ma versione inglese ed italiana per il sistema non cambia nulla è sempre una R17 per esempio.. quindi vengono salvati li i file di personalizzazione quali menu pgp etc.etc...

Disinstallando una la versione R17 toglie tutto ovviamente.
Non è proprio così in quanto sotto la cartella R17 c'è sempre la cartella "ita" (per la versione italiana naturalmente) sotto cui vengono appunto salvati i file di personalizzazione.
 

aupaz

Utente Junior
Professione: ingegnere
Software: Autocad, Solid Edge, Solidworks 2009, Edilclima
Regione: Friuli Venezia Giulia
#13
allora grazie del sudore versato a suo tempo e risparmiato alla plebe ora! ;-)))))
 

MBT

Utente Senior
Professione: tiro righe, compilo tabelle...
Software: non serve un software per fare quel che faccio...
Regione: nella Terra di Mezzo
#14
Non prendertela per arri...
quando non sa che pesci linkare, dice che è una caxxata e che bastava cercare con google...

al è fat cussi.... :)