• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Leggi altro.

Antialiasing

BlueEyes73

Utente Junior
Professione: Artigiano
Software: SolidWorks 2009 X64 SP5.1 su Windows7
Regione: Italia
#1
Mi piacerebbe sapere se qualcuno riesce ad attivare l'antialiasing con le schede quadro. Premetto che a casa ho una ati 4870 e riesco tranquillamente a forzare l'aa dal pannello di controllo (oltre il 4x da problemi ma va be). Il problema è che con la quadro fx3700 non ci riesco in nessun modo e posso solamente tenere quello software del programma sulle linee.
Ho provato sia i driver certificati che gli ultimi e non riesco ad abilitarlo. Essendo la quadro una scheda per programmi professionali e la 4870 per "giocare" non riesco proprio a capirne il motivo. Entrambi i Solidworks sono su Vista64 e sono le versioni 2009 x64 sp2.
 
Professione: Progettazione meccanica
Software: NX3;NX6 e SW2009
Regione: Emilia Romagna
#2
Mi piacerebbe sapere se qualcuno riesce ad attivare l'antialiasing con le schede quadro. Premetto che a casa ho una ati 4870 e riesco tranquillamente a forzare l'aa dal pannello di controllo (oltre il 4x da problemi ma va be). Il problema è che con la quadro fx3700 non ci riesco in nessun modo e posso solamente tenere quello software del programma sulle linee.
Ho provato sia i driver certificati che gli ultimi e non riesco ad abilitarlo. Essendo la quadro una scheda per programmi professionali e la 4870 per "giocare" non riesco proprio a capirne il motivo. Entrambi i Solidworks sono su Vista64 e sono le versioni 2009 x64 sp2.
Hai provato a cambiare le impostazioni di antialiasing ? (Strumenti, Opzioni, Visualizzazione / Selezione) ?
Come pure la qualità delle immagini ? (Strumenti, Opzioni, Proprietà Doc, Qualità delle immagini) ?

Prova anche qua http://solidmentor.com/modules/wiwimod/index.php?page=AntiAliasing
 

BlueEyes73

Utente Junior
Professione: Artigiano
Software: SolidWorks 2009 X64 SP5.1 su Windows7
Regione: Italia
#3
Hai provato a cambiare le impostazioni di antialiasing ? (Strumenti, Opzioni, Visualizzazione / Selezione) ?
Come pure la qualità delle immagini ? (Strumenti, Opzioni, Proprietà Doc, Qualità delle immagini) ?

Prova anche qua http://solidmentor.com/modules/wiwimod/index.php?page=AntiAliasing
Come dice il link da te postato è possibile utilizzare o l'AA del programma con le opzioni che hai elencato sopra (ma è software e solo sulle linee) o via driver come fa vedere nelle immagini, il mio problema è proprio li, forzandolo via driver non cambia nulla e non si attiva, mi chiedevo quindi se qualcuno ci riesce e come...
Il fatto che si attivi con una ati normale mi lascia :confused:
 
Professione: Progettazione meccanica
Software: NX3;NX6 e SW2009
Regione: Emilia Romagna
#4
Come dice il link da te postato è possibile utilizzare o l'AA del programma con le opzioni che hai elencato sopra (ma è software e solo sulle linee) o via driver come fa vedere nelle immagini, il mio problema è proprio li, forzandolo via driver non cambia nulla e non si attiva, mi chiedevo quindi se qualcuno ci riesce e come...
Il fatto che si attivi con una ati normale mi lascia :confused:
C'è un'opzione in SolidWorks che disabilità l'Antialiasing di SolidWorks, facendolo gestire dalla scheda video.
Prova e sappici dire.
 

BlueEyes73

Utente Junior
Professione: Artigiano
Software: SolidWorks 2009 X64 SP5.1 su Windows7
Regione: Italia
#5
C'è un'opzione in SolidWorks che disabilità l'Antialiasing di SolidWorks, facendolo gestire dalla scheda video.
Prova e sappici dire.
Le ho provate tutte :frown:

Dal pannello nvidia ho provato sia "Migliora l'impostazione dell'applicazione" che "Escludi qualsiasi impostazione dell'applicazione" e varie tipologia di antialiasing, e ho provato sia nelle "impostazioni globali" che in "impostazioni programma" (sotto la voce Dassault Systemes Solidworks).
 
Professione: Progettazione meccanica
Software: NX3;NX6 e SW2009
Regione: Emilia Romagna
#6
Le ho provate tutte :frown:

Dal pannello nvidia ho provato sia "Migliora l'impostazione dell'applicazione" che "Escludi qualsiasi impostazione dell'applicazione" e varie tipologia di antialiasing, e ho provato sia nelle "impostazioni globali" che in "impostazioni programma" (sotto la voce Dassault Systemes Solidworks).
Puoi allegare un'immagine del tuo problema ?
 

BlueEyes73

Utente Junior
Professione: Artigiano
Software: SolidWorks 2009 X64 SP5.1 su Windows7
Regione: Italia
#7
Puoi allegare un'immagine del tuo problema ?
Praticamente quello che vorrei fare è attivare l'AA via driver come ho fatto sul pc di casa con una semplice ati 4870. Quello che ottengo è presente nelle immagini prova4a e prova5a con l'antialiasing attivo sempre. Con la quadro 3700 invece non riesco a rimane sempre come nell'immagine prova3a (ho disattivato quello software di Solidworks in entrambi i casi).
 

Allegati

Professione: Progettazione meccanica
Software: NX3;NX6 e SW2009
Regione: Emilia Romagna
#8
Praticamente quello che vorrei fare è attivare l'AA via driver come ho fatto sul pc di casa con una semplice ati 4870. Quello che ottengo è presente nelle immagini prova4a e prova5a con l'antialiasing attivo sempre. Con la quadro 3700 invece non riesco a rimane sempre come nell'immagine prova3a (ho disattivato quello software di Solidworks in entrambi i casi).
Io non so, ma a me sembra che tu debba settare corretamente i parametri delle proprietà del documento.
Allega il file che domani ci provo al lavoro.
Io ho una quadro FX570.
 

BlueEyes73

Utente Junior
Professione: Artigiano
Software: SolidWorks 2009 X64 SP5.1 su Windows7
Regione: Italia
#9
Io non so, ma a me sembra che tu debba settare corretamente i parametri delle proprietà del documento.
Allega il file che domani ci provo al lavoro.
Io ho una quadro FX570.
Umm... ma dovrebbe essere indipendente dalle proprietà del documento, a casa io tolgo la spunta da Opzioni del sistema - Visualizzazione/Selezione - Bordi Schizzi Anti-Alias. Facendo così disabilito l'anti-alias di solidworks, a questo punto vado nel pannello del driver e lo attivo. A casa nessun problema, con la quadro sul lavoro non c'è verso di farlo funzionare e qualsiasi cosa faccio nel pannello driver nvidia rimane sempre uguale. Per provare basta un semplice cilindro, ho allegato le immagini prima giusto per capire l'effetto che fa attivare l'aa dal driver. Un altro vantaggio è che l'aa "hardware" è attivo sempre anche su assiemi di grandi dimensioni.
 

BlueEyes73

Utente Junior
Professione: Artigiano
Software: SolidWorks 2009 X64 SP5.1 su Windows7
Regione: Italia
#10
Visto che nessuno a parte cubalibre00 (che ringrazio :wink:) ha risposto... vuol dire che nessuno usa l'antialiasing hardware su schede quadro (cosa che mi sembra assurda visto che è una delle funzionalità tanto "acclamate" :biggrin:) o funziona a tutti? :confused:
 

Oldwarper

Moderatore Solidworks
Staff Forum
Professione: Progettista
Software: Solidworks, Cimatron IT, Cimatron E, Rhino, AutoCAD, Logopress, Solidcam
Regione: Emilia Romagna
#11
Mai usato.
 

BlueEyes73

Utente Junior
Professione: Artigiano
Software: SolidWorks 2009 X64 SP5.1 su Windows7
Regione: Italia
#12
Se qualcuno ha voglia/tempo di provare potete vedere se vi funziona?

Prima disabiltiamo l'antialiasing software: da solidworks Opzioni_Visualizzazione/Selezione_Bordi/Schizzi antialias togliere la spunta.

A questo punto basta disegnare anche solo un cerchio per vedere tutti i bordi "seghettati". Se è così andiamo sul pannello di controllo nvidia (tasto sx sul desktop), Gestione impostazioni 3d (se non c'è basta abilitare le Impostazioni Avanzate), Impostazioni Programma, lasciando senza spunta Mostra solo i programmi presenti... cercare Dassault Systemes Solidworks.
A questo punto selezionare:

Antialias - Modalità: Migliora l'impostazione dell'applicazione o Escludi qualsiasi impotstazione dell'applicazione

Antialias - Impostazione: scegliere una di quelle, più il numero è alto migliore sarà l'antialiasing, un 8x andrà benissimo.

Provate a caricare un modello e se funziona dovrebbe essere attivo l'antialiasing sia nelle visuali con che senza bordi.

Scusate se insisto su sta cosa che a molti sembrerà ridicola, ma ho preso una quadro soprattutto per questa funzione e vorrei sfruttarla .
Grazie a chi avrà voglia di provare. :tongue:
 
Professione: Progettazione meccanica
Software: NX3;NX6 e SW2009
Regione: Emilia Romagna
#13
Se qualcuno ha voglia/tempo di provare potete vedere se vi funziona?

Prima disabiltiamo l'antialiasing software: da solidworks Opzioni_Visualizzazione/Selezione_Bordi/Schizzi antialias togliere la spunta.

A questo punto basta disegnare anche solo un cerchio per vedere tutti i bordi "seghettati". Se è così andiamo sul pannello di controllo nvidia (tasto sx sul desktop), Gestione impostazioni 3d (se non c'è basta abilitare le Impostazioni Avanzate), Impostazioni Programma, lasciando senza spunta Mostra solo i programmi presenti... cercare Dassault Systemes Solidworks.
A questo punto selezionare:

Antialias - Modalità: Migliora l'impostazione dell'applicazione o Escludi qualsiasi impotstazione dell'applicazione

Antialias - Impostazione: scegliere una di quelle, più il numero è alto migliore sarà l'antialiasing, un 8x andrà benissimo.

Provate a caricare un modello e se funziona dovrebbe essere attivo l'antialiasing sia nelle visuali con che senza bordi.

Scusate se insisto su sta cosa che a molti sembrerà ridicola, ma ho preso una quadro soprattutto per questa funzione e vorrei sfruttarla .
Grazie a chi avrà voglia di provare. :tongue:
La risposta è stata più o meno quella che hai inserito qua.
Neanche a me funziona...
A parte provare l'ultimo driver o quello consigliato dalla SolidWorks, l'unico altro consiglio che ti posso dare è quello di provare RivaTuner....

Se saprò altro o tu troverai la soluzione...teniamoci aggiornati.
 

BlueEyes73

Utente Junior
Professione: Artigiano
Software: SolidWorks 2009 X64 SP5.1 su Windows7
Regione: Italia
#14
La risposta è stata più o meno quella che hai inserito qua.
Neanche a me funziona...
A parte provare l'ultimo driver o quello consigliato dalla SolidWorks, l'unico altro consiglio che ti posso dare è quello di provare RivaTuner....

Se saprò altro o tu troverai la soluzione...teniamoci aggiornati.
Grazie mille, ma ho già provato anche a forzarlo con Rivatuner :frown:.
E' una cosa che proprio non mi riesco a spiegare, e manco posso accedere al forum ufficiale senza subscription :frown:.
 

Parceval

Utente Junior
Professione: Progettista meccanico
Software: Solidworks
Regione: Padova
#15
Se qualcuno ha voglia/tempo di provare potete vedere se vi funziona?

Prima disabiltiamo l'antialiasing software: da solidworks Opzioni_Visualizzazione/Selezione_Bordi/Schizzi antialias togliere la spunta.

A questo punto basta disegnare anche solo un cerchio per vedere tutti i bordi "seghettati". Se è così andiamo sul pannello di controllo nvidia (tasto sx sul desktop), Gestione impostazioni 3d (se non c'è basta abilitare le Impostazioni Avanzate), Impostazioni Programma, lasciando senza spunta Mostra solo i programmi presenti... cercare Dassault Systemes Solidworks.
A questo punto selezionare:

Antialias - Modalità: Migliora l'impostazione dell'applicazione o Escludi qualsiasi impotstazione dell'applicazione

Antialias - Impostazione: scegliere una di quelle, più il numero è alto migliore sarà l'antialiasing, un 8x andrà benissimo.

Provate a caricare un modello e se funziona dovrebbe essere attivo l'antialiasing sia nelle visuali con che senza bordi.

Scusate se insisto su sta cosa che a molti sembrerà ridicola, ma ho preso una quadro soprattutto per questa funzione e vorrei sfruttarla .
Grazie a chi avrà voglia di provare. :tongue:

A me funziona! :finger:
Ho una nVidia FX1500 driver 84.80, SW2008 SP4
 
Professione: Artigiano
Software: SolidWorks 2009 X64 SP5.1 su Windows7
Regione: Italia
#16
A me funziona! :finger:
Ho una nVidia FX1500 driver 84.80, SW2008 SP4
Grazie mille per la prova, su che SO lo usi? XP o Vista (32 o 64)? Ti funziona in tutte le viste compresa quella solo Ombreggiatura?

Ho provato a contattare nvidia, ma mi hano detto che hanno problemi con la licenza di rete di Solidworks 2009 e ci vorrà un pò di tempo :confused:
 

Parceval

Utente Junior
Professione: Progettista meccanico
Software: Solidworks
Regione: Padova
#17
Grazie mille per la prova, su che SO lo usi? XP o Vista (32 o 64)? Ti funziona in tutte le viste compresa quella solo Ombreggiatura?

Ho provato a contattare nvidia, ma mi hano detto che hanno problemi con la licenza di rete di Solidworks 2009 e ci vorrà un pò di tempo :confused:
Io uso XP32, e l'antialiasing mi funziona in tutte le viste e ti dirò addirittura che il rallentamento non è per niente pesante (assiemi di 500 parti)! :biggrin:
 
Professione: Artigiano
Software: SolidWorks 2009 X64 SP5.1 su Windows7
Regione: Italia
#18
Io uso XP32, e l'antialiasing mi funziona in tutte le viste e ti dirò addirittura che il rallentamento non è per niente pesante (assiemi di 500 parti)! :biggrin:
Infatti è proprio per quello che vorrei attivarlo si per questioni di velocità che di estetica :finger:, a sto punto credo che il problema sia o in Solidworks 2009 o in Vista 64...
 

BlueEyes73

Utente Junior
Professione: Artigiano
Software: SolidWorks 2009 X64 SP5.1 su Windows7
Regione: Italia
#19
Questa è stata la risposta di Nvidia...:mad:

"NVIDIA engineers have discussed this problem with SolidWorks engineers. According to SolidWorks engineers, here is the explanation for the problem:

The final rendering is using a FBO which doesn't pick up the forced FSAA setting. This is a feature of Solidworks 2009. This is being fixed in Solidworks 2010.

Since this is verified by Solidworks to be a Solidworks application issue, I will close this case.

Please contact Solidworks for information about Solidworks 2010."


Ma il fatto che con una ATI non firegl funziona mi lascia abbastanza perplesso... :confused:
 

cubalibre00

Utente Senior
Professione: Progettazione meccanica
Software: NX3;NX6 e SW2009
Regione: Emilia Romagna
#20
Questa è stata la risposta di Nvidia...:mad:

"NVIDIA engineers have discussed this problem with SolidWorks engineers. According to SolidWorks engineers, here is the explanation for the problem:

The final rendering is using a FBO which doesn't pick up the forced FSAA setting. This is a feature of Solidworks 2009. This is being fixed in Solidworks 2010.

Since this is verified by Solidworks to be a Solidworks application issue, I will close this case.

Please contact Solidworks for information about Solidworks 2010."


Ma il fatto che con una ATI non firegl funziona mi lascia abbastanza perplesso... :confused:
Sono dispiaciuto che un Service Pack non possa risolvere il problema, ma è servito a dimostrare una deficienza nelle API di SolidWorks che non permettono la possibilità di sfruttare al meglio delle costose schede video.
Se sei in manutenzione, prova a farti sentire con quelli della SolidWorks, spingendo ad una risoluzione nel più breve tempo possibile....non si sa mai...visto che consigliano tali schede per certi impieghi.

Grazie per il tuo contributo.