Animazione di parti variabili

mak2163

Utente poco attivo
Professione: Docente
Software: Solid Edge
Regione: Umbria
#1
Salve!
Sono un ingegnere meccanico ed insegno meccanica e tecnologia in un professionale. Utilizzo AutoCAD, Solid Edge e SolidWorks, ma prediligo SE V20 per la sua estrema facilità di apprendimento ed interazione da parte degli alunni.
Quest'anno i miei studenti si sono appassionati a Solid Edge in maniera particolare e mi "costringono" a creare sempre nuovi problemi su complessivi meccanici.
Ultimamente ho proposto loro di creare un sistema valvola-sede-molla-camma per un motore a combustione interna ed ho loro insegnato come sincronizzare la corsa della valvola con la compressione della molla mediante le parti variabili.
Il problema che mi si pone è che SE aggiorna la posizione della molla solo dopo aver confermato lo spostamento della valvola. Quando effettuiamo l'animazione con la camma che ruota, la valvola sale e scende correttamente, ma la molla rimane ferma e non segue il moto, comprimendosi e decoprimendosi.
Ho provato a cercare possibili soluzioni, ma non ho trovato nulla di adatto (forse colpa mia che sono un principiante in questo forum!).
Vorrei risolvere il problema, o almeno sapere se SE può fare questa animazione con parti variabili, o meno, in modo da chiarire il problema ai miei studenti che si stanno affannando a cercarne una soluzione (cosa didatticamente molto positiva, ma alla fine frustrante se non ricondotta a soluzione certa!)
Ringrazio tutti coloro che potranno aiutarmi e spero di essermi inserito nel posto giusto e nella maniera corretta!
Un saluto!
 

gerod

Moderatore
Staff Forum
Professione: Libero professionista
Software: Solid Edge, Ansys DS, e altri ancora
Regione: Veneto
#2
Ciao e benvenuto.
Ricordo che ne avevamo già discusso in passato. Non ricordo che vis sia una soluzione ma deformare una molla e' un po' dura con il SE.
Non so se la cosa sia possibile con le versioni superiori.
Attendiamo qualche altro esperto.
Mi fa piacere che i tuoi studenti siano così interessati!
Un saluto.
 
Professione: Ingegnere
Software: Alcuni, ma non tutti
Regione: Campania
#3
Un problema simile si pone nell'animazione dei robot. I cavi del dressing integrato infatti non seguono i movimenti, e anche se lo facessero darebbero un grosso quanto inutile carico computazionale.

La soluzione che generalmente si adotta è quello di fare i cavi rigidi, tagliati sul centro del giunto, e le due metà solidali ai due bracci che convergono sul giunto. Se guardi da vicino vedi il cavo "spezzato", ma in realtà l'effetto è tutto sommato buono. Del resto siamo ingegneri, non pubblicitari.

Allo stesso modo si potrebbe fare la molla tagliata a metà (intendo, da un piano ortogonale all'asse, posizionato a metà molla), e delle due metà, una solidale alla valvola e l'altra fissa. Vedrai la molla "autocompenetrarsi" nella zona centrale, ma dovresti ottenere un effetto tutto sommato abbastanza buono.
 

Be_on_edge

Moderatore
Staff Forum
Professione: Progettazione
Software: Solid Edge
Regione: Emilia Romagna
#5
Salve!
Sono un ingegnere meccanico ed insegno meccanica e tecnologia in un professionale. Utilizzo AutoCAD, Solid Edge e SolidWorks, ma prediligo SE V20 per la sua estrema facilità di apprendimento ed interazione da parte degli alunni.
Quest'anno i miei studenti si sono appassionati a Solid Edge in maniera particolare e mi "costringono" a creare sempre nuovi problemi su complessivi meccanici.
Ultimamente ho proposto loro di creare un sistema valvola-sede-molla-camma per un motore a combustione interna ed ho loro insegnato come sincronizzare la corsa della valvola con la compressione della molla mediante le parti variabili.
Il problema che mi si pone è che SE aggiorna la posizione della molla solo dopo aver confermato lo spostamento della valvola. Quando effettuiamo l'animazione con la camma che ruota, la valvola sale e scende correttamente, ma la molla rimane ferma e non segue il moto, comprimendosi e decoprimendosi.
Ho provato a cercare possibili soluzioni, ma non ho trovato nulla di adatto (forse colpa mia che sono un principiante in questo forum!).
Vorrei risolvere il problema, o almeno sapere se SE può fare questa animazione con parti variabili, o meno, in modo da chiarire il problema ai miei studenti che si stanno affannando a cercarne una soluzione (cosa didatticamente molto positiva, ma alla fine frustrante se non ricondotta a soluzione certa!)
Ringrazio tutti coloro che potranno aiutarmi e spero di essermi inserito nel posto giusto e nella maniera corretta!
Un saluto!
Ciao e benvenuto,

durante il movimento la molla non viene ricalcolata, sarebbe troppo pesante e di fatto il movimento diverrebbe lentissimo. Viene invece calcolata dopo lo spostamento.

Per vedere quello che chiedi devi salvare un'immagine di ogni iterazione e poi combinarle in un filmato.

Puoi farlo a mano oppure tramite il modulo motion o il modulo di animazione. (dovrei verificare se in automatico ti aggiorna la molla prima di salvare l'immagine).

Ciao
 

gerod

Moderatore
Staff Forum
Professione: Libero professionista
Software: Solid Edge, Ansys DS, e altri ancora
Regione: Veneto
#6
Sono d'accordo con Fulvio. SE nasce per progettare e non per fare animazioni e rendering. Ci sono strumenti dedicati per far questo e lo fanno egregiamente.
Ho fatto una cosa del genere con VN4D: in questo caso la molla veniva deformata dal carico e così potevo realizzare il filmato.
Ciao
 

mak2163

Utente poco attivo
Professione: Docente
Software: Solid Edge
Regione: Umbria
#7
Grazie a tutti per i preziosi consigli! Li inoltro direttamente ai miei studenti (invitandoli magari ad iscriversi al forum).
Quando avranno prodotto i loro lavori, magari pubblico qua le loro soluzioni più significative.

Un saluto a tutti!!
 

Tequila

Utente Senior
Professione: teorico del paleocontatto
Software: Solid Edge ST7, scarabocchi su carta
Regione: Veneto (PD)
#8
Grazie a tutti per i preziosi consigli! Li inoltro direttamente ai miei studenti (invitandoli magari ad iscriversi al forum).
Quando avranno prodotto i loro lavori, magari pubblico qua le loro soluzioni più significative.

Un saluto a tutti!!
bene perfetto... gia che ci sei avvisa i tuoi studenti di leggersi le regole del forum e di fare la presentazione appena iscritti cosi evitano di prendersi delle strigliate (in buona fede) da noi del forum :finger:
 
Professione: Ingegnere
Software: Alcuni, ma non tutti
Regione: Campania
#9
Grazie a tutti per i preziosi consigli! Li inoltro direttamente ai miei studenti (invitandoli magari ad iscriversi al forum).
Quando avranno prodotto i loro lavori, magari pubblico qua le loro soluzioni più significative.

Un saluto a tutti!!
C'è anche un forum "Istituti Tecnici / Università", forse lo si può sfruttare per raggruppare meglio i thread. Ad esempio se avete intenzione di sviluppare un progetto intero.