animazione asola livera

Max-C

Utente Standard
Professione: Mechanical designer
Software: Siemens NX - Solidworks - Inventor - Autocad
Regione: Piemonte-Provincia TO
#1
Buon giorno a tutti,
ho un progetto del quale dovrei realizzare un'animazione per una presentazione.
Il problema è che quando vado in ambiente "studio di movimento" mi dice che una accoppiamento percorso o asola è in "libero" e se posiziono e animo dei motori ugualmente non si muove. Invece se metto le asole diverse da libero altre parti si muovono "aziono con altri motori " ma le parti con asola restano bloccate. Qualcuno sa dirmi cosa posso fare per cortesia.

Grazie:redface:
 

Max-C

Utente Standard
Professione: Mechanical designer
Software: Siemens NX - Solidworks - Inventor - Autocad
Regione: Piemonte-Provincia TO
#2
Buon giorno a tutti,
ho un progetto del quale dovrei realizzare un'animazione per una presentazione.
Il problema è che quando vado in ambiente "studio di movimento" mi dice che una accoppiamento percorso o asola è in "libero" e se posiziono e animo dei motori ugualmente non si muove. Invece se metto le asole diverse da libero altre parti si muovono "aziono con altri motori " ma le parti con asola restano bloccate. Qualcuno sa dirmi cosa posso fare per cortesia.

Grazie:redface:
Buon giorno,
mi ritrovo nuovamente con questo problema sovra spiegato. Qualcuno mi può aiutare?
Nessuno crea animazioni/ movimenti base/ analisi di movimento con progetti dove vi sono asole/accoppiamenti di percorso???
 

Tantocattivo

Utente Standard
Professione: Disegnatore progettista
Software: Autocad - Solidworks 2015/2016 -3ds Max-Photoshop-Sony Vegas
Regione: Sicilia
#3
Ciao, mi è capitato di fare piccole animazioni e per me sono state sempre problemi. Cose che a mano si muovevano bene, animate no!! prova a cambiare tipo di accoppiamento giusto per capire dove risiede il problema e caso mai se in unrenza trova un walkaroud.
 

luca1669

Utente Standard
Professione: progettista
Software: solidworks,solid edge, pro/e 2000i-wf4
Regione: emilia romagna
#4
In allegato trovi un file in cui ho fatto delle prove per capire meglio il problema (sono in SW14).
Settando l'ambiente "animazione" ho potuto muovere il componente ma il vincolo di percorso deve essere settato con guida a distanza o percentuale e deve essere lui la guida del meccanismo (cosa che può essere un grosso problema negli assiemi con più accoppiamento percorso e comunque non hai tutte le possibilità di guida di un motore tradizionale).
Settando l'ambiente "movimento di base" ho dovuto congelare tutti i vincoli asola o percorso e inserire un vincolo Contatto nell'ambiente di animazione. In questo modo tutto funziona ma i calcoli per ottenere l'animazione sono più complessi.
 

Allegati

Max-C

Utente Standard
Professione: Mechanical designer
Software: Siemens NX - Solidworks - Inventor - Autocad
Regione: Piemonte-Provincia TO
#5
Grazie per l'aiuto!
Il messaggio di errore che mi escono sono i seguenti.
Immagine.png

Io infatti in questo assieme ho più asole guidate in quanto muovendo un braccio, mediante un sistema di camme e asole vado a chiudere una sorta di pinza...
 

Max-C

Utente Standard
Professione: Mechanical designer
Software: Siemens NX - Solidworks - Inventor - Autocad
Regione: Piemonte-Provincia TO
#6
In allegato trovi un file in cui ho fatto delle prove per capire meglio il problema (sono in SW14).
Settando l'ambiente "animazione" ho potuto muovere il componente ma il vincolo di percorso deve essere settato con guida a distanza o percentuale e deve essere lui la guida del meccanismo (cosa che può essere un grosso problema negli assiemi con più accoppiamento percorso e comunque non hai tutte le possibilità di guida di un motore tradizionale).
Settando l'ambiente "movimento di base" ho dovuto congelare tutti i vincoli asola o percorso e inserire un vincolo Contatto nell'ambiente di animazione. In questo modo tutto funziona ma i calcoli per ottenere l'animazione sono più complessi.
Ora l'animazione funziona. Però non si riesce a fare lo studio di movimento base.... Non capisco se è un loro bug oppure (per un errore così ben descritto) è un grande limite di solidworks...
 

luca1669

Utente Standard
Professione: progettista
Software: solidworks,solid edge, pro/e 2000i-wf4
Regione: emilia romagna
#7
Per lo studio di base, come ti ho detto prima, ho dovuto sospendere i vincoli asola e percorso ed aggiungere il controllo dei contatti fra i corpi interessati: non faccio molte animazioni ma mi sembra che possa essere un limite di SW.
 

Max-C

Utente Standard
Professione: Mechanical designer
Software: Siemens NX - Solidworks - Inventor - Autocad
Regione: Piemonte-Provincia TO
#8
Per lo studio di base, come ti ho detto prima, ho dovuto sospendere i vincoli asola e percorso ed aggiungere il controllo dei contatti fra i corpi interessati: non faccio molte animazioni ma mi sembra che possa essere un limite di SW.
A quella di sospendere i vincoli asola e impostare i contatti tra perno e componente asolato ci ho pensato giusto nel weekend ora provo e vedrò che riesco a fare. Penso che attualmente sia l'unica soluzione.

Grazie mille per l'aiuto :finger:
 

Max-C

Utente Standard
Professione: Mechanical designer
Software: Siemens NX - Solidworks - Inventor - Autocad
Regione: Piemonte-Provincia TO
#9
Ho parlato con l'assistenza.
Dunque l'accoppiamento asola da quell'errore perchè è stato appena "inserito" nel cad e bisogna ancora ottimizzarlo quindi nel motion non la si può lasciare libera ma bisogna creare il contatto perno asola.
Vi dico un paio di consigli utili (base) che mi ha anche detto giusto per completezza.
a)Usare molti sottoassiemi fissi e il minor numero possibile quelli flessibili
b)i Non usare (o in numero minimo) vincoli avanzati/meccanici in quanto possono dare problemi (per esempio l'errore che recita circa: gli accoppiamenti avanzati, meccanici e ripetizioni di componenti possono far restituire errori di calcolo) e appesantiscono il calcolo. dell'assieme.
c) semplificare l'assieme quando si vuole fare un qualsiasi studio motion.

Infine mi ha confermato che anche Solidworks 2015 possiede questa "limitazione".

Preciso che non ho incortrato l'operatore più bravo del mondo.... Infatti anche lui era molto insicuro sui vari comandi motion...