Ancora Work Manager...

Shaba

Utente Standard
Professione: Disegnatore
Software: Me10 The Best! OSD 19, KeyCreator 13.5, SolidWorks 2017, NX
Regione: Lazio+Veneto
#1
Ho un problema... :confused:
Lavorando come esterno per una ditta mi collego con WM al loro database.
Loro giustamente mi mettono alcuni documenti in stato non VISIBILE (tipicamente gli assiemi) in quanto io sono un'esterno.
Il problema è che a volte io cerco uno codice e lo trovo, ma vedo che non ha documenti associati, e invece questi ci sono ma sono in stato non VISIBILE.
Non esiste una macro o un modo per fare una query dell'esistenza del documento? Non mi interessa scaricarlo, solo sapere della sua esistenza...
Non mi dite di chiedere a loro perchè mi dicono che non si puo' fare.. (e io ci credo poco)

GRAZIE! :cool:
 
Ultima modifica:

Shaba

Utente Standard
Professione: Disegnatore
Software: Me10 The Best! OSD 19, KeyCreator 13.5, SolidWorks 2017, NX
Regione: Lazio+Veneto
#3
Work Manager 15.00A
WM per gli amici
 

drnaik

Utente Junior
Professione: Cad manager
Software: Vari
Regione: Lombardia
#5
Scusa il ritardo...Non esiste un metodo standard per farlo perchè l'impostazione che ha il tuo cliente ti impedisce di vedere il modello ,(basterebbe che cambiasse il permesso da "NON VISIBILE" a "NON VISIBILE IL FILE").

In alternativa, il vecchio e buon WM ha una comoda riga di comando che permette di creare delle ricerche sql, bypassando i controlli WM.
Se mi mandi il nome della famiglia dei modelli ti mando una macro che con qualche limite fa quello che richiedi
 

Shaba

Utente Standard
Professione: Disegnatore
Software: Me10 The Best! OSD 19, KeyCreator 13.5, SolidWorks 2017, NX
Regione: Lazio+Veneto
#6
Grazie della risposta, ti ho mandato un PM
 
Ultima modifica:

Shaba

Utente Standard
Professione: Disegnatore
Software: Me10 The Best! OSD 19, KeyCreator 13.5, SolidWorks 2017, NX
Regione: Lazio+Veneto
#7
Ancora Work Manager...

Visto che sono collegato in remoto a WM la connessione mi cade spesso e mi ci vuole un sacco per riconnettermi.
Io continuo a pingare il server dal promp dei comandi ma vedo che a volte mi cade comunque la connessione..
La mia idea è: non si potrebbe fare una macro che WM lancia una volta al minuti per 'rinfrescare' il collegamento? Che non faccia nulla di importante ma solo tipo un PING verso il server.
Così da tenere 'vivo' il collegamento.

Grazie :cool: