Pagina 1 di 3 123 UltimaUltima
Risultati da 1 a 10 di 21
  1. #1
    Utente Junior
    Iscritto dal
    2015
    Messaggi
    76
    Professione
    progettazione
    Regione
    Veneto
    Software
    Inventor 2014, Autocad

    Predefinito Problemi formule parametri

    Buongiorno a tutti,
    ho riscontrato un problema nell'inserimento di formule nei parametri in Inventor 2014: praticamente (per spiegarla semplicemente), dovrei fare un cubo di acciaio partendo dal peso e quello che ho fatto è stato creare un parametro utente dove inserisco il valore del peso e un parametro "Lato" con formula "((Peso/7.85)^(1/3))", (dove 7.85 è il peso specifico dell'acciaio), mi trovo con risultato un valore x10! La stessa formula in excel dà risultato corretto, non so spiegarmi il motivo e a questo punto mi sorgono dubbi anche sulla correttezza dei calcoli di Inventor.
    Qualcuno sa spiegare questo errore?
    Grazie

  2. #2
    Utente Standard L'avatar di Catafratto
    Iscritto dal
    2011
    Messaggi
    809
    Professione
    Disegnatore/progettista
    Regione
    Veneto
    Software
    Inventor 2016

    Predefinito

    Attento alle unità di misura, prova con:

    ( Peso / 7.85 kg/dm^3 ) ^ ( 1 mm / 3 mm )

    specificando nella colonna Unità/tipo l'unità di misura del Peso (kg, suppongo); altrimenti possono venire pasticci come il tuo

    Edit: aggiunta

    Inventor usa come unità di misura interna il cm, forse quando non viene espressamente specificato ci sono problemi per quello...
    Spesso astuzia ed intelligenza sono molto più efficaci dell'ottusa forza bruta: ma non ho proprio tempo di cercare qualcun alltro...

  3. #3
    Utente Junior
    Iscritto dal
    2015
    Messaggi
    76
    Professione
    progettazione
    Regione
    Veneto
    Software
    Inventor 2014, Autocad

    Predefinito

    Citazione Originariamente Scritto da Catafratto Visualizza Messaggio
    Attento alle unità di misura, prova con:

    ( Peso / 7.85 kg/dm^3 ) ^ ( 1 mm / 3 mm )

    specificando nella colonna Unità/tipo l'unità di misura del Peso (kg, suppongo); altrimenti possono venire pasticci come il tuo

    Edit: aggiunta

    Inventor usa come unità di misura interna il cm, forse quando non viene espressamente specificato ci sono problemi per quello...
    ho messo il peso con unità "g" e lato con unità "mm" e formula "((peso/7.85 su)^(1 su /3 su))" e dà il valore corretto, la formula compare sempre in rosso e mi sa che non è un buon segnale.
    Su formule più complesse diventa ingestibile, forse conviene lavorare su un excel incorporato?

  4. #4
    Utente Standard L'avatar di Catafratto
    Iscritto dal
    2011
    Messaggi
    809
    Professione
    Disegnatore/progettista
    Regione
    Veneto
    Software
    Inventor 2016

    Predefinito

    Non è ingestibile, anzi, ti permette di mischiare unità di misura diverse ed avere risultati corretti. Se la formula è in rosso vuol dire che c'è un errore, se una formula che viene segnalata come incorretta genera un risultato incorretto direi che tutto torna. Se rileggi la tua formula vedi che hai indicato il tuo peso specifico come su, Senza Unità. Se rileggi la mia vedi che ho indicato l'unità di misura per esteso e così non ti da segnale rosso
    Spesso astuzia ed intelligenza sono molto più efficaci dell'ottusa forza bruta: ma non ho proprio tempo di cercare qualcun alltro...

  5. #5
    Utente Standard L'avatar di Catafratto
    Iscritto dal
    2011
    Messaggi
    809
    Professione
    Disegnatore/progettista
    Regione
    Veneto
    Software
    Inventor 2016

    Predefinito

    Tra l'altro, ora che ci penso, se usi g e mm, la densità non dovrebbe essere 0.00785? O mi sto perdendo da pollastro con i calcoli?
    Spesso astuzia ed intelligenza sono molto più efficaci dell'ottusa forza bruta: ma non ho proprio tempo di cercare qualcun alltro...

  6. #6
    Utente Senior L'avatar di Ilario
    Iscritto dal
    2007
    Messaggi
    2813
    Professione
    Disegnatore CAD
    Regione
    E. Romagna
    Software
    Inventor, AutoCAD

    Predefinito

    In aggiunta si può anche dire che se la formula è inserita nel parametro "lato", Inventor si aspetti una misura in lunghezza lineare, quindi la formula "((peso/7.85 su)^(1 su /3 su))" non è corretta in quanto restituisce una massa.
    Combatto tra passione ed obbligo....

  7. #7
    Utente Junior
    Iscritto dal
    2015
    Messaggi
    76
    Professione
    progettazione
    Regione
    Veneto
    Software
    Inventor 2014, Autocad

    Predefinito

    Citazione Originariamente Scritto da Catafratto Visualizza Messaggio
    Tra l'altro, ora che ci penso, se usi g e mm, la densità non dovrebbe essere 0.00785? O mi sto perdendo da pollastro con i calcoli?
    sì è vero......

  8. #8
    Utente Junior
    Iscritto dal
    2015
    Messaggi
    76
    Professione
    progettazione
    Regione
    Veneto
    Software
    Inventor 2014, Autocad

    Predefinito

    Citazione Originariamente Scritto da Ilario Visualizza Messaggio
    In aggiunta si può anche dire che se la formula è inserita nel parametro "lato", Inventor si aspetti una misura in lunghezza lineare, quindi la formula "((peso/7.85 su)^(1 su /3 su))" non è corretta in quanto restituisce una massa.
    restituisce il valore in mm ma la formula rimane comunque rossa, allego esempio
    File Allegati File Allegati

  9. #9
    Utente Senior L'avatar di Ilario
    Iscritto dal
    2007
    Messaggi
    2813
    Professione
    Disegnatore CAD
    Regione
    E. Romagna
    Software
    Inventor, AutoCAD

    Predefinito

    No, la restituisce in "g" e TU la forzi in "mm", infatti se la formula la scrivi così "( ( peso / 0,00785 g/mm^3 ) ^ ( 1 mm / 3 mm ) )" la formula magicamente diventa nera e non più rossa
    Combatto tra passione ed obbligo....

  10. #10
    Utente Junior
    Iscritto dal
    2015
    Messaggi
    76
    Professione
    progettazione
    Regione
    Veneto
    Software
    Inventor 2014, Autocad

    Predefinito

    è vero, funziona come dici,
    però non capisco perchè aggiunge i mm nell'elevazione a potenza visto che non ha unità di misura


  • Pagina 1 di 3 123 UltimaUltima

    Discussioni Simili

    1. parametri e formule
      Di cen82 nel forum Inventor
      Risposte: 2
      Ultimo Messaggio: 13-01-2012, 11: 23
    2. Problemi di scomparsa parametri,bolle e testo vario di assiemi nelle tavole
      Di verospetta82 nel forum Creo Parametric (ex Pro/E)
      Risposte: 0
      Ultimo Messaggio: 07-10-2009, 12: 42
    3. Star...problemi con parametri k-epsilon
      Di Enrico Pascolini nel forum CAE/FEM/CFD forum generale
      Risposte: 3
      Ultimo Messaggio: 08-08-2009, 23: 39
    4. Problemi con famiglie e parametri
      Di Zimus88 nel forum Revit
      Risposte: 2
      Ultimo Messaggio: 30-05-2009, 19: 04

    Segnalibri

    Segnalibri

    Permessi di Scrittura

    • Tu non puoi inviare nuove discussioni
    • Tu non puoi inviare risposte
    • Tu non puoi inviare allegati
    • Tu non puoi modificare i tuoi messaggi
    •  





    CAD3D.it - la community dei progettisti