Risultati da 1 a 6 di 6
  1. #1
    Utente poco attivo
    Iscritto dal
    2013
    Messaggi
    8
    Professione
    Ing.
    Regione
    Abruzzo
    Software
    CATIA V5 R19

    Predefinito Catia V5R19 SP2 W32: errore ScriptingERR_1004

    E' la prima volta che posto una nuova discussione dato che questo preziosissimo forum è un ottimo strumento per conoscere, approfondire argomenti, nonchè sbrogliare matasse inerenti a CATIA. Dopo aver sviluppato la mia abilità con i vari moduli ho deciso di buttarmi nello sviluppo di macro per automatizzare le mie procedure, specie nel caso di progettazione parametrica, di modifica di componenti CATPart. Per prova, con sommo stupore, dopo aver scaricato una macro proprio da questo forum per colorare le filettature nel 3D, al momento dell'esecuzione della macro è comparsa la seguente finestra di errore:

    CNEXT - CATScriptErrorMessages: ScriptingERR_1004
    Eseguire lo script:"Colorafiletti.CATScript"
    il motore di script CATScript non è installato correttamente.
    Installare il motore di script ed eseguire nuovamente lo script.

    Tale errore si è riproposto con tutti gli script che ho provato a compilare ed eseguire successivamente, siano essi in formato CATScript o MS VBScript. Nel secondo caso il messaggio di errore è più o meno simile:

    CNEXT - CATScriptErrorMessages: ScriptingERR_1004
    Eseguire lo script:"hellomsg.catvbs"
    il motore di script MS VBScript non è installato correttamente.
    Installare il motore di script ed eseguire nuovamente lo script.

    Convinto che si trattasse di un problema legato ad una errata installazione di CATIA ho avuto da miei colleghi altre versioni di CATIA ma questo problema non si è risolto. Ho cercato sia su questo forum che su forum non italiani potenziali casi simili al mio ma al momento pare sia l'unico ad avere questo tipo di problema.

    A questo punto chiedo lumi a voi utenti più esperti del forum ed alla vostra esperienza su come uscire da questo pantano.

    Il mio setup è il seguente:Microsoft Windows Vista Home Edition 6.0.6002 (WinVista Beta)- Intel Pentium III Xeon, 2000 MHz (2.5 x 800)-NVIDIA GeForce 9600M GT- RAM 4 GB- hd 232 GB, IDE.

    Vi ringrazio in anticipo per la vostra disponibilità!

  2. #2
    Moderatore L'avatar di ferrezio
    Iscritto dal
    2008
    Messaggi
    997
    Professione
    Progettista meccanico
    Regione
    Marche
    Software
    Catia, Think3

    Predefinito

    Aspetta altre risposte, ma secondo me devi istallare il SPk6 della R19, o meglio ancora cambiare sistema operativo, ma ti ripeto, aspetta altre risposte.

    Ciao

  3. #3
    Utente poco attivo
    Iscritto dal
    2013
    Messaggi
    8
    Professione
    Ing.
    Regione
    Abruzzo
    Software
    CATIA V5 R19

    Predefinito

    Citazione Originariamente Scritto da ferrezio Visualizza Messaggio
    Aspetta altre risposte, ma secondo me devi istallare il SPk6 della R19, o meglio ancora cambiare sistema operativo, ma ti ripeto, aspetta altre risposte.

    Ciao
    Grazie ferrezio per la dritta! Per ora ho fatto un upgrade al SPK9 come da te suggerito. Purtroppo il problema permane! A meno che non ci sia una fase che io ignori vi spiego cosa ho fatto sin dall'inizio:
    - installato CATIA;
    - installato SPK (2 o versioni successive);
    - creato file spinotto.CATPart (un particolare filettato);
    - scaricato lo script macro Colorafiletti.CATScript;
    - avvio Catia;
    - caricamento file prova spinotto.CATPart da me disegnato;
    - seleziono menu\strumenti\macro\macro;
    - seleziono la cartella dove ho salvato lo script precedentemente scaricato;
    - evidenzio il CATScript Colorafiletti.CATScript e seleziono Esegui;
    - viene prodotta la finestrella di cui sopra nel precedente post (allego screenshots).
    screen1.gifscreen2.gif
    Non so magari ci sono librerie da caricare o altre cose che ignoro.

    p.s.: provando le macro Excel sul file GSD_PointSplineLoftFromExcel.xls per caricare in CATIA dei punti di una curva parametrica, creata ad esempio con MatLab, non vi sono problemi. Magari è una info che può darvi spunto!

    Vi ringrazio ancora per l'attenzione e le risposte che arriveranno!

  4. #4
    Moderatore L'avatar di ferrezio
    Iscritto dal
    2008
    Messaggi
    997
    Professione
    Progettista meccanico
    Regione
    Marche
    Software
    Catia, Think3

    Predefinito

    Hai provato la macro su fori anzichè su perni?

    ciao

  5. #5
    Utente poco attivo
    Iscritto dal
    2013
    Messaggi
    8
    Professione
    Ing.
    Regione
    Abruzzo
    Software
    CATIA V5 R19

    Predefinito

    Citazione Originariamente Scritto da ferrezio Visualizza Messaggio
    Hai provato la macro su fori anzichè su perni?

    ciao
    Ti ringrazio ferrezio per i preziosi consigli ma credo sia più un problema di CATIA. In questo http://www-01.ibm.com/support/docvie...id=swg1HD57004 si parla del mio problema nelle R17 ed R18 fixed e che quindi nella R19 non dovrebbe sussistere ( io ho la R19 SP9, avendo fatto l'upgrade come da te suggerito). Allego minivideo sul classico esempio "hello CATIA". Come detto questo errore si ripresenta con tutti i tipi di script: siano essi CATScript o VBScript, siano essi vuoti siano essi aventi linee codice.


  6. #6
    Utente poco attivo
    Iscritto dal
    2013
    Messaggi
    8
    Professione
    Ing.
    Regione
    Abruzzo
    Software
    CATIA V5 R19

    Predefinito

    Forse ho tralasciato il particolare: sul mio laptop è installata la versione Express Edition di Visual Studio 2008! Un aggiornamento alla 2010 o versioni successive compatibili con Vista è auspicabile? Come sempre attendo lumi da utenti più addentrati di me in materia!


  • Discussioni Simili

    1. sheetmetal CATIA V5R19
      Di rai nel forum CATIA V5 vari
      Risposte: 1
      Ultimo Messaggio: 07-09-2012, 11: 08
    2. Problema installazione Catia v5r19 su Win7 x64 SP1
      Di mousetrap nel forum CATIA V5 Infrastructure
      Risposte: 0
      Ultimo Messaggio: 27-11-2011, 13: 12
    3. Errore nell'esportazione in stl Catia V5R19
      Di rafaingmec nel forum CATIA V5 CATPart
      Risposte: 5
      Ultimo Messaggio: 27-04-2011, 10: 11
    4. Catia V5r19- analisi dei nodi
      Di boris\ nel forum CAE/FEM/CFD forum generale
      Risposte: 8
      Ultimo Messaggio: 15-11-2010, 16: 12
    5. Catia V5R19 Import
      Di domever92 nel forum CATIA V5 vari
      Risposte: 3
      Ultimo Messaggio: 04-11-2010, 10: 35

    Segnalibri

    Segnalibri

    Permessi di Scrittura

    • Tu non puoi inviare nuove discussioni
    • Tu non puoi inviare risposte
    • Tu non puoi inviare allegati
    • Tu non puoi modificare i tuoi messaggi
    •  





    CAD3D.it - la community dei progettisti