Risultati da 1 a 10 di 10
  1. #1
    Moderatore L'avatar di stefano.garbin
    Iscritto dal
    2009
    Messaggi
    540
    Professione
    CAD-CAE-PLM manager
    Regione
    Veneto
    Software
    NX 11, teamcenter 10.1.7, Ansys 18.2, Recurdyn v8r5

    Predefinito Problema assembly constraints

    Carissimi,

    Io ed i miei colleghi ci scontriamo a volte con un problema che non riusciamo a capire e nemmeno a riprodurre.
    Accade infatti che aprendo alcuni assiemi (in cui tutti i pezzi all'interno sono completamente vincolati) si vedono tutte le parti "navigare nell'aria", come se i vincoli fossero falliti.
    Guardando però nell'assembly naviator non si vede alcun warning riguardante i vincoli!
    Poi magari dopo aver chiuso e riaperto l'assieme tutto torna ok.
    L'unico caso in cui abbiamo trovato una soluzione-motivazione era quello di un assieme con un componente che creava problemi. Se si sopprimeva tutto ritornava ok. Eliminando e riaggiungendo quel componente il problema si sistemava.
    Capita anche a voi qesto tipo di problemi?
    PS: dimenticavo, usiamo NX7.5.4.4 + TC8.3.0.3
    Stefano Garbin
    CAD & CAE manager
    www.campagnolo.com

  2. #2
    Utente Standard L'avatar di ceschi1959
    Iscritto dal
    2007
    Messaggi
    819
    Professione
    progettista
    Regione
    veneto
    Software
    UG 11 - NX11 TC10

    Predefinito

    Ciao,
    hai provato a caricare gli assiemi con l'opzione 'use partial loading' disattivata?
    Il partial loading infatti fa in modo che NX carichi i componenti con solo la geometria definita nel reference set. Può darsi che i vincoli siano su altra geometria, da qui il fallimento dei vincoli.

    p.s. buon lavoro

  3. #3
    Moderatore L'avatar di stefano.garbin
    Iscritto dal
    2009
    Messaggi
    540
    Professione
    CAD-CAE-PLM manager
    Regione
    Veneto
    Software
    NX 11, teamcenter 10.1.7, Ansys 18.2, Recurdyn v8r5

    Predefinito

    Grazie dell'utilissimo consiglio Cesare!
    Quando si ripresenterà il problema proverò a fare come dici!
    Stefano Garbin
    CAD & CAE manager
    www.campagnolo.com

  4. #4
    avalon3d
    Visitatore

    Predefinito

    Stefano, ti conviene centralizzare le load option, o dare uno std a tutti controllando anche le save option.

    Ciao

  5. #5
    Moderatore L'avatar di stefano.garbin
    Iscritto dal
    2009
    Messaggi
    540
    Professione
    CAD-CAE-PLM manager
    Regione
    Veneto
    Software
    NX 11, teamcenter 10.1.7, Ansys 18.2, Recurdyn v8r5

    Predefinito

    Tutta la gestione utenti è già centralizzata (con "nx75custom" di Rob Cohon) con load options e save options preimpostate.
    La cosa che mi incuriosisce è che questo comportamento si verifica con assiemi fatti, salvati e riaperti anche dallo stesso utente e da nessun altro.
    NB: ovviamente nessun messaggio strano nei log NX.
    Stefano Garbin
    CAD & CAE manager
    www.campagnolo.com

  6. #6
    avalon3d
    Visitatore

    Predefinito

    mh... a naso bisogna vedere come sono stati dati i vincoli. L'assembly constraint ha semplificato molto la vita, ma un utente abituato a utilizzare le mating condition se ne ricorda di episodi divertenti...

    tutti i solidi dell'assembly son parametrici e modellati con criterio?

    bhe, immagino che tu abbia già contollato il livello "user" di tutti gli utenti...

    prova a vedere che succede anche lanciando un part cleanup se dovesse ri-capitare.

    Ciao

  7. #7
    Utente Junior L'avatar di spantik
    Iscritto dal
    2011
    Messaggi
    20
    Professione
    Progettazione macchine duplicatrici
    Regione
    Veneto
    Software
    Unigraphics NX7.5

    Predefinito

    Ciao Avalon, scusate se devio un'attimo, approfitto dello spunto e se serve mi sposto: da NX5 alla NX6 non riesco a capire la nuova logica delle mating condition: come funziona? Se c'è già un post sapete indirizzarmi? Grazie e scusate l'intromissione.

  8. #8
    Utente Senior L'avatar di The_Matrix
    Iscritto dal
    2008
    Messaggi
    1797
    Professione
    Industry Leader - Automotive & Machinery
    Regione
    Mi piacerebbe lavorare in California... Invece sto in Piemonte. Pazienza...
    Software
    NX10/TC10/4GD

    Predefinito

    Citazione Originariamente Scritto da ceschi1959 Visualizza Messaggio
    Ciao,
    hai provato a caricare gli assiemi con l'opzione 'use partial loading' disattivata?
    Il partial loading infatti fa in modo che NX carichi i componenti con solo la geometria definita nel reference set. Può darsi che i vincoli siano su altra geometria, da qui il fallimento dei vincoli.

    p.s. buon lavoro
    In NX8.5 la logica del "Partial Loading" è cambiata, se non ricordo male adesso gli AC e i WL funzionano anche a PL attivato.
    (sono sicuro al 100% per i WL... sugli AC mi affido alla memoria)
    BG UgoverALL - Siemens PLM

  9. #9
    Utente Standard
    Iscritto dal
    2010
    Messaggi
    449
    Professione
    Progettista
    Regione
    Piemonte
    Software
    NX8 TC9

    Predefinito

    Citazione Originariamente Scritto da The_Matrix Visualizza Messaggio
    In NX8.5 la logica del "Partial Loading" è cambiata, se non ricordo male adesso gli AC e i WL funzionano anche a PL attivato.
    (sono sicuro al 100% per i WL... sugli AC mi affido alla memoria)
    NX8 e NX8.5 si comportano allo stesso modo, non è cambiato niente.
    Il 'Partial loading' lo puoi attivare già da NX8, ma ti consiglio di attivare anche 'Load Smart Lightweight Data' nei customer default.
    Grazie...

  10. #10
    Utente Senior L'avatar di The_Matrix
    Iscritto dal
    2008
    Messaggi
    1797
    Professione
    Industry Leader - Automotive & Machinery
    Regione
    Mi piacerebbe lavorare in California... Invece sto in Piemonte. Pazienza...
    Software
    NX10/TC10/4GD

    Predefinito

    Citazione Originariamente Scritto da Utente NX Visualizza Messaggio
    NX8 e NX8.5 si comportano allo stesso modo, non è cambiato niente.
    Il 'Partial loading' lo puoi attivare già da NX8, ma ti consiglio di attivare anche 'Load Smart Lightweight Data' nei customer default.
    Lo "Smart Lightweight" dovrebbe essere attivato di default per tutti (dopo il refile, s'intende, altrimenti non serve a nulla)... deve essereci davvero un buon motivo per non farlo.
    Oddio... non sapete quante aziende non usano i Lightweight...
    la butto li: il 90%.
    BG UgoverALL - Siemens PLM


  • Discussioni Simili

    1. Problema con Assembly
      Di morgan65 nel forum Solid Edge
      Risposte: 9
      Ultimo Messaggio: 01-09-2011, 12: 08
    2. Precisione negli Assembly constraints
      Di Utente NX nel forum NX (Unigraphics)
      Risposte: 13
      Ultimo Messaggio: 12-02-2011, 15: 04
    3. Problema con Assembly Features
      Di vapo nel forum CATIA V5 CATProduct
      Risposte: 5
      Ultimo Messaggio: 05-01-2010, 09: 13
    4. Matings e Constraints
      Di BCK nel forum NX (Unigraphics)
      Risposte: 1
      Ultimo Messaggio: 05-06-2008, 18: 50
    5. Problema relazioni in assembly
      Di luca1971 nel forum Solid Edge
      Risposte: 11
      Ultimo Messaggio: 19-02-2008, 13: 17

    Segnalibri

    Segnalibri

    Permessi di Scrittura

    • Tu non puoi inviare nuove discussioni
    • Tu non puoi inviare risposte
    • Tu non puoi inviare allegati
    • Tu non puoi modificare i tuoi messaggi
    •  





    CAD3D.it - la community dei progettisti