Risultati da 1 a 7 di 7
  1. #1
    Utente Standard L'avatar di PiegatoreSolidworks
    Iscritto dal
    2010
    Messaggi
    442
    Professione
    piegatore e disegnatore notturno...
    Regione
    Toscana
    Software
    Solidworks 2012 sp4

    Predefinito Problema salvataggio....

    Salve ragazzi voglio proporvi un mio problema: ho un insieme di particolari che voglio salvare in un altra cartella con gli stessi nomi o altri simili tipo con prefisso o suffisso... qual'è il problema? Che quando apro l'insieme nella nuova cartella e vado ad aprire il singolo particolare mi rimanda alla vecchia cartella! Allora ho fatto salva tutto con nuovi riferimenti e specificando la nuova cartella ma non sono riuscito a risolvere...Dove sto sbagliando? P.s. ho solidworks sp4.

    Grazie a tutti, a presto.

  2. #2
    Moderatore SWX, Navale L'avatar di sampom
    Iscritto dal
    2007
    Messaggi
    3690
    Professione
    Progettazione/Costruzione macchine e impianti
    Regione
    Piemonte (CN)
    Software
    SolidWorks 2015 SP5/2016 SP2, AutoCAD (poco)

    Predefinito

    Citazione Originariamente Scritto da PiegatoreSolidworks Visualizza Messaggio
    Salve ragazzi voglio proporvi un mio problema: ho un insieme di particolari che voglio salvare in un altra cartella con gli stessi nomi o altri simili tipo con prefisso o suffisso... qual'è il problema? Che quando apro l'insieme nella nuova cartella e vado ad aprire il singolo particolare mi rimanda alla vecchia cartella! Allora ho fatto salva tutto con nuovi riferimenti e specificando la nuova cartella ma non sono riuscito a risolvere...Dove sto sbagliando? P.s. ho solidworks sp4.

    Grazie a tutti, a presto.
    Ciao PS

    ..non ho capito bene che tecnica hai usato per copiare/salvare quei files..

    Hai provato facendo un Pack & Go dall'assieme? Puoi aggiungere pre o suffissi (o cambi i nomi uno ad uno se ne hai voglia), trasferisci tutto in una cartella creata appositamente ed i file richiamati dal "nuovo" assieme dovrebbe ripescarli tutti da lì senza problemi.

    Saluti
    Marco

  3. #3
    Utente Junior
    Iscritto dal
    2010
    Messaggi
    17
    Professione
    Studio ingegneria
    Regione
    Nordest
    Software
    AutoCad, SW

    Predefinito

    Citazione Originariamente Scritto da PiegatoreSolidworks Visualizza Messaggio
    Salve ragazzi voglio proporvi un mio problema: ho un insieme di particolari che voglio salvare in un altra cartella con gli stessi nomi o altri simili tipo con prefisso o suffisso... qual'è il problema? Che quando apro l'insieme nella nuova cartella e vado ad aprire il singolo particolare mi rimanda alla vecchia cartella! Allora ho fatto salva tutto con nuovi riferimenti e specificando la nuova cartella ma non sono riuscito a risolvere...Dove sto sbagliando? P.s. ho solidworks sp4.

    Grazie a tutti, a presto.

    Fai così:
    Salva con nome
    Clicca Riferimenti
    Cambia la vecchia cartella con quella nuova
    Eventualmente aggiungi dei Prefissi/Suffissi
    Clicca Salva tutto come copia
    Clicca "Salva tutto".

  4. #4
    Utente Standard L'avatar di PiegatoreSolidworks
    Iscritto dal
    2010
    Messaggi
    442
    Professione
    piegatore e disegnatore notturno...
    Regione
    Toscana
    Software
    Solidworks 2012 sp4

    Predefinito

    Citazione Originariamente Scritto da Syncmaster Visualizza Messaggio
    Fai così:
    Salva con nome
    Clicca Riferimenti
    Cambia la vecchia cartella con quella nuova
    Eventualmente aggiungi dei Prefissi/Suffissi
    Clicca Salva tutto come copia
    Clicca "Salva tutto".
    Si esatto anche io ho fatto cosi,cioè ho aperto l'assieme ed ho fatto come mi dici tu ma il risultato è che nella nuova cartella mi salva solo il file di insieme e non i singoli file dei particolari. Dove sbaglio? Quando poi apro il nuovo file di assieme nella nuova cartella e poi decido di aprire uno dei particolari in esso contenuto, solidworks mi apre si il file ma nella vecchia cartella...

    C'è qualcosa che non va...!

  5. #5
    Moderatore Solidworks L'avatar di Oldwarper
    Iscritto dal
    2007
    Messaggi
    2098
    Professione
    Progettista
    Regione
    Emilia Romagna
    Software
    Solidworks, Cimatron IT, Cimatron E, Rhino, AutoCAD, Logopress, Solidcam

    Predefinito

    Citazione Originariamente Scritto da PiegatoreSolidworks Visualizza Messaggio
    Salve ragazzi voglio proporvi un mio problema: ho un insieme di particolari che voglio salvare in un altra cartella con gli stessi nomi o altri simili tipo con prefisso o suffisso... qual'è il problema? Che quando apro l'insieme nella nuova cartella e vado ad aprire il singolo particolare mi rimanda alla vecchia cartella! Allora ho fatto salva tutto con nuovi riferimenti e specificando la nuova cartella ma non sono riuscito a risolvere...Dove sto sbagliando? P.s. ho solidworks sp4.

    Grazie a tutti, a presto.
    Allora, gia' ti dovrebbe essere chiaro che nei files di assieme e' inserita la posizione dei files che lo compongono. Se salvi come semplice copia, i riferimenti non verranno cambiati, perche' non sa che degli altri files ne esiste una copia corrispondente. Per questo MAI copiare tramite Esplora risorse se non per motivi di backup.

    Il Salva come copia in Solidworks non fa altro che salvare lo STESSO file con gli STESSI riferimenti con un altro nome, senza pero' aggiornare il riferimento nell'assieme padre.

    I modi corretti per copiare un assieme sono i seguenti;
    1) Utilizzare Solidworks Explorer e usare la funzione Pack and Go, in cui potrai aggiungere anche un prefisso/suffisso in automatico a tutti i file e/o rinominare le singole parti/assiemi copiate mantenendo aggiornati i riferimenti nei particolari/assiemi che fanno riferimento ad esso.
    2) In Esplora Risorse di Windows, tasto DX, menu Solidworks, Pack and Go, vedi sopra
    3) In Solidworks, File\Trova riferimenti\Copia file e ci si trova ancora in una schermata uguale a quella del Pack and Go.

    Il modo scorretto per copiare un assieme e' il seguente:
    1) copia tutto l'assieme e i particolari in un'altra cartella
    2) rinomina la cartella originale in modo da non farla piu' trovare dall'assieme
    3) apri l'assieme copiato e digli di volta in volta dove trovare i file che non trova piu' (molte volte una volta indicato il primo di una cartella poi trova gli altri)
    4) Rinomina la cartella originale al nome originale.

    In questo modo rischi che alcuni file non vengano sincronizzati, in quanto alcuni riferimenti di singole parti non vengono aggiornate.

    Capita inoltre che sia con pack and go che copia bruta alcuni files (parti derivate, offset di superfici nel contesto) vadano a pallino i riferimenti e il nuovo assieme peschi ancora nel vecchio. Per questo a volte faccio packandgo e rinomina di cartella, poi apro il nuovo assieme e lo ricostruisco, specie i sottoassiemi e le parti derivate, per scoprire se qualche riferimenti e' rimasto indietro.
    Saluti, Stefano.
    “Timeo Fenestras et dona ferentes”

  6. #6
    Utente Standard L'avatar di PiegatoreSolidworks
    Iscritto dal
    2010
    Messaggi
    442
    Professione
    piegatore e disegnatore notturno...
    Regione
    Toscana
    Software
    Solidworks 2012 sp4

    Predefinito

    Grazie ragazzi ho provato con pack & go ed ho risolto tutto. Mi pare che l'altra volta avevo fatto salva cambiando riferimenti ma forse ricordo male!

    Grazie ancora, a presto.

    Marco.

  7. #7
    Utente Junior
    Iscritto dal
    2010
    Messaggi
    17
    Professione
    Studio ingegneria
    Regione
    Nordest
    Software
    AutoCad, SW

    Predefinito

    Citazione Originariamente Scritto da PiegatoreSolidworks Visualizza Messaggio
    Grazie ragazzi ho provato con pack & go ed ho risolto tutto. Mi pare che l'altra volta avevo fatto salva cambiando riferimenti ma forse ricordo male!

    Grazie ancora, a presto.

    Marco.
    Infatti... avevi seguito quello che ti dicevo io più sopra.
    Il pack & go è stato inserito recentemente, fin prima si faceva tranquillamente con il Save as...


  • Discussioni Simili

    1. problema su salvataggio pdf
      Di bladina nel forum Solid Edge
      Risposte: 9
      Ultimo Messaggio: 11-02-2011, 12: 16
    2. problema con il salvataggio
      Di xwebx nel forum Creo Parametric - Configurazione
      Risposte: 10
      Ultimo Messaggio: 06-10-2009, 10: 35
    3. Problema salvataggio file Catia V5 r19 in V5r16
      Di CrazyLion nel forum CATIA V5 Infrastructure
      Risposte: 3
      Ultimo Messaggio: 17-06-2009, 20: 41
    4. Risposte: 6
      Ultimo Messaggio: 27-03-2009, 18: 19

    Segnalibri

    Segnalibri

    Permessi di Scrittura

    • Tu non puoi inviare nuove discussioni
    • Tu non puoi inviare risposte
    • Tu non puoi inviare allegati
    • Tu non puoi modificare i tuoi messaggi
    •  





    CAD3D.it - la community dei progettisti